Skip navigation

UNIX Issues

370 Views 7 Replies Latest reply: Feb 20, 2013 8:49 AM by dtrasatti RSS
dtrasatti Calculating status...
Currently Being Moderated
Feb 18, 2013 6:46 PM

For some reason, I can't ls /dev/cu.* in my terminal. I'm trying to verify my USB serial adapter is plugged in.

 

I went on my wife's laptop and had no problems with this command. This command won't even even call up anything on my terminal. I get "no such file or directory" is my terminal not in the correct directory or something? I just seems like my Unix paths are all screwed up. Is this possible?

  • Frank Caggiano Level 7 Level 7 (22,805 points)
    Currently Being Moderated
    Feb 19, 2013 7:07 PM (in response to dtrasatti)

    There should be a few thiings in /dev that start with cu.  What is your system and OS? Why are you trying to verify the USB serial adapter that way? Are you having problems?

     

    If you go to the Apple Menu and select About this Mac and then More Info and System Report and look in the hardware listings do you see the USB adapter?

  • MrHoffman Level 6 Level 6 (11,710 points)
    Currently Being Moderated
    Feb 20, 2013 8:05 AM (in response to dtrasatti)

    What is the vendor and model for the USB serial device you are connecting? 

     

    Based on that dump of the contents of /dev, the USB serial dongle you have is either not connected, or was not recognized by the software, or was not established as a traditional /dev device, or it's hiding being some other tty device name that might require checking the docs or polling the USB bus. 

     

    If you have Xcode and its ancillary Hardware and IO Tools kit installed on your OS X system, then Spotlight search for the USB Prober tool, and launch that and see what that tool finds on your I/O bus.  (Locally, I have it in Applications > Developer Tools > Hardware IO Tools directory.)

     

    Dongles based on the Prolific PL-2303 USB to Serial Bridge chip generally will show up as a device in /dev, and you can then reference those with cu or screen or tmux or whatever you choose to use for that.  The TrippLite Keyspan USB adapters do work this way, for instance; I've used several of those with serial connections.  (Though I should check the lastest OS X release; haven't tried that recently.)

  • Frank Caggiano Level 7 Level 7 (22,805 points)
    Currently Being Moderated
    Feb 20, 2013 8:11 AM (in response to dtrasatti)

    What hardwre are you on?

     

    Seems strange that the dvice shows up in System Profiler and not in /dev. Also a bit odd you don;t showh the cu devices for bluetooth. On the MBP I'm on now I get

    LIBMACLAPcaggiano:dev frank$ ls -l cu*

    crw-rw-rw-  1 root  wheel   33,   3 Feb 18 09:55 cu.Bluetooth-Modem

    crw-rw-rw-  1 root  wheel   33,   1 Feb 18 09:55 cu.Bluetooth-PDA-Sync

    LIBMACLAPcaggiano:dev frank$

     

    Pretty much the same on an iMac also. Should say I'm running 10.8.2. What version os your wife's laptop?

  • Frank Caggiano Level 7 Level 7 (22,805 points)
    Currently Being Moderated
    Feb 20, 2013 8:31 AM (in response to dtrasatti)

    Have you ever used the bluetooth on your computer? If not the devices may not show until you do. If you have a bluetooth device you can pair up as a test then you can see if the cu.Bluetooth devices get created.

     

    Have you tried connecting the adaptor on your wife's laptop to test if you can see it there?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.