Skip navigation

NVDA(OpenGL): Channel exception!

191498 Views 455 Replies Latest reply: Mar 22, 2014 1:04 AM by devil_in_disguise RSS
  • julien banchet2 Calculating status...
    Currently Being Moderated
    Sep 25, 2012 8:50 AM (in response to julien banchet2)

    Well... 10.8.1 is ultra stable, not a single glitch! (Since I already had Flash on 10.8.1 before and for long enough, I can say it's not Flash alone that did this...)

     

    Cloning almost done, will update using the combo to 10.8.2 tomorrow (keeping flash away to keep away a possible Flash/OSX combination problem, will try later with it)

     

    I read on some other non-disclosable places (mainly those talking about OSX on non-Apple computers) that the Combo update somehow fixes a few rigs, maybe i wouldn't be able to reproduce the issue... and honestly, I can't spend time on that anyways

  • LifeReceiver Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 9, 2012 8:30 AM (in response to Witch)

    I started getting this error when I upgraded from Lion to ML 10.8.2.  I've since done a fresh install of Lion where it persisted and am now running a fresh install of Snow Leopard.  It does occur in SL as well, but its not as frequent. I'm concerned Mountain Lion may have caused a hardware fault.  Otherwise it may be a firmware issue.

     

    I'm running a late 2008 model Macbook Pro with the nVidia 9400m and 9600m GT graphics card.

  • bulletproof. Calculating status...
    Currently Being Moderated
    Oct 9, 2012 2:07 PM (in response to LifeReceiver)

    I did a fresh install of ML and still get the error as well.  It is not as frequent after the latest ML patch, but I still get it.  Same behavior where the screensaver 3D graphics appears to trigger it.  I unlock my screen and can move the mouse but continue to see a frozen image of the screensaver and have no access to any part of the OS.  Hard shut down is only option and I lose all data that wasn't saved when it happens.

  • agrantfan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 15, 2012 4:16 AM (in response to bulletproof.)

    I had the same issue. It was related to my NVIDIA GeForce 7300 GT graphics card.

     

    My fix:

     

    I navigated to /System/Library/Extensions and moved all the files starting with NV and GeF to a backup directory on my desktop, then used Kext Wizard option "System/Library/Extensions" to Repair Permissions and to Rebuild Cache, then rebooted.

     

    The computer restarted with no gray screen and no more NVDA(OpenGL) log entries.

     

    I recommend that you try this.

  • StephenCCH Level 1 Level 1 (45 points)
    Currently Being Moderated
    Nov 15, 2012 10:58 AM (in response to agrantfan)

    One problem agrantfan, there is no visible files nor any hidden files in that folder, on any of my Macs (Nvidia or ATI). Zero.

  • dragonauta Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 19, 2013 11:17 PM (in response to Witch)

    I've had this issue for years and I barely took the time to look deep into it, and I'm also getting these log entries.

     

    What seems amazing is that it's clearly a GPU issue that Apple just decided to ignore instead of doing a recall like they should have, hoping that we'll shutup and go away.

     

    So right now, if I want this fixed by Apple, I have to pay a LOT of money. And if I want to sell it I practically have to give it away because since these iMacs (late 2006 in my case) have such a bad rep, nobody wants to buy them.

     

    Great going Apple. Thanks a lot.

  • madweasel Calculating status...
    Currently Being Moderated
    Feb 20, 2013 6:41 AM (in response to dragonauta)

    @dragonauta

     

    Just one question. Is your browser Firefox?

  • dragonauta Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 20, 2013 8:03 AM (in response to madweasel)

    I have this issue with all kinds of browsers and programs.

  • madweasel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 20, 2013 8:51 AM (in response to dragonauta)

    Ah. OK. I had this problem, which turned out to be a Flash and Firefox issue. I can reproduce it by simply having Firefox open on a site with Flash features.

     

    My GPU is a GeForce 7300. I keep away from Firefox and use Clickto Flash on Safari, and all is good.

  • Disputator Calculating status...
    Currently Being Moderated
    Mar 20, 2013 6:31 AM (in response to Witch)

    The problem still exists.

     

    I have an early 2008 MacBook Pro 4,1 with the NVIDIA GeForce 8600M GT 256 MB. It started about a week ago. I can't really reproduce it. Sometimes it doesn't happen for days and then I can't do anything because it keeps happening.

     

    Just happened again.

  • Simon69 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Mar 25, 2013 4:13 PM (in response to Disputator)

    I have a mid 2012 MacBook Pro Retina.

    My video freezes and the machine does not respond, however I can SSH into the machine and see:

    NVDA(OpenGL): Channel exception! exception type = 0x1f = Fifo: MMU Error


    The issue started the same evening that I installed 10.8.3 and updated VMware 5.0.3.

     

    Having read this thread, has anyone resolved the issue though replacement of hardware?

     

    Thanks

  • ffranke Calculating status...
    Currently Being Moderated
    Apr 2, 2013 12:50 AM (in response to Simon69)

    I have the exaxt same problem with my brand new 27 iMac. It's REALLY annoying. I brought it into the apple store, they tested it for two days but found nothing. At first I thought, it was of a faulty second monitor I attached, but even after removing it, the error reappears..........

  • Disputator Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 7, 2013 9:42 AM (in response to Witch)

    After 2 weeks, this morning it started again. This time my MacBook Pro seemed to recover as it didn't actually freeze after the first Channel exception. I was able to use it for another few minutes, then it froze. After rebooting a couple of times and sometimes the Mac even crashing during the startup I was using the Safe Boot mode for a couple of hours. No problems there, which makes me think it's software related. On the other hand, after leaving the book powered off and letting it cool down for an hour or so I could boot regularly again, which makes me feel it's actually hardware related.

     

    How annoying is that?!

  • James_22 Calculating status...
    Currently Being Moderated
    May 27, 2013 9:32 PM (in response to Witch)

    Try install Cuda 5.0.59 drivers and after check console.

     

    Cheers!

  • LifeReceiver Level 1 Level 1 (15 points)
    Currently Being Moderated
    Jun 12, 2013 9:31 AM (in response to James_22)

    I installed Cuda 5.0.59 and the problem is persisting. I'm afraid Mountain Lion might have caused a hardware fault in my video card. This happens on Mountaion Lion 10.8.4 with everything as up to date as I can make it.  It doesn't matter whether I keep it on integrated or discrete, it happens just as regularly.  I think our only hope right now is Mavericks, but I'm doubtful.

     

    So far my best solution is to run Snow Leopard.  It happens much more intermittently.  Rather than mulitple times a day it may happen only once or twice a week.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.