Skip navigation

iPhone5 issues with WPA2/AES Wifi

186028 Views 537 Replies Latest reply: Feb 22, 2014 7:49 AM by jenniefromnew york RSS
  • Geobound Calculating status...
    Currently Being Moderated
    Jan 31, 2013 12:01 PM (in response to C4RLOCO)

    Like many before me, my iPhone 5 will not hold the wifi connection.


    At first I thought the issue was with my ISP, so I had the tech come out and look at my system because I thought that all my devices were dropping their signals.


    He found no issues and asked me to monitor what the problems were, and with what devices.




    2 x iPhone 5

    2 x iPad (2nd and 3rd gen)

    1 x iMac (2013 model OSX)

    1 x Apple TV (3rd gen)

    1 x Dell laptop

    1 x Wii system

    1 x Xbox


    As it turns out all the devices, but the iPhone 5's hold their wifi connection.


    If I am within 5 feet of the wireless, then the conncection stays strong. If I go to the second floor of my home, then the signal drops and I go back to LTE.


    However the wifi signal still comes in strong, the phone just says unable to connect to wifi or wrong password.


    Now obviously the correct password is inputed as the phone works within a few feet of the wifi, but once getting outside of 10' radius the connection drops though the signal remains strong when I look it up in settings.


    I have tried with and without cases, I have tried hardware resets, and I have tried network resets, as well as the afore mentioned new wireless modem from my ISP.


    This is clearly a device issue, and I look forward to Apple's response in fixing this.

  • theblacksmoke Calculating status...
    Currently Being Moderated
    Feb 9, 2013 5:30 AM (in response to C4RLOCO)

    I keep on comparing my Iphone5 to the Iphone 4s and Ipod touch of my roommate. His Iphone and Ipod have full bar of the wifi connection indicator but my Iphone5 has 1 or 2 bars or more often does not have wifi indicator. We were 15feet away from the wifi machine, but my friend's gadgets has full connection, mine does not have, i need to change position to get one.. so how is that? does my iphone 5 broken?

  • CPC Level 1 Level 1 (90 points)
    Currently Being Moderated
    Feb 14, 2013 10:56 AM (in response to Geobound)

    Geobound - What type of wireless router(s) are you using?  There are a bunch of us discussing the same issue on another forum.


    This does seem to be an iOS issue, but we're not sure of the reason.  My WiFi is all Apple (Time Capsule with an Airport Express extending the network) and I have the same issue that you're describing.  All my other devices work, including other iOS devices that have not been updated.

  • CPC Level 1 Level 1 (90 points)
    Currently Being Moderated
    Feb 15, 2013 10:18 PM (in response to CPC)

    At the suggestion of others on a related thread, I have found that switching to wirelessN - 5.0 GHz mode gets my iPhone working again.  Signal strength goes back to "Excellent".  No distance problems, etc.  All other modes still create the problem.  The MAC address filtering and choice of password security do not impact at all.  Of course, I can't stay in that mode because then other devices I have do not work.



  • liambehar Calculating status...
    Currently Being Moderated
    Feb 16, 2013 3:18 AM (in response to Geobound)

    im having exactly the same problem. when i move 5 feet from the router i can still get clear signal but im unable to connect

  • slugworth1987 Calculating status...
    Currently Being Moderated
    Feb 16, 2013 4:03 AM (in response to C4RLOCO)

    I took my iPhone 5 to apple they replaced it now I have working wifi! Just stop moaning and take your device back!!

  • Alobar65 Calculating status...
    Currently Being Moderated
    Feb 20, 2013 4:36 PM (in response to C4RLOCO)

    It's not just a hardware issue: it's a hardware-software (iOS6.x) conflict. We have 3 iPOD/iPADs running iOS5.x that work fine with AES, but both iPhone4 and iPAD retina using iOS6.1 do not STAY connected with AES, but do fine with TKIP.


    The iPhone worked fine with iOS5.0 and only had problems with the switch to iOS6.


    It's much simpler for all involved, customers and Apple, to fix iOS6 than replace hardware, obviously. I'll bet they're working on it...

  • luckyinlife Calculating status...
    Currently Being Moderated
    Feb 20, 2013 5:32 PM (in response to C4RLOCO)

    No update. Just reporting AGAIN that since I updated to IOS6, I cannot keep a wifi connection at home on either the iphone 4s or iPad. The day and months before there were no problems what so ever............

  • Louie67 Calculating status...
    Currently Being Moderated
    Feb 22, 2013 10:47 AM (in response to C4RLOCO)

    I went to the Apple Store today with this problem and they exchanged the phone for me.  I was out of there with my new phone all set up in less than 15 minutes.

  • Nywharfrat Calculating status...
    Currently Being Moderated
    Feb 22, 2013 11:14 AM (in response to Louie67)

    DId they exchange with a brand new phone, or a "remanufactured" phone?  Unless you were in the 30 window from when u got it, it was most likely the latter.


    Which is bulls$it. This is an ~$800 device that is less than 5 months old.  Why should I accept a phone with used components???

  • rithusarang Calculating status...
    Currently Being Moderated
    Feb 22, 2013 12:12 PM (in response to C4RLOCO)

    does anyone have a problem with the speed of internet when connected to wifi?

  • Nywharfrat Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 22, 2013 12:40 PM (in response to rithusarang)

    rithusarang - absolutely


    Last night I was testing my newly replaced iPhone 5 and iPad 3rd gen on my home network. My provider is FIOS and I have 70mbps down and 25mbps up. I use the Actiontec cable modem/router MI424WR with WPA2 and factory defaults (802.11n)


    Using Speedtest:


    My wife's 4S got 22 down

    My iPhone 5 (6.1.2) got 12 down

    My iPad 3rd gen (6.1.2) got 2.6 down


    Laptop got 45 down

  • Richard Cranium Calculating status...
    Currently Being Moderated
    Feb 22, 2013 7:19 PM (in response to Louie67)

    Good for you.


    When I went to the Apple store, they flat-out told me that since I could connect to an unsecured network (which is all they have in the store) there was nothing wrong with the phone and they would not replace it or do anything else.


    Sure, they pulled out the crap of "well, update the firmware in your access point."  My access point is accessible by several Windows, Linux, and Android devices; if Apple doesn't care about about integrating with other ecosystems, fine, but that's not an inducement for me to buy their freaking products.


    This will be the last Apple product that I will ever buy (and my 2nd computer was an Apple II+ back in the day).

  • Louie67 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 22, 2013 8:23 PM (in response to Richard Cranium)

    I was worried they would not do anything either because I was able to connect to their network. But I told them I had stayed in three different hotels without being able to connect and even bought a new router thinking that may have been the problem. Their network was the first time in three weeks i had been able to connect to wifi. Luckily he didn't even hesitate at offering me an exchange. 


    I didn't think to ask if it was a refurbished phone or not until Nywharfrat brought it up. It looks new but I am not 100% sure that it is. I go oversee's a lot so it is more important to me to be able to access wifi than making sure it was brand new. It would be nice if they had a consistent policy on exchanging phones for customers.

  • CADbloke Calculating status...
    Currently Being Moderated
    Feb 26, 2013 3:02 AM (in response to Richard Cranium)

    Richard Cranium wrote:

    since I could connect to an unsecured network (which is all they have in the store) there was nothing wrong with the phone ...

    Tesltra tried that one on me too. After a 1-hour stand-off and me saying I would rather a full refund tha any of their mess-around they replaced it and the new phone works on WPA2 PSK AES. I have another iPhwn 5 with generally works fine but in-app downloads are abysmally slow. I've has sporadic but brief success messing with router MTU settings and resetting the network but it regresses in no time at all.


    iOS 6 is a dud. Apple hasn't jumped the shark, it has jumped into it.


    Never again.


More Like This

  • Retrieving data ...

Bookmarked By (29)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.