Skip navigation

iPhone 5: 6.1.2 breaks 5 GHz Wi-Fi connectivity

8338 Views 20 Replies Latest reply: Jun 15, 2013 11:19 AM by Atomnote RSS
  • Kykiskly Calculating status...
    Currently Being Moderated
    Feb 21, 2013 12:59 PM (in response to Thomas Cloer)

    6.1.3 is in the works already , though it doesnt mention anything about Wifi & Bt fixes.

     

     

    http://modmyi.com/content/10109-ios-6-1-3-beta-2-released-developers.html

  • A S M Calculating status...
    Currently Being Moderated
    Feb 22, 2013 3:21 PM (in response to Thomas Cloer)

    I had the same problems. Then I have configured new the wlan access on the iPhone. Important to select the correct security key (WAP2)!!!, select no static IP data. (sorry for my english)

  • JeaniceSkipper Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 25, 2013 6:13 PM (in response to Kykiskly)

    FIXED!!!!

     

    I have iPhone 4s running 6.1.2 Everything worked great before the lovely update. My wifi did the same thing that everyone else's seems to be doing. It would not recognize my home router.

     

    Evidently, in the update, Apple changed how the "Ask to Join Networks" button operates. Previously, I didn't have to have the button toggled to on, my phone would just automatically lock onto my router. I have fought and fought with this update. I have done several "network settings resets". I have even restored my phone twice. I have tried every crackpot, and not so crackpot, suggestion on these forums and NOTHING has worked. I could go to settings and connect to the router each time I used the phone, but it would only stay connected for a few minutes.

     

    Today, I toggled the "Ask to Join Networks" button to "on", then opened Safari. My phone then asked if I wanted to join the network, I responded with "join". My phone has been on wifi all day! I left home and came back several hours later, and FINALLY... my phone locks on automatically.

     

    Go to settings>, Wi-Fi>, toggle "Ask to Join Networks" button to "on". Then click on your router/network in the list.

     

    I realize that everyone's problems are not the exact problems I had, but maybe this will help some of you having problems.

     

    Good Luck!

  • rockmyplimsoul Level 5 Level 5 (5,370 points)

    Just curious, do you hide your router's SSID (network name)?  Also, do you use WEP security?  Either of these seem to be "resolved" by your suggestion, but you can also try broadcasting your SSID (hiding it doesn't do much of anything) and change to WPA2, which is much more secure than WEP.

  • JeaniceSkipper Level 1 Level 1 (0 points)

    In response to rockmyplimsoul:

     

    I do not have my network hidden. It is an open network that can be joined by anyone.

  • Atomnote Calculating status...

    Thanks! That worked for me as well. I'm using an Asus router and the 2Ghz network worked without issue. But it would not accept my password for the 5Gz network despite several attempts and "forgetting" the network all together.

     

    Toggling Ask to Join Networks to On and opening Safari, I re-entered my password and it worked!

     

    A little surprising that Apple would not catch a bug like this.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.