2 Replies Latest reply: Feb 23, 2013 12:09 PM by John Galt
hdroadking Level 1 Level 1 (0 points)

I have to select the default wifi each time i wake up the system at home. When it wakes up it does not wake up with the default selected. My default wifi is the only wifi used.

  • 1. Re: macbook pro will not wake up using default wifi
    dominic23 Level 7 Level 7 (20,930 points)

    Follow the troubleshooting steps in this article.

     

    http://support.apple.com/kb/HT4628?viewlocale=en_US&locale=en_US

  • 2. Re: macbook pro will not wake up using default wifi
    John Galt Level 8 Level 8 (36,360 points)

    Make sure you are using the most recent OS X update for the version you have. Run Software Update.

     

    Then, go to System Preferences > Network, select Wi-Fi, then the Advanced... button. If more than one network appears, delete those that you do not routinely want to use with the "–" (minus) button. Press OK, then Apply.

     

    If your MBP still does not automatically reconnect upon wake from sleep, delete the file

     

    /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist

     

    ... and restart your Mac.

     

    To find that file quickly, select the above path (triple-click the line), control-click to bring up the contextual menu, and select Services > Reveal. Drag that file to the Desktop, or directly to the Trash.

     

    This will completely erase your AirPort network preferences, requiring that you select your Wi-Fi network and authenticate again.

     

    If nothing else helps, try turning off Bluetooth if you do not require it. BT interference was suspected in preventing automatic reconnections to preferred networks upon wake from sleep, though this was never confirmed.