Skip navigation

Intel iMac FireWire 800 port not working

630 Views 3 Replies Latest reply: Feb 24, 2013 12:34 AM by barubin RSS
barubin Level 1 Level 1 (15 points)
Currently Being Moderated
Dec 31, 2012 4:20 PM

I have a 24" 2.8 GHz Intel Core 2 Duo iMac (Model ID iMac7,1). A few years ago I had the logic/mother board replaced when it had issues with the FW ports (the FW800 port rarely functioned) along with fan problems. After behaving itself with any and all FW peripherals since then, the FW800 port suddenly doesn't recognize anything. I've plugged the seemingly non functioning devices into the FW400 port and we're good to go at half speed but in the FW800 port the only sign of life is it is providing power. Nobody in the family uses FW devices besides myself and it worked fine (booted off an external SSD with numerous ports the last time I tried it, about two weeks ago. I don't remember any Apple updates, only updates to applications and virus definitions.

 

Any ideas/suggestions, besides getting a new iMac or accepting FW400 speeds?

 

TIA.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.