Skip navigation

Black screen during Windows install

3762 Views 13 Replies Latest reply: Feb 24, 2013 2:45 PM by hatstis RSS
hatstis Calculating status...
Currently Being Moderated
Jan 9, 2013 12:14 AM

Hello,

 

I have a late 2012 27-inch iMac with the GeForce 680MX 2GB graphics card. I'm trying to install Windows 7 or Windows 8 using Boot Camp, but neither works.

 

In either case, I can use the Boot Camp Assistant to create a bootable USB install disk, download the latest Windows support software from Apple, and partition the drive to allocate space for the Windows installation.

 

As soon as I partition the drive, the iMac restarts and tries to boot into Windows. But the only thing I ever see is a black screen (no blinking cursor), no matter how long I wait.

 

This seems like the exact same issue that plagued the late-2009/mid-2010 iMacs,

http://support.apple.com/kb/TS3173

In other words, it looks like the drivers included with the default Windows install disk don't work on the late 2012 iMac, at least not when configured with the 680MX. 

 

Since this looks like the old problem but Apple doesn't appear to have provided drivers for the new iMac yet (the older iMacs above used ATI graphics, not NVIDIA), I tried to add the latest NVIDIA notebook graphics card drivers to the Windows install disk using the directions here,

http://superuser.com/questions/501812/corrupt-graphics-during-windows-8-installa tion

In particular, I used these drivers,

http://www.geforce.com/drivers/results/55125

They're not explicitly supporting the 680MX (I couldn't find any drivers for it in NVIDIA's website) but they do support the 680M and a whole slew of other cards. Thought it was worth a try.

 

Anyway, that didn't do the trick. Still the black screen for me.

 

Any ideas? Have others had this issue with the new iMacs?

 

Thanks

iMac, OS X Mountain Lion (10.8.2), iMac 27 late 2012 GeForce 680MX 2GB
  • storyway Calculating status...
    Currently Being Moderated
    Jan 9, 2013 4:49 AM (in response to hatstis)

    Switch the computer off and start again, holding the alt-key, than you may choose the boot partition. this worked for me.

  • Ratz1 Calculating status...
    Currently Being Moderated
    Jan 13, 2013 5:57 PM (in response to hatstis)

    I'm running into this same problem, got the 680MX 2GB, and a 1TB Fusion, I've been scouring the internet and can't find anything....

    Anyone found a solution yet?

  • BruinBecca Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 15, 2013 4:06 AM (in response to hatstis)

    I am having the same problem. 

  • BruinBecca Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 15, 2013 11:44 AM (in response to BruinBecca)

    And go figure - I called AppleCare and did the exact same process following the Bootcamp Assistant as it's supposed to work and now it worked fine. 

  • BruinBecca Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 15, 2013 12:33 PM (in response to hatstis)

    I have a new late 2012 iMac 21.5 with a fusion drive. What I did was to erase the partition that didn't work last night and start fresh. The representative did have me unplug the power cord in the back and plug it back in after 60 seconds now that I think of it. I then went through bootcamp assistant and created a partition and it installed fine.  I have a SuperDrive and copy of Win 7 64 bit DVD 1 pack. I'm still working on getting drivers to install so my mouse and whatnot will work. My Internet is out but if I can't figure it out I will be calling back. Hope this helps!

  • BruinBecca Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 15, 2013 2:16 PM (in response to BruinBecca)

    Okay. It was a success! For the drivers, following my install I used bootcamp assistant and burned a copy of the downloaded drivers onto a CD. I switch to windows and installed them from there.

  • Dremondo Calculating status...
    Currently Being Moderated
    Feb 17, 2013 3:01 PM (in response to hatstis)

    Any luck yet hatstis? I'm having the same problem... Can someone pleeeeas talk me through it like a baby monkey...?

  • stevec1234 Calculating status...
    Currently Being Moderated
    Feb 24, 2013 1:58 PM (in response to hatstis)

    I've made the USB drive following the bootcamp prompts, but when I reboot, I get a "no bootable device" error. I'm not sure if I should be booting from the windows partition that bootcamp creates or from the USB stick.

     

    The USB stick does not show it as a startup device disk in preference, nor as a boot option using the 'option' key at boot time (not suprising now I think about it, its a FAT32 volume).

     

    I've tried windows 7 and 8, same deal. I would like to remove the bootcamp partition and start again, but bootcamp does not seem able to remove the thing.

     

    I would love to get this thing working.

  • stevec1234 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 24, 2013 2:33 PM (in response to stevec1234)

    By the way, when you started over with the bootcamp install, how did you remove the bootcamp partition? I have tried to remove it with the bootcamp assistant (ticked the "Remove Windows 7 or later version" tick box), no go, just get a blue and white striped status bar. Tried in Disk Utility, no go.

     

    I have a fusion drive on a late 2012 27" iMac. Bootcamp is proving to be an absolute pain, can't seem to get anything to work.

     

    Any advice on removing the dud bootcamp partition welcome.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.