Skip navigation

iCal will not open and crashes.

501 Views 3 Replies Latest reply: Feb 26, 2013 6:29 PM by John Maisey RSS
Jae9c Calculating status...
Currently Being Moderated
Feb 24, 2013 5:30 PM

Process:         iCal [7550]

Path:            /Applications/iCal.app/Contents/MacOS/iCal

Identifier:      com.apple.iCal

Version:         5.0.3 (1605.4)

Build Info:      iCal-1605004000000000~3

Code Type:       X86-64 (Native)

Parent Process:  launchd [143]

 

 

Date/Time:       2013-02-24 20:23:02.141 -0500

OS Version:      Mac OS X 10.7.5 (11G63)

Report Version:  9

 

 

Interval Since Last Report:          595330 sec

Crashes Since Last Report:           5

Per-App Crashes Since Last Report:   4

Anonymous UUID:                      DFC890C7-FBFD-42AB-A539-B0C49A3C1498

 

 

Crashed Thread:  0

 

 

Exception Type:  EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

 

 

Application Specific Information:

dyld: launch, loading dependent libraries

 

 

Dyld Error Message:

  Library not loaded: /System/Library/PrivateFrameworks/GeoKit.framework/Versions/A/GeoKit

  Referenced from: /Applications/iCal.app/Contents/MacOS/iCal

  Reason: image not found

 

 

Binary Images:

       0x10e23f000 -        0x10e55bff7  com.apple.iCal (5.0.3 - 1605.4) <7B576EF5-9039-3B1F-897A-0033233FC9E1> /Applications/iCal.app/Contents/MacOS/iCal

    0x7fff6de3f000 -     0x7fff6de73baf  dyld (195.6 - ???) <C58DAD8A-4B00-3676-8637-93D6FDE73147> /usr/lib/dyld

 

 

Model: MacBookPro5,5, BootROM MBP55.00AC.B03, 2 processors, Intel Core 2 Duo, 2.26 GHz, 8 GB, SMC 1.47f2

Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB

Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x0198, 0x393930353432382D3030352E4130324C4620

Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x0198, 0x393930353432382D3030352E4130324C4620

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.106.198.19.22)

Bluetooth: Version 4.0.8f17, 2 service, 11 devices, 1 incoming serial ports

Network Service: AirPort, AirPort, en1

Serial ATA Device: Hitachi HTS545016B9SA02, 160.04 GB

Serial ATA Device: HL-DT-ST DVDRW  GS23N

USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0x24400000 / 2

USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0x26500000 / 2

USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0236, 0x04600000 / 3

USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x04500000 / 2

USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06100000 / 2

USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8213, 0x06110000 / 4

MacBook Pro, Mac OS X (10.7.5), Mid 2009
  • John Maisey Level 5 Level 5 (6,870 points)
    Currently Being Moderated
    Feb 25, 2013 1:10 PM (in response to Jae9c)

    Hi,

     

    iCal is not finding the "GeoKit.framework" on your computer's system.  Perhaps it has been removed or there is some other issue with your computer.

     

    Have you tried rebooting the computer?

     

    If that does not help, you could try making a new user account on the computer and opening iCal there. Can you open it on a fresh user account?

     

    Best wishes

    John M

  • John Maisey Level 5 Level 5 (6,870 points)
    Currently Being Moderated
    Feb 26, 2013 6:29 PM (in response to Jae9c)

    Alex,

     

    The frameworks iCal uses come with the OS. I have not personally heard of the GeoKit.framework before.  I suggest you could try reinstalling the 10.7.5 Lion update. Or if that does not help then use the Lion recovery partition.

     

    John M

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.