3 Replies Latest reply: Feb 25, 2013 2:21 PM by Eric Root
burner_jenny Level 1 Level 1 (0 points)

I have a Macbook Pro from mid 2007 and I have 10.6.8. When I try to purchase mountain lion all I'm told is that it isn't compatable with my machine. How do I trouble shoot this issue? Any pointers?


MacBook Pro, Mac OS X (10.6.8)