Skip navigation

WD External drive won't mount

18733 Views 35 Replies Latest reply: Apr 3, 2014 7:25 PM by mdazlan76 RSS
1 2 3 Previous Next
medinaray Calculating status...
Currently Being Moderated
Feb 22, 2013 12:22 PM

Hello everyone! I haven't been here in a while because I just haven't had any Mac issues. Now I do.

 

I have a 1 TB WD external HD that won't mount. I connect it via firewire to an Old G4 Sawtooth running OS 10.5.8. My mac sees the drive, it just won't mount. I've also tried to mount it via USB, but again, my system sees the drive, but won't mount it. I inadvertantly disconnected the firewire cable, which I didn't realize for several hours. I reattached the cable, tried to mount it, and nothing. I ran disc repairs, and Disc Utility actually told me the drive was successfully repaired. Again I tried to remount it, but nothing. I repaired permissions, and this didn't work. I've tried different cables, and this doesn't work.

 

I don't have another Mac to connect it to, so I don't know if this would work. Here's where things get a little wierd, but interesting. I connected it to my PC laptop, and it mounted. Now, this is a drive that was formatted Mac OS Extended (Journaled) on my G4, so I have to use Mac Drive so my PC will recognize and mount The Drive. So My PC sees The Drive as Mac OS Extended, and mounts it. All files are in tact, and the drive runs normally. This is a music drive and it plays normally on my PC. Meanwhile, if I try connecting it back on My Mac, the name of The Drive randomly changes from 931.5 GB WD to 931.5 GB WD My Media Book. I believe My Media Book is the factory name of The Drive before OS formatting. The Volume name remains the same on my G4 each time I've tried to mount it.

 

I do have another identical drive that mounts from all the bus ports on my G4. Any ideas here? Can I get my Drive to begin mounting on my G4 again? Any and all answers are appreciated.

Sawtooth G4; 1.8 GHz Dual 7447A; Radeon 9800/128MB; 2GB Ram, Mac OS X (10.4.11), Seagate 200 & 500GB HD; WD 120GB HD; Lacie DVD±RW; 550 Watt PSU
  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Feb 22, 2013 2:54 PM (in response to medinaray)

    Hi, I assume you were trying to mount it in Disk Utility by highlighting it & clicking on the Mount icon above?

     

    In Finder's Menu, select Go menu>Go to Folder, and go to "/volumes". (no quotes)

     

    Volumes is where an alias to your hard drive ("/" at boot) is placed at startup, and where all the "mount points" for auxiliary drives are created for you to access them. This folder is normally hidden from view.

     

    Does it show there?

  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Feb 22, 2013 9:00 PM (in response to medinaray)

    I don't think you can do that, & my guess is the PC changed it somehow.

     

    Might try to mount it in Terminal, like the last post here...

     

    https://discussions.apple.com/thread/1779529?start=0&tstart=0

  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Feb 23, 2013 10:38 AM (in response to medinaray)

    I'll try to help with terminal if you need it when you get back.

  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Feb 24, 2013 1:16 PM (in response to medinaray)

    As I understand it there are two forms...

     

    diskutil mount disk0s1

     

    diskutil mountDisk "DriveName"

  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Feb 25, 2013 12:25 AM (in response to medinaray)

    Good work!

     

    Open Terminal and type these commands carefully with the spaces & change 320GB HD to the name of your drive.

     

    sudo chflags 0 "/volumes/320GB HD"

    sudo chown root "/volumes/320GB HD"

    sudo chmod 1775 "/volumes/320GB HD"

    sudo -k

  • BDAqua Level 10 Level 10 (114,670 points)
    Currently Being Moderated
    Feb 25, 2013 12:19 PM (in response to medinaray)

    Hmmm,

     

    In Terminal, what does this command show?

     

    diskutil list

    /dev/disk0

       #:                   type name               size      identifier

       0: Apple_partition_scheme                    *596.2 GB disk0

       1:    Apple_partition_map                    31.5 KB   disk0s1

       2:             Apple_Boot                    128.0 MB  disk0s2

       3:             Apple_RAID                    596.0 GB  disk0s3

    /dev/disk1

       #:                   type name               size      identifier

       0: Apple_partition_scheme                    *596.2 GB disk1

       1:    Apple_partition_map                    31.5 KB   disk1s1

       2:             Apple_Boot                    128.0 MB  disk1s2

       3:             Apple_RAID                    596.0 GB  disk1s3

    /dev/disk2

       #:                   type name               size      identifier

       0:              Apple_HFS CVBRaid0           *1.2 TB   disk2

    /dev/disk3

       #:                   type name               size      identifier

       0: Apple_partition_scheme                    *465.8 GB disk3

       1:    Apple_partition_map                    31.5 KB   disk3s1

       2:         Apple_Driver43                    28.0 KB   disk3s2

       3:         Apple_Driver43                    28.0 KB   disk3s3

       4:       Apple_Driver_ATA                    28.0 KB   disk3s4

       5:       Apple_Driver_ATA                    28.0 KB   disk3s5

       6:         Apple_FWDriver                    256.0 KB  disk3s6

       7:     Apple_Driver_IOKit                    256.0 KB  disk3s7

       8:          Apple_Patches                    256.0 KB  disk3s8

       9:              Apple_HFS Leo                167.3 GB  disk3s10

      10:              Apple_HFS Mac OS X Install DVD 9.0 GB    disk3s12

      11:              Apple_HFS LeoUPdate          167.3 GB  disk3s14

      12:              Apple_HFS TigerOS9           121.7 GB  disk3s16

    /dev/disk4

       #:                   type name               size      identifier

       0:    CD_partition_scheme                    *754.2 MB disk4

       1:    Apple_partition_map                    31.5 KB   disk4s1s1

       2: Apple_partition_scheme                    656.7 MB  disk4s1

       3:              Apple_HFS Civilization III   632.6 MB  disk4s1s2

    /dev/disk5

       #:                   type name               size      identifier

       0: Apple_partition_scheme                    *40.0 MB  disk5

       1:    Apple_partition_map                    31.5 KB   disk5s1

       2:              Apple_HFS Chicken of the VNC 40.0 MB   disk5s2

     

    http://superuser.com/questions/429058/how-can-i-get-the-mount-path-of-a-usb-devi ce-on-osx

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.