Skip navigation

Can't remove bootcamp partition

1664 Views 11 Replies Latest reply: Feb 28, 2013 5:33 PM by Csound1 RSS
stevec1234 Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 24, 2013 5:27 PM

Hi all, I have a late 2012 27 inch iMac with a fusion drive. I have attempted to bootcamp Windows 8 following various posts here and elsewhere. Short story - its failed on each and every attempt, and now it seems as though I am stuck with a dud bootcamp partition.


I created a windows install USB for windows 8 and later windows 7 and created a bootcamp partition with the bootcamp assistant. The USB key was created without error. But when the system rebooted to start the Windows installation I got a message saying there was 'no boot device'. I tried various fixes including using rEFIt and creating the USB stick using microsoft's tool. Nothing has worked.


I would like to delete the windows partation and start again (don't know if this will make a difference, nothing has worked so far). I have tried to remove it with the bootcamp assistant (ticked the "Remove Windows 7 or later version" tick box), no go, just get a blue and white striped status bar. Tried in Disk Utility, also no go.


Just don't get why bootcamp installation is so painful and time consuming. Any advice on removing the dud bootcamp partition welcome. Any tips about which USB devices are suitable for Bootcamp would also be appreciated.



iMac, OS X Mountain Lion (10.8.2)


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.