Skip navigation

Where can I get a version of Aperture compatible with Snow Leopard?

416 Views 6 Replies Latest reply: Feb 25, 2013 2:19 PM by Phil_Jackie RSS Branched to a new discussion.
Phil_Jackie Calculating status...
Currently Being Moderated
Feb 22, 2013 7:25 AM

I have Snow Leopard (10.6) on my iMAC and I did not upgrade to Lion as it is good enough for what I do with my iMAC.

Unfortunately, the Aperture version available in the App Store recommends MAC OS 1.7 or later.

 

Is there a previous version of Aperture, which is compatible with Snow Leopard (10.6), still available?

If so, where can I get it?

 

Thank you in advance to the Apple community.

 

Philippe

iMac, Mac OS X (10.6.8)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.