6 Replies Latest reply: Feb 26, 2013 7:10 AM by enriquemennedez
enriquemennedez Level 1 Level 1 (0 points)

I clicked on a document you wish to open in Open Office.  I get Info for that document. In the box that says "Open With", select Open Office.  I click on the window which gives me three options.  First, is TextEdit which is the current default app.  (Open office and Preview are the other options.)   I click on Open Office and TextEdit comes up.  As an experiment, I click on Preview and Preview was ably chosen.  How can I make Open Office for all word douments?  I appreciate your help in advance.

ITunes, Mac OS X (10.7)
  • 1. Re: Changing default app
    ds store Level 7 Level 7 (30,305 points)

    If you want to open a single instance of Text document with OpenOffice, right click and open with OpenOffice.


    If you want to have OpenOffice open just that file with OpenOffice all the time, then Get info and open with OpenOffice and close. Double click the file.


    If you want to have OpenOffice open all Text documents with that same format (like .txt, .rtf, .doc etc.) extension then click on a file, then Get Info then Open with: OpenOffice and then click Change All before closing the Get info window.



    BTW, LibreOffice is the new fork of OpenOffice since Oracle bought Sun and is really not paying much attention to it.


    So LibreOffice is what you should be using now and it will open your OpenOffice files just the same.

  • 2. Re: Changing default app
    enriquemennedez Level 1 Level 1 (0 points)

    As far as opening all Text documents, the Info Window does not allow me to make the choice of Open office. When I click on Open Office, text edit is what comes up.  It won't allow mw to change it.


    I am running Mountain Lion 10.8.2 and am haing trouble sownloading LibreOffice.


    I get the following error message:

    "LibreOffice.app" can't be opened because it is from an unidentified developer.

    Your security preferences allow installation of only apps from the MAc App Store and identified developers.

    Safari downloaded this file today at 8:18AM from www.libreoffice.org.


    I appreciate you help.

  • 3. Re: Changing default app
    VikingOSX Level 5 Level 5 (5,490 points)

    Control-click on the LibreOffice 4 icon in /Applications. Then select Open to override OS X gatekeeper. You only need to do this once, and future launches of LibreOffice will be normal.

  • 4. Re: Changing default app
    enriquemennedez Level 1 Level 1 (0 points)

    I tried it and I am still getting the same error message?

  • 5. Re: Changing default app
    macjack Level 9 Level 9 (50,510 points)

    What happens when you go to System Preferences > Security & Privacy > and "allow apps downloaded from anywhere"?

  • 6. Re: Changing default app
    enriquemennedez Level 1 Level 1 (0 points)

    That solved my problem.  Thanks a buch!!!