Skip navigation

Conflict with Thunderbolt/Mini DisplayPort and Sony Bravia Sync

4108 Views 23 Replies Latest reply: Mar 26, 2013 2:39 AM by Wombert RSS
1 2 Previous Next
Sorking Calculating status...
Currently Being Moderated
May 27, 2011 5:16 AM

I'm UK-based and I've just bought a new iMac and it's thrown up a bizarre conflict/compatibility problem with my TV.

 

My 2007 iMac was hooked up to an HDMI input on my Sony Bravia TV (KDL-40Z4500) and used it as a 'second' display, mainly so I could watch the BBC iPlayer and other video, plus iTunes/Front Row. It was connected with a "Mini DVI to HDMI female & DVI-D female Splitter" adapter - using HDMI to get to the TV and a standard 3.5 audio jack to connect the audio (headphone out on the iMac to an input on the TV.

 

Aside from plugging and unplugging the audio, it worked a treat.

 

This week I set up my new iMac, which of course doesn't have a Mini DVI port. So the old adapter is no good, and I have now bought two new ones - Thunderbolt (actually Mini DisplayPort) to HDMI - and tried them both. And they both create the same problem.

 

The picture reaches the TV and can be watched. That much is fine. I no longer have to mess about with an audio jack, either - just change the Audio Out setting in the Volume menu bar option.

 

But: as soon as the connection is made - iMac to TV via Thunderbolt/HDMI - a conflict occurs with the TV set-up. I have a Sony Home Theatre System for surround sound - HT-IS100 - which is connected to both a DVD recorder and Blue-ray player. (Again, both Sony.) With all these devices being the same brand I can use Bravia Sync. The main benefit being that when I press play on a player, of change a TV channel, both the screen and the system audio switch to that device. No messing around with the remote changing the inputs on both each time you switch.

 

That is, until you plug in the Mac connection.

 

This never happened with the old set-up, the old Mac, but now when the connection is made the TV 'forgets' the surround system. The Bravia Sync for it is cancelled and playing anything requires a manual change of channel. (For picture only. The Surround system DOES change over to the playing DVD, say; but the picture doesn't. Though when I change TV channel it doesn't communicate that change to the theatre system, so the picture changes but the sound stays wherever it was.)

 

According to the menus on the Bravia, it can no longer 'see' the surround system - it only sees the Blu-ray and DVD devices (which are only connected THROUGH that system - all into the theatre device and then back to the TV). The first thing to happen is that the TV switches back to internal sound, its built-in speakers; to get surround back I have to go into the menus and manually change it back.

 

What seems to be happening is that the connection to the Mac is bringing data to the TV that is overriding the Bravia Sync system's awareness of its home theatre connection. I have to disconnect the Mac HDMI and switch off/on to get the TV and system back to normal. (That's with the second adapter. With the first, the change was permanent enough that I had to do a factory reset each time!)

 

Given that the TV system is unchanged, and there's no setting anywhere to 'ignore/override' or any other such thing that I can see, I'm pretty sure this comes down to something on the iMac/Thunderbolt/Mini DisplayPort adapter side. The obvious thought, to me at least, being that the inclusion of sound in this set-up, via the HDMI, might be relevant.

 

As a side note: It's impossible to change the display settings - including sound output - until the second screen is connected to the Mac. This makes total sense, but means I can't change any audio out settings until the connection is made...by which time the Bravia Sync is already 'broken'. Though there isn't much to change, so far as I can see when I am hooked up, that would affect the issue.

 

I know this is a messy, cross-system problem, but any advice/solutions would be hugely appreciated.

iMac, Mac OS X (10.6.7)
  • rbilabronze Calculating status...

    Hi Sorking.  I am not sure if you are still having the issue. But, I have the exact same issue.  I actually don't think it is data coming from the Thunderbolt port.  I think it is somehow coming from the mini display to hdmi adaptor.  If I plug the adapter into the HDMI cable (before even connecting it to the macbook pro) it switches my audio to the TV (and jams up my sony CT-150 soundbar so inputs can't change, etc.).  When I unplug the adapter sometimes it self corrects (and other times I have to manually change the audio output in the Sony TV menu).

     

    Definitely some conflict between that adapter and BraviaSync.

     

    By the way, the adapter I am using is a Belkin adapter.

     

    Have you had any luck fixing this issue?

  • vurukov Calculating status...

    I have exactly the same issue with a Sony TV, a Sony Sound System (Amp/Receiver) and a PS3. Everything was working like a charm for years. I used to use a HP Lapton that I would HDMI connect to the AMP.

     

    I recetly replaced the laptop with an iMac and Bravia Sync doesn't work unless I disconnect the iMac. I had hoped that I can leave the wire plugged in and simply switch the input of the Receiver and have it display on the TV. No such luck. I have a Moshi adapter so add that one to the list.

     

    I am hoping that something will improve but I am not holding my breath on this one.

  • vurukov Level 1 Level 1 (0 points)

    I also contacted both, but didn't find many encouraging signs that anything will be done to correct this issue. To be frank, although not pivotal, I would have considered getting a different computer brand if guaranteed that it won't wreck havoc on my set-up.

     

    Anyways, just a quick question:

     

    I went through a painstaking effort to restore the Bravia sync. I was hoping that it would just work, but instead had to reboot the PS3 (after hours of internet searching, a simple unplug of the power cord of the PS3 did the trick)

     

    At any rate, I was wondering if I can in some way disable the Bravia Sinc on either the Amp, or the TV when I connect the iMac and then safely (and most importantly) easily connect it again. This would be an acceptable workaround as I don't need Bravia Sync on the iMac. The only downside would be that I need to physically disconend the Moshi adapter (oh well) when I need Bravia sync to work, which is most of the time as I only occasionally would need the iMac connected.

    Thanks

  • Cattapan Calculating status...

    I have the same issue here. If you have already found a solution, please tell me.It really doesn't make sense.

  • mdougan Calculating status...

    Same problem here I'm using a cable I bought from amazon and anytime I even plug it in to my BDV-E580 surround sound system it drops out the bravia sync and the tv switches back to the internal speakers. Plugging the cable directly into the tv also makes the bravia sync die also. Really hoping for a solution for this as its highly annoying!

  • Wombert Calculating status...

    Has anyone been able to solve this?

     

    I'm having the issue with a KDL-46HX755 Bravia... I've tried a "Dr. Bott" mDP to HDMI cable and a "Kanaan" mDP to HDMI adapter with a "full spec" HDMI cable.

     

    Once I plug in my 15" 2011 MBP, the TV reports "TV Speakers active due to Audio System communication failure" and the connection to my sound system breaks down (it's a Yamaha YHT-S401, but it also happened with a Panasonic and a Philips system). The device also disappears from the HDMI device list in the HDMI base setup menu.

     

    At this point, I've pretty much ruled out the audio system and cables/adapters as culprits; it's either the MBP or the TV.

  • Wombert Level 1 Level 1 (0 points)

    Found a solution!

     

    On your adapter or cable, simply remove or cover pin #13 which carries the HDMI CEC signals; see http://en.wikipedia.org/wiki/HDMI for the pinout.

     

    I did it on my mDP to HDMI cable (which has a plug, not a receptacle, so the pinout is mirrored of course), was a bit of work, but I got the pin removed, and now everything is shiny.

     

    As an alternative, connect an HDMI to DVI adapter to your adapter, then a DVI to HDMI cable to it (so the chain of connections/conversions is mDP-HDMI-DVI-HDMI), that will remove the CEC signals (because DVI can't do that), but keep the audio intact.

  • Pemberton_ Calculating status...

    Having this exact same problem...really annoying.

     

    All I wanted was to be able to 'plug and play' and here I am...searching the internet for obscure threads on random incompatibility issues. So much for the 'just works' philosophy.

     

    I've just noticed that according to the HDMI 1.4 spec, that officially supports ARC - if I get an adaptor that supports 1.4 spec will it solve this? The one I have now is 1.3b, I think.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.