Skip navigation

iPhone 4s, echo when using apple headset during a call

157826 Views 624 Replies Latest reply: Apr 1, 2014 10:08 AM by JAW Software RSS
  • i_am_ric Calculating status...

    did you try taking off your cover?

  • Tim Hassett Level 1 Level 1 (5 points)

    I did. Problem still persisted. 

     

     

    I've tried everything from reboots, to restores, different headsets, and the problem continues. 

  • sleif Calculating status...

    I get massive echo problems if I connect external speakers to iPhone 4S and use this speakers as audio out plus the internal mic of the iPhone. My voice partner gets an horrible echo - so I've to lower volume of my speakers - but then I rarely hear my call partner - no chance :-(

     

    With my iPhone 3GS this scenario was a great solution to have a free hand call during driving my car - the car radio line in connected to my iPhone; using the mic of the iPhone.

     

    I've tried everything from reboots, to restores, different speakers, with/without case and the problem continues too. Also tested with four other iPhones 4s from friends.

  • JMoMusic Calculating status...

    I have posted this on a few other threads... Hope this helps!

     

    I believe that I have a solution!

     

    I had an Iphone 4S.  It did not have this problem.  It broke and I bought a used Iphone 4.  It did have this problem and I wanted to throw it out the window.  I noticed that (and you may want to troubleshoot this too to see if you have the same issue i do)..... If I make or recieve a call prior to plugging in my headphones, I will have the external microphone problem.  If the headphones are plugged in before I answer a call or before I push send, there is no problem.  Anyhow..... There is a siimple (albeit pain in the butt solution).  If you make or answer a call prior to plugging in your headphones and the external mic is active, simply push the speaker button twice.  You are doing this to turn the speakerphone on and then off again.  When I do this, the external mic is killed and I can go about my phone call without any problems.  This solution works for me but I deem it unneccesary and temporary. It's been a while since anyone has posted on this.  Has anyone come up with a better or more permanent solutioin?  Hope this helps! 

  • moserrw Calculating status...

    iPhone 4S here and having the same problem....

     

    When I am on a call using Skullcandy Headphones + mic, the other person complains of a terrible echo..... Terrible.

     

    Thanks for the suggestion!

     

    Apple really needs to address this! These phones aren't cheap!

  • jlefoot Calculating status...

    JMoMusic, you seem to have found the solution!  I started getting the echo when I recently updated my two year old iphone 4 operating system.  Plugging the headset in before making the call appears to prevent the echo.

     

    Thanks

  • guinea13 Calculating status...

    I have the same issue and mine occurs when using any bluetooth or an apple headset.  I have a iphone 4s that is less than a year old with IOS 6.1.  It is kind of ridiculous that they have not fixed this in the almost 2 years that the issue has been going on.  The work around does not seem to always work.

     

    Has Apple responded to any of this on what they are going to do about it?

  • Robeeboy Level 1 Level 1 (0 points)

    Apple will never acknowledge there is or ever was an echo issue with their I Phone. I purchased the 4S when it 1st came out and mine had the echo issue. Didn't matter who the carrier was, or the type of headset you used or when you plugged it in or if it was bluetooth etc etc etc. There was clearly an issue that Apple did not want to admit. Basically a flaw they refuse to fix. You wonder why their stock is plummeting? Go figure. The Apple Era will soon end and people might actually wake up and realize....."Hey" I dont have to be cool and have an I Phone just cuz everybody else has one. There are actually better phones on the market and more on the way. 

  • samad502 Calculating status...

    This is the same case with me too..

     

    the opposite person hear his/her own echo.

    This happens when i use iphone directly.

    But if i on speaker , or i user headset, there is no problem.

     

    APPLE, Please fix this issue . ITS SR: 2,500 i have spent on this phone.

  • renato85 Calculating status...

    This issue seems to be absolutely RANDOM! It is slightly different for every user! What a mess...

     

    I bought my iPhone 4S in november 2011 and I since then only few times I experienced the echo problem.

     

    Since a couple of weeks, people calling me started hearing echo of themselves while speaking with me when I used Apple headset (and ONLY the apple set. I tried with a pair of In-ear Senheiser and it worked fine). And it was THE VERY SAME headset I've been using for a year and a half! And no "turn on the speaker" or "unplug then replug the headset" solution worked for me.

     

    Then fewdays ago I replaced the original headset with a pair of new Apple Earpods and everything went fine again! I really can't understand what's wrong with this phone...

  • thehilker Calculating status...

    THANK YOU! To reiterate the solution for others:

     

    JMoMusic wrote:

     

    I have posted this on a few other threads... Hope this helps!

     

    I believe that I have a solution!

     

    I had an Iphone 4S.  It did not have this problem.  It broke and I bought a used Iphone 4.  It did have this problem and I wanted to throw it out the window.  I noticed that (and you may want to troubleshoot this too to see if you have the same issue i do)..... If I make or recieve a call prior to plugging in my headphones, I will have the external microphone problem.  If the headphones are plugged in before I answer a call or before I push send, there is no problem.  Anyhow..... There is a siimple (albeit pain in the butt solution).  If you make or answer a call prior to plugging in your headphones and the external mic is active, simply push the speaker button twice.  You are doing this to turn the speakerphone on and then off again.  When I do this, the external mic is killed and I can go about my phone call without any problems.  This solution works for me but I deem it unneccesary and temporary. It's been a while since anyone has posted on this.  Has anyone come up with a better or more permanent solutioin?  Hope this helps! 

  • Kerappo Level 1 Level 1 (0 points)

    I'm using etymotic ER23-HF3 iPhone headset and iPhone 4s at 6.1.1

     

    The phone works "normally" if I do not use the headset.

     

    When using the headset:

    The persons at the other end keep complaining about the echo and usually just hang up if I do not have a possibility to speak without the headset.

     

    The headset is (and must be) plugged in all the time.

     

    I have tried:

    - speaker phone on / off. Does not work all the time and / or if it works, the echo returns back to their ear in about 5 to 10 seconds.

     

    My friends have started to suggest galaxy instead :-(

     

    Would anyone here have any better suggestions for me, mainly to get rid of only the echo, not the phone :-) ???

  • TheBasicMind Calculating status...

    I suspect this is an issue where Apple have run into a patent. The simple fact is Facetime used to behave perfectly in this regard, but it is clear to me with recent updates it simply no longer has voice filtering. There are very many patents in this space and it seems likely to me they have removed the feature so they can't be sued. The problem is, it's an essential feature and means Facetime is no longer the premium feature it once was.

  • TheBasicMind Level 1 Level 1 (0 points)

    Indeed, did a quick search and found this:

     

    http://www.patentgenius.com/patent/5619566.html

     

    Owned by Motorola (Google) no less.

  • Rich Hill Calculating status...

    Same issue with my 15GB 4GS. Case on or case off, over half the people that I talk to on my phone complain of an echo. So dissapointing. I'm going to the Apple Store tomorrow (for the 3rd) time to hear the latest version of company mandated excuses.

     

    Termas@mac.com

Actions

More Like This

  • Retrieving data ...

Bookmarked By (28)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.