3 Replies Latest reply: Feb 26, 2013 10:58 AM by LarryHN
Grifforama Level 2 Level 2 (165 points)

Since upgrading iPhoto, it is now constantly rebuilding thumbnails at startup, and telling me there are missing files.

If I press cancel, it goes to the next and the next etc etc, and eventually opens, but will do the same thing if I close and re-open iPhoto.

If I try and find the photo, I can't. It might have been renamed or something. I don;t know. I tried rebuilding the Database. No dice. Repairing Library. No dice.

I am so fed up of every time I upgrade one of these core apps, it flakes out on me.....

What can I do ? I suspect the only thing I can do it to create a brand new library and start from scratch, losing all my ambums, etc etc.

Also, that would be very hard to do as I have a 60GB iphoto library. I have no space to keep that seperate while importing and creating a new one.

Am I stuck or is this a "genius" bar visit ?

  • 1. Re: Upgraded iPhoto. Constant thumbnail rebuilding.
    LarryHN Level 9 Level 9 (56,645 points)

    How much free disk space do you have?

     

    waht is the exact error message?

     

    in the iPhoto preferences is the preference to "copy imported items to the iPhoto library checked (default) or have you unchecked it (strongly not recommended)?

     

    LN

  • 2. Re: Upgraded iPhoto. Constant thumbnail rebuilding.
    Grifforama Level 2 Level 2 (165 points)

    I have approximately 23GB of free disk space on a 500GB drive (tons of music/photos)

    That preference is ticked.

     

    The error is "Alert. The photo "xxx.jpg could not be opened, because the original item cannot be found"

     

    I have not had this error since trying to upgrade.

  • 3. Re: Upgraded iPhoto. Constant thumbnail rebuilding.
    LarryHN Level 9 Level 9 (56,645 points)

    And?

    in the iPhoto preferences is the preference to "copy imported items to the iPhoto library checked (default) or have you unchecked it (strongly not recommended)?

    So since upgrading the old error has gone away and it not constantly uncessucessfully tries to rebuild thumbnails?

    I have not had this error since trying to upgrade.

    What changes were made just before the not found error started happening?

     

    LN