Skip navigation

Older iMac not connecting to Internet, why?

221 Views 6 Replies Latest reply: Feb 28, 2013 7:19 PM by tsharper RSS
tsharper Calculating status...
Currently Being Moderated
Feb 15, 2013 4:55 PM

I have an older iMac running os10.5 but is not staying connected to the internet.

 

When checking the diagnostics, it says we are connected to the server and internet.

 

I have numberous user accounts and the only one that works is the admin account, the others do not stay connected.

 

I have added a new location and changed the connection orders and even checked the date and times on the imac but am not having any luck.

 

This is my kids computer and with it not working means they are messing with mine. So any help would be greatly appreciated.

MacBook Pro, Mac OS X (10.7.3), 2.5 GHz Intel Core 2 Duo with 4gb
  • BDAqua Level 10 Level 10 (114,805 points)
    Currently Being Moderated
    Feb 16, 2013 2:41 PM (in response to tsharper)

    Hi, it sounds like you've tried much of what I would recommend, but see off there might be additionl things here...

     

    Make a New Location, Using network locations in Mac OS X ...

     

    http://support.apple.com/kb/HT2712

     

    10.7 & 10.8…

     

    System Preferences>Network, top of window>Locations>Edit Locations, little plus icon, give it a name.

     

     

    10.5.x/10.6.x/10.7.x instructions...

     

    System Preferences>Network, click on the little gear at the bottom next to the + & - icons, (unlock lock first if locked), choose Set Service Order.

     

    The interface that connects to the Internet should be dragged to the top of the list.

     

    10.4 instructions...

     

    Is that Interface dragged to the top of Network>Show:>Network Port Configurations.

    If using Wifi/Airport...

     

    Instead of joining your Network from the list, click the WiFi icon at the top, and click join other network. Fill in everything as needed.

     

    For 10.5/10.6/10.7/10.8, System Preferences>Network, unlock the lock if need be, highlight the Interface you use to connect to Internet, click on the advanced button, click on the DNS tab, click on the little plus icon, then add these numbers...

     

    208.67.222.222

    208.67.220.220

     

    Click OK.

     

    If that doesn't work try changing channels on your Router.

  • BDAqua Level 10 Level 10 (114,805 points)
    Currently Being Moderated
    Feb 26, 2013 6:08 PM (in response to tsharper)

    Does 17.149.160.49 work for one of those users?

  • blackdogaudio Level 2 Level 2 (310 points)
    Currently Being Moderated
    Feb 26, 2013 7:50 PM (in response to tsharper)

    Long shot maybe but have you enabled System Preferences>Parental Controls and accidently denied all other users access to the Internet (or on all websites but a few in the list OSX creates by default?)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.