Skip navigation

I can't imessage from my phone number through ichat

32612 Views 27 Replies Latest reply: Feb 13, 2014 12:34 PM by Ralph Johns (UK) RSS
1 2 Previous Next
dana429 Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 2, 2013 12:44 PM

I updated the software, but I can't find my phone number as an option of the accounts I can iChat from on messages

here I should be able to choose to be reached for messages at my phone number, but it isn't an option.

Can anyone help?

 

<Email Image Edited By Host>

MacBook Pro, OS X Mountain Lion (10.8.2)
  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Mar 2, 2013 12:39 PM (in response to dana429)

    HI,

     

    I would check the iPhone end.

    In Settings > Messages > Send and Receive is the iPhone Number ticked (it is likely to be greyed out)

     

    If it is not then remove the Apple ID.

    Wait to see if the iPhone Number can be selected.

    If not, Turn Messages Off  (or put the iPhone in Airplane mode)

    Wait again.

    Turn Messages back on.

    If the Number can now be selected then do so.

    Then re-add the Apple ID.

     

    Reboot Messages on the Mac.

    it should now get a alert style message to say the iPhone is using it's number an the Apple ID.

     

     

     

    3Sigcopy2.png
    8:39 PM      Saturday; March 2, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Mar 4, 2013 11:21 AM (in response to dana429)

    HI,

     

    I know I asked the Hosts to remove the Pic you posted as it listed the email you are using in iMessages which presumably is your Apple ID.

     

    I cannot remember if it displayed an "add Email" button.

    If it does, you can use this and add the iPhone Number instead.

    This has to be in the form of +Country code as in +44 for the UK then the Carrier/area code (may involve dropping a leading 0 at this point) followed by the number.

    My number to dial here is 07973XXXXXX. In Messages it appears as +44 7973 XXXXXX  (The app seems to space the numbers)

     

    3Sigcopy2.png
    7:21 PM      Monday; March 4, 2013


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • The Big 88 Level 1 Level 1 (0 points)

    Untitled.pngI am having the same problem i live in the United states though

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)

    Hi,

     

    That pic does not appear to be iOS version 6.1 or above.

     

    If that is the Send and Receive pane then remove the Apple ID.

    Then either Turn Off Messages on the iPhone or put it in Airplane Mode to break with the server.

    Wait a few minutes.

     

    Now take the iPhone out of Airplane Mode or Turn On Messages depending which you used above.

    Check the iPhone Number is now listed as the Send and Receive "ID".

     

    You can now add the Apple ID back and both should be listed as Send and Receive "IDs"

    You can then chose the Send From Option.

     

    IF, after a further five minutes, the pop up has not appeared on the Mac version of Messages then restart Messages on the Mac.

    This should ge the pop up to appear and when Accepted both the iPhone Number and the Apple ID should appear on the Mac version.

     

     

     

    3Sigcopy2.png
    7:01 PM      Monday; May 6, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • SagaSaga Level 1 Level 1 (0 points)

    This is helpful Ralph.  I have a similar situation, except the phone number does not appear, greyed out or otherwise, under iMessage settings.  When you say "remove the Apple ID" do you mean:

    • remove the email address(es) from iMessage settings > Send & Receive? 
    • delete the apple ID account in iCloud settings?
    • or what?

     

    Any guidance will be appreciated!

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Sep 22, 2013 1:20 PM (in response to SagaSaga)

    Hi,

     

    Ignore the Cincinnati Bell pic below (May 6th) as it has an older version of the iOS.

     

    However on the iPhone > Settings > iMessages  remove the Apple ID here.

    It does not have to be the iCloud one.

     

    Basically remove the Apple ID and turn the Messages app Off, or put the phone into Airplane Mode (Anything that will break with the server).

    Restart the Phone and/or App and make sure the iPhone number is ticked - i.e. on first starting Messages on the iPhone it will use the iPhone Number only.

    If this appears to be done  (I once had it unticked whilst the apple ID was the active item) then re-add the Apple ID.

     

    Restart the Mac version of Messages.

    At this point you should get a pop up alert on the Mac saying the iPhone is using it's Number and the Apple ID for iMessages.

    Accepting this should add the iPhone Number to the Mac versions "Receive At" list and the Start Conversation From drop down at the bottom.

     

     

    3Sigcopy2.png
    9:20 pm      Sunday; September 22, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Rangeley Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 22, 2013 7:27 PM (in response to dana429)

    Thank you, Ralph.  I'm helping SagaSaga with this problem.  We tried your approach, turning airplane mode back off after the restart (is that OK?) and going directly to settings > iMessage.  It asks for a password for the apple ID and we refuse to give it.  Now it is "Waiting for activation."  This seems an indefinite state. 

     

    We are in a similar situation with FaceTime, which is also sitting, "waiting for activation."

     

    I know, or at least believe, from experience that if I sign in with the apple ID, there will be a very brief moment when the phone shows up on the list with the email addresses (in Settings > iMessage > Send & Receive), but then it will disappear from that list.  It is now merely unchecked, the phone number does not appear in the list at all.

     

    This has been going on for a long time, with iOS6 and now 7.  She can iMessage or SMS, but they appear to the recipient as if sent from two different people with the same name.  One person only receives SMS, the other only receives iMessages. 

     

    How long should we "wait for activation," before trying something different?

  • Rangeley Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 22, 2013 8:57 PM (in response to dana429)

    OK, I lost patience after an hour of "waiting for activation."  I went ahead with linking iMessage to the apple ID and sure enough, the phone number appeared at the top of the Send&Receive list, with two emails below it.  Perfect.  I then click Next -- the only alternative to cancelling -- after which the phone was "verifying" for a while.  When it finished, I looked back at the Send&Receive list, and the phone number is no longer listed.

     

    Any ideas on what is going on there?

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Sep 23, 2013 12:26 PM (in response to Rangeley)

    Hi,

     

    On the iPhone the default (as New) state is for the iPhone Number to be listed in the Messages Setttings once you turn the App On in the phone.

     

    When you add the Apple ID here you are likely to need the password as well.

    Although technically your Apple ID password could be blank I don't think Apple let you set one up this way.

    However the app on the iPhone has no way on knowing that and will try to Verify the Apple ID and supposedly Blank password.

    Although it should fail, it may get stuck trying to verify this for a long time.

     

    I went ahead with linking iMessage to the apple ID and sure enough, the phone number appeared at the top of the Send&Receive list, with two emails below it.

     

    This sounds like it is the Mac version but I am not entirely sure.

     

     

    3Sigcopy2.png
    8:26 pm      Monday; September 23, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • joelske Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 28, 2013 12:22 PM (in response to dana429)

    I am having the exact same problem as rangeley.

    I have to sign into my Apple ID account otherwise it continually says waiting for activation

    When I do sign in I see my number greyed  out and email in black. I deselect my email so only my greyed out number is ticked and when I click next, under send and receive it says that I have no addresses selected!

     

    Please help!

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)
    Currently Being Moderated
    Sep 28, 2013 12:50 PM (in response to joelske)

    HI,

     

    iPhone Pic  (iOS 7.0.2)

    iMessageiPhone.png

    Your iPhone's own number should be greyed out.

    If Messages is Active/Enabled at the screen before this one then the iPhone number should work as the only Send and Receive "ID"

    Once you add the Apple ID (with Password) you should get this listed in the Send and Receive options as well.

    You can then select between starting from the iPhone Number or the Apple ID

     

    In My pic I have a second Apple ID and an second iPhone number that belong to a second phone.

    The two IDs are linked via iCloud which is why iMessages keeps trying to link them together.

     

    If I remove (the Permission) the Apple ID from the Send And Receive List then the Start from List part disappears from the window/Screen.

     

     

     

    3Sigcopy2.png
    8:50 pm      Saturday; September 28, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • joelske Level 1 Level 1 (0 points)

    photo.JPG

     

    as you can see, my number doesnt have a tick so it cant be selected.

  • Ralph Johns (UK) Level 9 Level 9 (66,805 points)

    Hi,

     

    From the email alert of your post I cac link and see the pic but for some reason the Post is not showing up to me here at the moment.

     

    Have you tried this

    Remove the Apple ID  (Apple ID Here)

    Then turn the the Messages App Off  (Slider on the previous screen)

    In fact go one  set further and in the General Settings set the Airplane mode.

    Wait a few minutes.

    Take it out of Airplane Mode and turn On the Messages app.

     

    Is the iPhone Number now ticked ?

    I had what you are seeing and removing the app and setting Airplane Mode (to break with the iMessages server) and then "restarting" seems to reset the iPhone Number as an option in Messages.

     

    If it does become ticked now re-add the Apple ID.

     

     

    3Sigcopy2.png
    10:22 pm      Saturday; September 28, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.