Skip navigation

Mac Mini 2012 video blinking out

153797 Views 1,193 Replies Latest reply: Mar 29, 2014 2:11 AM by knightshade91 RSS Branched to a new discussion.
  • Zundfolge Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 25, 2013 10:22 AM (in response to KevCheng)

    Ok...apparently I owe Apple an apology.  I called them up Saturday and the tech had me unplug everything, hold the power button down for 15 seconds, plug everything in, then restart whilst holding down Option+Cmd+ (I think) 'R' + 'D'.  The computer restarted and I have had NO issues since.

     

    It was getting so bad that I was having to turn everything off and back on a few times an hour; sometimes minutes apart.

     

    Not sure what the issue was or what this fixed, but it worked.

  • BDAqua Level 10 Level 10 (114,715 points)
    Currently Being Moderated
    Feb 25, 2013 12:38 PM (in response to Zundfolge)

    Thanks for the report, good to hear!

  • Michael Aos Calculating status...
    Currently Being Moderated
    Mar 2, 2013 9:07 AM (in response to KevCheng)

    Late 2012 Mac Mini 2.6Ghz Core i7, Fusion drive.

     

    Installed 16GB of OWC RAM.  My primary display (Apple LED Cinema Display w/displayport) would occasionally go black.  Required a reboot (sometimes power-cycle of the Display would resolve it, and sometimes hot-plugging the display would resovle it).  I even saw a couple times where power-cycling the second display would bring the Apple display back to life too.

     

    Replaced the LED Cinema Display with an Apple Thunderbolt Display.  Exact same issue.

     

    installed a fresh OS on a 2nd HD -- same issue.

     

    Read about all the other people having a similar issue.  I was out of town, but installed the mid-December firmware update around 1/1/13.  Didn't help. 

     

    Dropped the Mini off at the Genius Bar of the Apple Store.  They kept it for a week, ran quick diags and gave it a clean bill of health.  Absolutely worthless.

     

    I finally dawned on me that it could be a RAM issue, so I reverted to the 4GB OEM RAM.  Worked perfectly.  No issues at all.  Rock solid. 

     

    Paired 1x 8GB OWC DIMM with 1x 2GB OEM RAM -- again, no issues.  Life is good. 

     

    OWC cross-shipped me a replacement 16GB upgrade.  Exact same issues all around.

     

    Now I'm returning the OWC RAM (with a 15% restocking fee). 

     

    I'm hoping I won't have this issue when using some other vendors RAM. 

     

    Any suggestions?

  • Tom Sheppard Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 2, 2013 9:22 AM (in response to KevCheng)

    Just so Apple doesn't get complacent with the reduced traffic on this topic, I continue to see sub-second flashes on both of my Dell monitors connected via DVI adapters to the Tb and HDMI ports. This occurs 1-3 times every day or so. Much better than my earlier reports, but still darned annoying. These monitors have been used on various other computers with no glitching whatsoever.

     

    As for all Apple updates, we can only hope that 10.8.3 will fix the problems once and for all. Going back to the days of the Mac II, this is the only computer from Apple, or any other vendor, that I've seen have video problems.

     

    I suspect this is related to the Mini using shared memory and probably some sort of bus conflict between the CPU and graphics chip arbitrating for the memory bus. Perhaps the video driver can't access the memory fast enough. My early 2008 MacBook connected to the 24" Dell monitor ran for many years without a single glitch and it too used shared memory. Is the Mini's graphics subsystem deficient?

  • Michael Aos Level 1 Level 1 (80 points)
    Currently Being Moderated
    Mar 2, 2013 9:29 AM (in response to Tom Sheppard)

    It definitely seems to be something with the shared video memory. 

     

    I can CONSISTENTLY demonstrate the issue by running a (Flash) video in full-screen on either Apple Display (2560 x 1440) while a second 1920 x 1200 display is attached AND I have 16GB of OWC RAM installed.

     

    Either Apple Display (I have one attached, and have borrowed another for testing) just goes black after about a minute, like it went to sleep or something.  Audio is still there, and if I connect remotely, the graphics are still there. 

     

    I wind up having to reboot the Mac to recover.

     

    If I pair one of the 8GB OWC DIMM's with an OEM 2GB DIMM, I don't have the issue.  Been running fine with 10GB for weeks.  Problem immediately reappears with 2x 8GB OWC DIMM's / 16GB of RAM.

    --

  • x704 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 2, 2013 7:51 PM (in response to Michael Aos)

    My video blink/snow problems on the 2012 mini are present with both the stock OEM (4GB) & OWC (16GB) ram upgrade when hooked up to my 1080p TV via HDMI to HDMI cable.  When hooked up to my 1080p Dell monitor (using HDMI to DVI adaptor) I haven't experienced problems.  Interestingly, my 2011 mini also has rare blink/snow issues when hooked up to my TV as well.

  • sincerus Calculating status...
    Currently Being Moderated
    Mar 7, 2013 9:56 AM (in response to KevCheng)

    Howdy folks!

     

    Thank you for sharing all of your stories.  It helped me finally start digging in the right direction.

     

    There are SEVERAL issues going on.  I have a Apple LED Display 24'' and an Acer 24'' monitor.

     

    If you have the old Apple displays with the mini port Apple DOES HAVE a firmware update.

     

    This is if your display is flickering.  There IS NO easy way to see which firmware version you are using.

    http://support.apple.com/kb/TS4045

     

    For those of you with the Mac Mini 2012 there is a KNOWN issue with the HDMI driver supplied by Intel.

    They have shipped Apple the fix and we should see it in the next version of OS X Mountain Lion 10.8.3.

     

    http://reviews.cnet.com/8301-13727_7-57556171-263/flickering-mac-minis-to-get-a- fix/

     

    I will try to post this as a seperate thread just in case anyone needs this info.

     

    Kind regards,

     

    Ed

  • slothinker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 7, 2013 10:48 AM (in response to sincerus)

    For a few folks (like me) this problem only manifests when waking up from Sleep mode ... it takes quite a few tries for the monitors (I have an Apple 24" and an HP w2207) to come back to life together.

     

    I just stumbled upon a trick which seems to help ...

     

    When the system is in Sleep mode, I use my iPhone's Remote app to connect to my (already running but asleep) iTunes. The iTunes library appears and I can start a piece of music. That, in turn, seems to wake up the Mac, which I then can log into normally.

     

    Note: Sleep mode on my system is set to wake for network.

     

    Hope this is useful.

  • georgioskio Calculating status...
    Currently Being Moderated
    Mar 14, 2013 3:19 PM (in response to sincerus)

    OS X Mountain Lion 10.8.3 is here but i dont see to write any solution for the video blinking out at mac mini 2012!!!

  • slothinker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 14, 2013 5:57 PM (in response to georgioskio)

    So I also just downloaded 10.8.3 and tried out a couple of things.

     

    First, my system 2012, 8 gigs ram, fusion, 1 tetrabyte.

     

    I have two monitors ... an Apple 24-inch and an HP 2207. Actually I have a couple of the 2207s. I can use the DVI version with the Mac Mini. Previously I couldn't get the HDMI version of the HP (w2207h) to work at all. Unfortunately, that is still the case (and I know my HDMI cable is good). All I get is a bunch of flashing when the w2207h is used as the secondary monitor, which is the only way I'd want to use it.

     

    The other problem I've previously reported relates to waking the system after it has gone to sleep. Even though it takes quite a while for the system to wake up, it looks to me like 10.8.3 represents some improvement in this area.

     

    Kind of a disappointment given the wait time for this fix but maybe this is a problem which can only be resolved w/ new (improved) hardware design. That's my guess.

  • zoney99 Calculating status...
    Currently Being Moderated
    Mar 14, 2013 6:15 PM (in response to KevCheng)

    Thanks slothinker. Too bad about the results of the OS X update. Really, nearly 5 months since the Late 2012 MM came out and still dealing with this. I read somewhere that the next MM is due "4th quarter" (financial quarter) and I guess I'm waiting until then.

  • georgioskio Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 15, 2013 1:39 AM (in response to KevCheng)

    I installed 10.8.3. version... The problem with the video blinking out still exists!!! And now???

  • Tom Sheppard Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 15, 2013 5:44 AM (in response to georgioskio)

    I think it's safe to conclude after this amount of time that Apple will not be fixing the problem. Clearly they either don't care,  don't have the technical ability to do so, or the hardware is unfixable.

     

    Based on past history with Apple updates, I usually wait a week before I install to see if others have major problems. That is how much my confidence in Apple has gone down. I no longer trust them.

     

    My own mini continues to have several sub-second flashes a day, which is extremely annoying. I've sent Apple feedback on this outside of this forum so I know they're aware. Will the latest update fix my mini's problem? It doesn't look promising.

     

    Apple has sold a defective product. They should own up to it and offer a return and discount on other models of Macs. They will remain silent, guaranteed.

  • Philip Tyler Level 4 Level 4 (2,255 points)
    Currently Being Moderated
    Mar 15, 2013 11:00 AM (in response to Tom Sheppard)

    I feel your pain, my first MM had this problem along with the grey noise issue. That MM Apple 'captured' and I was sent a new one, which arrived at the same time as the EFI update. So I installed that and mine has been fine since. I run dual monitor with an Eizo connected by MDP-DVI and a Formac connected by HDMI-DVI. Both monitors have worked fine.

     

    It would seem as if this is not just a MM problem in itself but a combination of MM and monitor as some seem fine while others have these problems. I just count myself very lucky my two monitors both work without any problems.

     

    One can only hope the next model of MM does not have this problem, as otherwise its a great little computer.

  • slothinker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 16, 2013 3:56 PM (in response to Philip Tyler)

    So ... after using 10.8.3 for a few days I'm happy to report that the problems I had rousing the Mac Mini from Sleep mode are greatly reduced. In fact, if yesterday/today is any, I'd say the problems are resolved. Hope so!!

     

    (For those who don't religously follow my postings I have a late 2012 Mac Mini w/ Fusion drive, 8 gigs ram. Two monitors: Apple 24" and HP w2207 using DVI connection in Portrait mode.)

1 ... 72 73 74 75 76 ... 80 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (37)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.