Skip navigation

mac mail password problem

13718 Views 19 Replies Latest reply: Jul 2, 2013 7:01 PM by Sneakie Pete RSS
  • John Harkins Level 1 Level 1 (85 points)
    Currently Being Moderated
    Jan 12, 2013 5:44 PM (in response to Mark Blake)

    Update: someone at apple contacted me (through the bug report tool) and requested that I run the sysdiagnose command on Mail while it was experiencing the problem. I have uploaded that report to them.

  • Jose_IUB Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 2, 2013 4:08 PM (in response to John Harkins)

    John --  Did Apple get back to you about what they found from that report?  Or are we left in silence?

     

    When this happens to me, my university account is automatically locked.  The Admins tell me it's from repeated attempts to authenticate on the smtp server, using an incorrect password.  This happens when I first turn on WiFi, even with all other apps "inactive."  Mail apparently does things in the background, even when it's supposedly asleep, and this is one of them.  I cannot find anything in error with my Mail account or keychains, and setting up a new account doesn't fix it.  Some clues would be helpful...

  • John Harkins Level 1 Level 1 (85 points)
    Currently Being Moderated
    Mar 2, 2013 6:39 PM (in response to Jose_IUB)

    Someone at Apple did contact me through the bug report and asked me to run additional diagnostics which I did and sent to them. I also looked through the diags myself to see if it might contain somethign that could be helpful but I didn't see anything. However, I think the problem should be fairly easy for them to reproduce based on the decription I gave them assuming it truly is a bug in either Mail or keychain (I believe it is). The bug is still listed as "open" on the bug report. Hopefully they are working on it.

     

    If you have the same issue as I, the workaround I'm using for now is to remove old keychains from my keychain list before I launch my mail client and that seems to cause Mail to behave better. I suppose I could just add the old keychain items to my default login keychain by hand at some point but that would be a fair amount of work. So, for now, I just delete the old keychains from the list (temporarily), start up Mail, and then close down Mail if I need to access an old keychain (by re-adding it to the keychain list).

     

    That said, the problem I am having will always produce a dialog box asking me to authenticate with my password when Mail fails to properly authenticate (even though my default keychain has the correct password). So if you are not being prompted to enter your password - it may be that you are having a different issue. Although Mail does attempt to authenticate in the background - it should always let you know when it fails with some dialog box. I understand that even entering the correct password will not work (with the problem I am having) but you should be able to avoid repeated multiple attempts by closing Mail and removing the keychain/account before you reach the deactivation - threshold. I realize this is not ideal but you may be able to arrive at some solution that "works" by deleting your email accounts and keychains (you don't have to permanently delete them) and starting from scratch. I was also unable to find any problem with my Mail accounts or keychains but the problem nevertheless happens so I sympathize with you. I will report back if Apple closes the bug report.

     

    Hope this helps.

  • Ragsthedog Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 26, 2013 11:44 AM (in response to wurlibennett)

    I have been a convert from windows to Mac for only three weeks but have encountered the same problem...password request every time I send an email.  As I have access to apple support for 90 days, I contacted them today and they have fixed the problem.  They reset all my I cloud account details  and it appears to be working fine.  It was apparently smtp server issues, however they did tell be that there may be a compatibility issue with BT yahoo and OSx and the emails received on my macbookpro are taking a lot longer( in some cases 5 mins) to appear than on my i phone and i pad.  BT are apparently aware of this and working to fix it so Im told. Ive read another thread re this somewhere in discussions but cannot find it so appologies if you are aware.  Apple support have been great although the phone call lasted 1.5hrs!!

  • Sneakie Pete Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 2, 2013 7:01 PM (in response to ferd41)

    Ready everyone- here is the magic answer - which I finally found at the end of a long, dark, ugly journey through the back alley of mac mail password ****-

    The real culpret lies not in your computer but in your iphone!

    After some time your iphone settings(passwords, etc) get corrupted, and so all you need to do is delete your mail accounts from your iphone and then reinstall them. This will give the necessary "refresh" needed to again make the phone mail sync with the computers mac mail client. After doing everything else under the sun, this is what worked for me.

    This is why some of you found that after logging in to web mail one time, deleting the keychain and then "remembering" the passwords again, etc, the problem would appear fixed, - for a few minutes. It would come back again as soon as any email would download to your phone, or you woud open the mail in your phone, get it now?

     

    Now - your all welcome, and donations will be accepted - jk

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.