1 4 5 6 7 8 Previous Next 135 Replies Latest reply: Jul 7, 2014 6:50 AM by nellivs Go to original post Branched to a new discussion.
  • 75. Re: Can't deactivate iMessage after switching phones?
    ingeniusone Level 1 Level 1 (0 points)

    I switched to a Samsung Galaxy 3 before turning iMessage off.Tried the suggestions above with the exception of using the iPhone microsim swap to turn off iMessage...

     

    Still no go -- cannot receive texts from iPhone users...I love apple (have a mac/iPad) but NOT loving this issue...

     

    Does anyone have any other suggestions, please share...

  • 76. Re: Can't deactivate iMessage after switching phones?
    Ray Earley Level 1 Level 1 (5 points)

    coocooconor, it sounds like several phones are registered to your Dad's Apple ID, is that possible?  That would explain the grayed out numbers in the iMessage settings.  My settings have my phone number (checked and grayed out) and also 2 emails that are associated with my apple ID; the primary email (apple ID) and the contact email, neither of which are checked.

     

    https://supportprofile.apple.com

     

    Each person needs to have a unique apple ID.  IF their phone is using someone else's ID, they can change it in settings->imessage-.Send & Receive->Use your apple ID for iMessage.  Clicking on "Use your Apple ID for iMessage will give you the option to change the apple ID for that phone.  It also has "log out" which will probably fix a lot of problems for posters on this group who swithced to a non-apple phone and continue to get messages there.

  • 77. Re: Can't deactivate iMessage after switching phones?
    Ray Earley Level 1 Level 1 (5 points)

    ingeniusone, you went to your old iPhone and turned iMessage off, and still don't get texts on your Galaxy 3?  Was your iPhone connected to wifi at the time? if not you might try that.  Or if your microsim is compatible between both phones, try the swap and then turn iMessage off.

  • 78. Re: Can't deactivate iMessage after switching phones?
    coreywade Level 1 Level 1 (0 points)

    Still trying to figure it our myself too. I have tried turning imessages on the device that I'm trying to receive texts from but that didn't help

    except when imessage was off, when I turned imessage back on, it reverted back to immesage and I quit receiving the messages. I traded my iPhone in to best buy to get my new phone, so I don't have access to deactivate imessage from my old iPhone. Any hep would be appreciated.

  • 79. Re: Can't deactivate iMessage after switching phones?
    Tray86 Level 1 Level 1 (0 points)

    I had exact same problem when I had to change my number due to harrassing calls, i still had the same phone (iPhone) so this may not apply or work for people who changed devices. Anyhow as another member said earlier, I could ring out and recieve phone calls with the new number, but messages were still going to my old number, and also at the top of my contacts my number was still showing up as the old one. I could message myself by sending a message from my new number to my old number. I tried reseting the phone and deactivating my account on the support profile page and non of it worked. I then went into message settings and turned iMessage off then back on, when I did that my send/ recieve went blank instead of displaying my old number, so I clicked on the blank space and it automatically popped in the new number itself, and now it displays the new number at the top of contacts instead of the old.

  • 80. Re: Can't deactivate iMessage after switching phones?
    Libra340 Level 1 Level 1 (0 points)

    I was experiencing the same problem. I went through all the channels I found. Explained it to the Apple Store, even showed them the numerous articles on this, and they were stumped. Spoke to Apple Support over the phone, same result. Tried the Support Profile way (the product's profile would not appear in my products list (after seeing the sucessfully registered check), to unregister.

     

    But decided to fiddle around in iTunes and discovered a way that worked for me.

     

    In iTune's Menu bar,

    1. Go to Store
    2. View My Apple ID. (Type your password in).
    3. After the page loads, in the "iTunes in the Cloud" section.
    4. Press Mange Devices
    5. Remove your phone from the list

     

    After this, my friends were relieved to say it stopped automatically sending their messages to my phone as an iMessage. 

     

    Afterwards, just to be on the safe side, i followed these instructions:

    WozzaX wrote:

     

    I think I have the full solution but does require you access to an iPhone (old or friends). I used my wifes.

     

    Grab a friends (wife) iphone.

    Log them out of iMessage (facetime as well if you want).

    I also logged out of my iMessage and Facetime on iMac and iPad just incase.

    Log in as you on the iPhone.

    Then turn iMessage (and facetime) Off. Leave it for a few minutes then reboot the phone still with it off.

    Log into your Apple Account via a website.

    Reset your Apple ID Password.

    On the iPhone turn on iMessage.

    It may look like its activated but it shouldnt cos the password has changed. just go into recievers and sign out and log back in as the original iphone owners account.

    Done.

    When I logged back in again on iPad and Mac my mobile number was missing. Hurrah.

     

    I am starting to wonder if this problem gets more complicated with owning multiple iDevices, compared to those who only use an iPhone. Maybe the iPhone's iMessage toggle works for strictly iPhone users. But for those who have synced it with their iPads or computers, it evolves into this problem.

     

    Deep down, I feel that Apple executives know of this issue, but do not care to rectify and give customers an easy solution to resolve it. This could be a way to give us **** for switching from their devices.

     

    (Proud owner of the new Samsung Galaxy S4 lol)

  • 81. Re: Can't deactivate iMessage after switching phones?
    Pablotennis Level 1 Level 1 (0 points)

    I switched from iPhone 4s to galaxy S4. After trying all mentioned above still had a problem with one of my contacts.

    I called her and the problem was her stupid iPhone. Make sure the person who is texting from iPhone to android has the SMS turned ON. Other wise they won't receive nor send text from/to androids

    I found that out bc the text she sent went to my iPad and not to my new great galaxy s4

     

    It is easy for the sender to go to:

    1 settings

    2 scroll down to messages

    3 turn ON the SMS. They can still have the iMessage ON too so the iPhone will use either one as needed.

     

    It is a annoying to mess with the change but each company has complete different platforms and work different

    iMessage works over data and goes among apple devices while android texting is SMS

  • 82. Re: Can't deactivate iMessage after switching phones?
    SeanJC Level 1 Level 1 (0 points)

    After about 24 hours of trying to fix this by all the various means, I think the final solution I came up with actually works.  I now have iPhone users texting me & being received on my newly acquired HTC One.  As I'm sure has been stated before, ALL Facetime & iMessage accounts need to SHUT OFF on all devices associated with the phone #.  All iPads, MacBook Pros, Air, iMac, iPhones, iPods, etc.  Everything.  Then, & most importantly, (& hopefully you still have access to the original iPhone that had the phone # on it), the phone can have no access to the internet.  Neither through Wifi or through the cellular network.  You can just shut off all cellular data &/or wifi.  Just make sure it's not connected tot he internet.  Once I shut that off, everything was seemingly back to normal.  I can now only hope Apple hears the frustration of all of these iPhone users (including myself, albeit, I've traded out the iPhone for the HTC One for now) & decides to make this process far more seamless in future iOS releases.  Really ridiculous this is even an issue.

  • 83. Re: Can't deactivate iMessage after switching phones?
    SeanJC Level 1 Level 1 (0 points)

    Follow up to this post... According to the chat I just hat w/an Apple support rep, you must leave the iMessage account signed out for at least 21 days for the phone # to completely disappear.  As long as you are signed out on all of your iMessage accounts, iMessage users should be able to text to non-Apple devices.  In my opinion, this is a HUGE fail on Apple's part.  Deactivation of a user's phone # should be immediate.  They have no right to hold on to your # for 3 weeks, and keep it associated with any of their products.  Awful user experience. 

  • 84. Re: Can't deactivate iMessage after switching phones?
    cenna75 Level 1 Level 1 (0 points)

    Same issue here. I'm not sure yet how to fix it, but here are three things I thought could be interesting to add:

    - as most people probably understand by now: there is little chance contacting your provider will help. This is an international issue (I'm from France for instance), so whether you're with AT&T, Verizon, etc. probably does not change a thing

    - I found out there are many iMessage apps on GooglePlay, agreed this is a terribly dirty fix and amounts to surrendering to Apple's forcing us to stay with them but I guess some will chose this option to make sure they can be contacted

    - finally, has anyone pointed out that when you google this issue, it looks like it's an old and widespread one (earliest posts around 2011)? I'm thinking that if great Apple, who besides can release crazy intelligent products, has not done anything about it, it's probably that they don't really want to... Let alone there is no official fix by Apple, only users communities. So I'm not surprised they're not helping when you call them. Among the tons of people that encounter the problem, I'm guessing a few will chose to go back to the iPhone. Hey, after all, there is no small profit!

    Thanks to everyone coming up with solutions and sharing them

  • 85. Re: Can't deactivate iMessage after switching phones?
    wmurphy1975 Level 1 Level 1 (0 points)

    I have also experienced this.  I temporarily transferred my cell service from an iPhone 5 to a Windows phone and was not receiving text messages from friends or family that had iPhones. 

     

    The only way for me to resolve this was to turn off iMesaage on all my other Apple devices.  Apple needs to come up with a better way to resolve this.

     

    You can read about my full experience here.

  • 86. Re: Can't deactivate iMessage after switching phones?
    alexfromcalgary Level 1 Level 1 (0 points)

    Hey there,

     

    I have recently changed to the galaxy S4 and am having the issue of having my friends send me imessages instead of texts. I have an iPad as well as a Macbook pro with iMessage on it. I have disabled my iMessage on my iPad but my friends are still able to send me iMessages....any advice as what to do? I tried to get my friend to delete me as a contact in his phone and re add me, see if that works.

     

    Any help would be great thanks!

  • 87. Re: Can't deactivate iMessage after switching phones?
    Rexxyroo1 Level 1 Level 1 (0 points)

    YES!!!!!!!!  IT WORKED!!!!!

  • 88. Re: Can't deactivate iMessage after switching phones?
    Rexxyroo1 Level 1 Level 1 (0 points)

    WORKED!!!!

  • 89. Re: Can't deactivate iMessage after switching phones?
    albermad Level 1 Level 1 (0 points)

    This didnt work for me

1 4 5 6 7 8 Previous Next