3 Replies Latest reply: Mar 5, 2013 9:42 AM by RajaRani
Kish1254 Level 1 Level 1 (0 points)

I have a iPod 2g and there is nothing wrong with it therefore no need to upgrade - Is the remote app avaialble for earlier iOS's?


iPod touch, iOS 4.2