Skip navigation

MacBook Air no audio output device found ???????? *please help*

315127 Views 385 Replies Latest reply: Apr 11, 2014 2:31 AM by Paula Hunts RSS
  • meleDargento Level 1 Level 1 (0 points)

    Briefly: 5 year old MBA 1,1; 'genius' at the apple store told me that it would be $300 for a new logic board; I consulted the forums instead and ordered an audio cable through; thus, I fixed it myself and I heard the chimes singing on boot-up.


    I can see responses have varied for this thread, and people have probably experienced a number of problems that invariably manifested as "no audio output device."  So i can only tell you my story and what worked. 

    I have a Macbook Air 1,1 (first generation, first model) that did not have too many problems while under warranty. Then just before hitting our 5 year anniversary my MBAs audio output became unreliable and then entirely non-functioning. 

    I tried different round-about fixes listed in the forums to see if it was a software problem, and even took it into to see an apple genius.  The genius hooked his machine up to mine and confirmed that it was a hardware problem, and then recommended that it would need a new logic board.   With a smug grin he said he could replace it for $300.  I recalled reading about a replacement audio cable as mentioned in the forums, and he said he could replace that for $50 even though I could see that it was listed for $10 in his inventory catalogue. 

    Because my machine was outside or warranty, I ordered the cable myself for the cheapest, easiest fix.  I opened up the under-belly of my MBA as an amateur tinkerer, and made the fix in an easy 30 minutes, I also installed a solid state drive.  I turned on my machine to hear again the glorious chimes of the boot-up. 

  • Morgan2 Level 1 Level 1 (65 points)

    Just wanted to add that my original MBA 1,1 has had the sound problem a for a few months. This is no longer my main machine (I have an iMac and an ipad), but I think I'm going to add an SSD, new battery, and fix the audio while I'm in there. This is in place of buying a new laptop, despite having a new need (I need to travel for work). I seriously paid a price for being an early adopter with this thing and even when I bought it I knew I shouldn't have (it was underpowered for my needs). But I think by adding an SSD and a new battery I can hopefully get another year out of this thing.

  • kendallfromaustin Level 1 Level 1 (0 points)

    I dont know if its been posted, and to be honest I have NO IDEA WHY THIS WORKS. BUT IT DOES.


    I followed the video then thought to myself "The placement cant matter, its gotta be the securing the connections and straightening the wire thats fixing it, apple pays engineers to build these things, imma stick with them" So i placed it back under the battery, Didnt work. Opened it up and did it the way the video says (cable above the battery) worked perfectly. To me it makes no sense, but it works. Heres the video, Enjoy.


  • WYkid Level 1 Level 1 (0 points)

    Thank you! Thank You!

    Followed the video-worked just like it!

    Original MBA is sounding again!


    Should add....I have tried everything short of going to Apple which was considering but, I am 265 miles form nearest store!  KISS definetly!

  • WYkid Level 1 Level 1 (0 points)

    OOPS a little over 12 hours and the MBA upon start up has no sound or ability to play You-tube.  Must be a further problem but, is very interesting the re arranging video cable makes it work.  For awhile.

  • meleDargento Level 1 Level 1 (0 points)

    My suspicion is that the position of the audio flex-cable apposed to the battery corrupts the ribbon over time. Whether that is due to the heat or other mechanics is beyond my deduction; still, I think it is flawed design to have the cable run directly under the battery.  Perhaps that is why an adjustment will fix, albeit temporarily, the connectivity.

    WYkid, if you have not replaced the cable yet, and in the event that you receive mail 265mi from the nearest apple store, I would go ahead and order this cable and the reccomended tools from  The video instructions make it an easy fix. AND when you install the new cable, you can seat it ABOVE the battery for a potentially longer life...  There maybe onlines stores with cheaper options, but $30 is not a bad deal for sound. My sound has been awesome since I replaced the cable 3 months ago.  Cheers!

  tm_source=ifixit_guide&utm_medium=guide_intro&utm_content=required_items&utm_ter m=macbook_air_models_a1237_and_a1304

  • Ninialoves Level 1 Level 1 (0 points)

    same thing happened to me. i just plugged and unplugged my headphones for like a couple of times and it got fixed.

  • sdsurfer2013 Level 1 Level 1 (0 points)

    My 2010 Macbook Air audio stopped working.  Based on this forum it seems it's the audio cable.  I bought a new audio cable and replaced the old one and the whole work took me about 5 minutes.  Now everything works.



    Need the following part:

    I/O Board Cable for MacBook air A1369 821-1143-B

  • maddog357 Level 1 Level 1 (0 points)

    Thanks marcopolo, your delete bezel.plist worked for a macbook air I have been trying to fix for the past few days. My problem was slightly different than the one described by Dinan101, the internal speakers would show up on the output devices list but I still wasn't getting any audio. Thanks again.

  • marcopolo Level 1 Level 1 (0 points)

    You are welcome. It is a drag that Apple has not sorted this issue out. It is unfortunately multifactorial. For some people it is a software glitch and for others it is clearly a hardware problem. I wonder if it may also be associated with running boot camp and windows corrupting bezel.plist, but I have not seen that thread.

  • dreamcatcher1 Level 1 Level 1 (0 points)

    I have just tried to replace the audio cable but no luck. After investigating more I find a slight difference in cable notation. The new one I got has the number 821-0576-02 while the old is 821-0576-A.


    Does this matter? Is this new cable wrong or should I be ok with it?


    My Air is A1237 (Air 1.1, 1st gen)

  • rynelandt Level 1 Level 1 (0 points)

    hey guys i may have figured it out, i had the same problem, but i resolved it, okay first grab an audio cable, go to sound under your system pref then click output. if there is no output at all there thats okay    well anyways then plug in your audio cable,adjust the sound a little bit if it shows u have sound, good cuz you have the audio cable in, well then you pull it out, adjust volume a little bit and just keep doing that untill you hear the sound adjustment ding and there you go it is fixed then magicly it will show up in your mac that you have sound from your internal speakers, if that didnt fixit then in the sound settings click on use audi port for: then click output when u have headphones in   if that didnt work you should take it in to an IT group at best buy or better yet take it to an apple retail store they may be able to help/do it for you.

  • DustinHK Level 1 Level 1 (0 points)

    Also my MBA (mid 2012) stopped making sound "No Output Devices Found". It happened after I applied the latest upgrade to 10.8.4. I'm sure it's a software problem because I still have startup chimes, and I also have sound when I boot from a Carbon Copy Clone of my previous system.


    I tried about anything I could find in this thread and elsewhere:

    - PRAM reset

    - SMC reset

    - Fix Permissions

    - Fix harddrive

    - Re-apply updates (Combo)

    - Delete the bezel preferences


    I also noticed that when I try to play a YouTube movie, it freezes after about 10 to 15 seconds.


    It's quite frustrating. Of course I'm just out of warranty as well.


    I think there must be some kind of software conflict, but I don't know how to find out.


    Anyone knows something else I could try?

  • Noiseles Level 1 Level 1 (0 points)

    It´s the same to me, but on a Mac Pro !

  • Noiseles Level 1 Level 1 (0 points)

    It was definetly a not perfectly installed 10.8.4. The apple support told me to start the computer wait shortly and hold cmd+R. then there was point reinstalling. I hope it was named like that, it was 2 days ago. but it was quite selftelling. I did that and everything works fine as usuapple . Hope this helps you.

    Perheps important to metion: before that I already installed the Combo Update AND afterwards the whole 10.8.4 over the App store again. This didn´t help. It has to be in the RECOVERY mode, as mentioned above !

    Good luck !


More Like This

  • Retrieving data ...

Bookmarked By (3)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.