Skip navigation

Can't Boot Into safe mode mountain lion

5605 Views 22 Replies Latest reply: Mar 8, 2013 7:19 AM by Rob Mitchell1 RSS
  • ericfromsan jose Calculating status...
    Currently Being Moderated
    Jan 10, 2013 9:38 AM (in response to gpinnyc)

    I too have the same issue, MBP 13 A1278 with latest ML update. I have moved the original 700GB disk to the dvd bay and placed a 240GB SSD in its place. The 700GB disk is empty, ML and all data are on the SSD drive. I cannot boot in Safe Mode, when I do, it stays stuck in the progress bar at about 15%.

  • ericfromsan jose Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 15, 2013 7:49 AM (in response to ericfromsan jose)

    Might be related to this discussion.

  • Rob Mitchell1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 7, 2013 7:52 AM (in response to gpinnyc)

    Not sure if this adds to the discussion...


    I'm still on 10.7, and the progress bar freezes at about 25% when I attempt to boot into safe mode on my Mac Pro. I tried starting up in safe mode from a 10.6 volume and it boots quickly. I've tried repairing permissions, etc. on 10.7, but didn't help. I'm wondering if I should reinstall the OS or try installing Snow Leopard, to see if either helps. Based on some comments, I worry it will just be a time-waster, and I don't really have a ton of spare time.


    Any thoughts?

  • Topher Kessler Level 6 Level 6 (9,305 points)
    Currently Being Moderated
    Mar 7, 2013 8:02 AM (in response to gpinnyc)

    One cause for this is a damaged HFS+ attributes file, which can cause Apple's fsck_hfs routine in Safe Mode to hang. The only way around this is to either use DiskWarrior or another such tool to attempt a repair, or to completely format and repartition the drive to ensure the filesystem structure is rebuilt, and then restore a backup to it.


    I've found this can be the case even when Disk Utility on the boot drive does not pick up any problems; however, if it does happen then Disk Utility on an external drive or on the OS X Recovery HD partition may show a similar hang when run.

  • Rob Mitchell1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 7, 2013 9:34 AM (in response to Topher Kessler)

    Thanks for your response, Topher. That leads me to more questions...


    Is there a way to determine with confidence if the problem is indeed the HFS+ attributes file?


    I haven't used DiskWarrior in a long while, and it appears their only upgrade from my version 3 software is to ship a physical disk to me for $49+shippping (or pay $99+shippping, and have immediate access to a download too -- not sure why they have that policy). Plus my internal optical drive died (though I do have a USB external)... Is there another tool you recommend?


    As for the restore option, would cloning the drive using SuperDuper somehow fix the problem, or does it clone the bad HFS+ attributes file? If SuperDuper clones the problem, what method of backup and restore would not clone the HFS+ attribute file?



  • Topher Kessler Level 6 Level 6 (9,305 points)
    Currently Being Moderated
    Mar 7, 2013 10:50 AM (in response to Rob Mitchell1)

    Run the followign command at the Terminal to boot the system in Safe-Single User mode (or replace the "s" with a "v" in the command to do the same in Verbose mode--they should be equivalent for this purpose):


    sudo nvram boot-args="-s -x"


    Provide your password and then restart the system and it should load in a text-based environment. A number of things will scroll up the screen with the most recent events happening at the bottom. One of these should be an indication of "fsck_hfs" running and checking various files. If it stops at the step of checking the attributes file and will not proceed even after an extended period of time, then you are experiencing this problem (you will have to hard-reset to exit if this is the case, and then reset the PRAM to clear these variables so it doesnt always load in this mode).


    File-level cloning likely would help the situation. Just be sure to fully format the old drive before cloning back.

  • Rob Mitchell1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 7, 2013 2:45 PM (in response to Topher Kessler)

    Thanks for the advice!

  • Rob Mitchell1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 8, 2013 7:19 AM (in response to Topher Kessler)

    Topher, thanks to your spot-on advice, my computer will boot again in safe mode!

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.