Skip navigation

Automator 2.2 "Copy Finder Items" Action Error

1770 Views 7 Replies Latest reply: Oct 21, 2013 10:40 PM by mikeharg RSS
JSchoenberger Calculating status...
Currently Being Moderated
Sep 4, 2011 1:02 PM

Hello all,

 

When I try to create an Automator workflow that finds a type of file (pdf) in a nested folder structure and copies those files to another folder - essentially extracting the pdfs from their nested folders - I get an error message.

 

 

1) I use the "find Finder items" action. I specify the top-level folder and set the kind to "document"

2) It returns 56 items

3) I use "copy Finder items" action and specify a new folder

4) The copy action fails stating that a given file "couldn't be saved in the folder". It does not always error-out on the same file. Changing or creating a new folder doesn't help.

 

 

I have tried this under two user accounts with the same result. I have tried deleting preferences. The same error results.

 

Any ideas?

 

I am running 10.7.1 on a 15" MacBook Pro, early 2011.

MacBook Pro, Mac OS X (10.7.1), Early 2011 i7 Model

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.