Skip navigation

Lost keywords when dragging to a photo.

365 Views 5 Replies Latest reply: Jan 10, 2014 5:39 PM by MLModel RSS
PJunkins Calculating status...
Currently Being Moderated
Mar 8, 2013 7:13 AM

When dragging some keywords from the Keywords HUD to a photo I dropped them prior to the pic. They disappeared from the HUD. When I used the search feature in the HUD they could not be found and if I check the keywords in the filter no pictures are displayed. The keywords still show attached to the pictures and I exported the keywords list and the missing keywords show in the exported list. I thought I could just import that list back but I can't select the list.  Any ideas of how to get them back in the HUD?

Aperture 3, Mac OS X (10.7.5)
  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Mar 8, 2013 7:27 AM (in response to PJunkins)

    When the keywords are inconsistent, it usually helps to repair the Aperture library using the Aperture Library First Aid Tools.

    Quit Aperture and relaunch it with the key combination ⌥⌘ firmly held down. Then select "Repair Database" from the First Aid panel.

     

    Regards

    Léonie

  • MLModel Calculating status...
    Currently Being Moderated
    Jan 10, 2014 3:51 PM (in response to léonie)

    I have this problem even after a complete Aperture database rebuilding. I was dragging a selection of keywords to selected photos and, changing my mind, I let the cursor drop the keywords back into the HUD. They disappeared. Photos still have those keywords. Exporting does not show the keywords. Adding the keywords back gives me new keywords, but although they are the same word they don't connect to the photos that had the old keywords. I can filter the library by the old keywords.

     

    There is something else weird about this situation, but it is compliated to explain. I think I lost two keywords, call them A and B. A was under X in the hierarchy and B was under Y. When I filter by keyword I see "A (B)", and selecting that does in fact filter by A even though A is not in the keyword HUD. B also shows up by itself in the keyword filter, and that works too, although B is not in the HUD. The problem, of ourse, is that if I add A and B back to the HUD I am getting a different keyword and none of the existing photos will be tagged with them. On the other hand, I can't tag any more photos with either of the keywords because they are not in the HUD.

     

    I am ready to throw away about 20 hours of importing photos and keyword labeling and go back to my last backup of the library. Very frustrating.

     

    I know there are other threads discussing this problem. This one seemed the most recent and relevant.


  • léonie Level 8 Level 8 (46,330 points)
    Currently Being Moderated
    Jan 10, 2014 4:28 PM (in response to MLModel)

    Have you checked, if the search field is cleared in your HUD? If you typed in an invisible character, like a space, some keywords may be hidden. Have you searched your HUD for your keywords by entering them in the search field? You should see multiple occurrences.

  • MLModel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 10, 2014 5:39 PM (in response to léonie)

    Thank you for your amazingly prompt reply. I see what you mean about having a space or something screw up the search. I found the keywords after looking for them again. I think rebuilding the database did actually fix the problem and I didn't follow up with some of the things I had tried before. The two keywords got moved to the top level of my keyword hierarchy, one under the other. They were near the end between two other similar words, easy to miss. I am embarrassed but grateful and relieved.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.