Skip navigation

Aperture 3 Exif-data date is incorrect

1061 Views 9 Replies Latest reply: Mar 19, 2013 3:00 AM by mwaltari RSS
mwaltari Level 1 Level 1 (30 points)
Currently Being Moderated
Mar 9, 2013 1:05 AM

I have searched the discussions data-base but could not find a solution for my problem;

I upgraded my hard-disk this week and imported Aperture library from a back-up. Had to erase my back-ups when I started a new TimeMachine back-up (have two hard-disks in my MacBook Pro now, HDD and SSD).

Yesterday I noticed that Aperture exif-data date is incorrect in all my photos - execept the very new ones taken this year.

There is no specific time-difference between the actual time and the time that Aperture but in all photos the year is 2013. The time, day and month seem to be correct.

Exif is shown correctly in Reveal and in Preview, so this narrows the problem to Aperture 3.


I tired to repair and to rebuild the data-base, without a luck with this problem. Many distorted previews were corrected though.

Does anyone have experienced the same, or do you have any idea on how to fix this without exporting and re-importing all the pictures after re-installing aperture???

I tried to re-import a picture, but the exif-date stays the same, y. 2013 despite it's real date is in 2009.

Aperture 3
  • léonie Level 8 Level 8 (46,510 points)
    Currently Being Moderated
    Mar 9, 2013 1:54 AM (in response to mwaltari)

    imported Aperture library from a back-up

    How exactly did you "import" the Aperture Library from your backup? Did you restore the library or import it into a new library?


    What kind of backup was it? A vault, a Time Machine backup, a clone? Or the Time Machine Backup you just erased?


    Are all dates incorrect or only the EXIF dates? The Info panel can also be set to show

         EXIF > Date

         Image > Date Created

         Aperture > Last Modified Date

         Aperture > Import Session



    Are the "Date Created" and "Last Modified Date" o.k.?





    Screen Shot 2013-03-09 at 10.48.36.png

  • léonie Level 8 Level 8 (46,510 points)
    Currently Being Moderated
    Mar 9, 2013 2:29 AM (in response to mwaltari)

    It was a TimeMachine backup that I have already deleted from my Time Capsule, and I imported the last backup file of my library to the new SSD, whereas the referenced library backup I imported to my newly formatted 1TB HDD (which is replacing my old DVD drive).

    When I restored my library from Time Machine the Setup Assistant copied the library from the TM backup to the SSD, and my dates are all correct. You did not use the intial setup or Migration Assistant, but copied or restored the library from Time Machine? Did you dive into the TimeTunnel to let Time Machine restore it, or did you copy it from the backup using the Finder?


    Maybe the different method of copying from the backup accounts for the date differences.


    What is your Aperture 3 version? Mine is AP 3.4.3.

  • léonie Level 8 Level 8 (46,510 points)
    Currently Being Moderated
    Mar 9, 2013 3:31 AM (in response to mwaltari)

    It is a pity, that you had to erase the original TM backup.


    And you are saying, that repairing and rebuilding the library did not help.

    Perhaps I should re-install everything,


    Reinstalling Aperture will not help, since the problem is with your library and not with the program.

    So you'll have to fix the library that you have now. It will be a lot of work to manually correct the dates. Before you start, make sure your backup is current and readable.


    I see two ways to get this fiexed.

    • You said, that exporting the originals and reimporting gave the correct dates, but this way you will lose your edits and captions (you could use the lift&stamp tool however to stamp the annotations and edits from your current versions onto the reimported images).
    • Since only the years seem to be off, you could use "Metadata > Adjust Date and Time" to batch change the dates for one project at a time. I would refrain from writing the changes to the EXIF, since your EXIF dates are o.k.




    P.S. One more thing to try: Aperture recreates the library when importing into a new, empty library. You could try to import your current library into a new library and see, if the EXIF are interpreted correctly.

  • léonie Level 8 Level 8 (46,510 points)
    Currently Being Moderated
    Mar 9, 2013 7:41 AM (in response to mwaltari)

    Good luck!

    At least your photos are all save.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.