14 Replies Latest reply: Mar 9, 2013 12:55 PM by Motib
Motib Level 1 Level 1 (0 points)

When I edit an image, and then export it to use in Imove, all of the stacked versions go into Imovie.  How do I solve this problem. (I have 'unstacked' the versions in Aperture.


Mac OS X (10.7.2)
  • 1. Re: Problems exporting an edited image to iMovie
    léonie Level 9 Level 9 (51,645 points)

    How exactly are you exporting to iMovie?

    • Are you selecting the edited version in the Browser and using "File > Export > Version"?
    • Or are you dragging the thumbnail from the Browser window to the Desktop for export?
    • Or are you accessing the Aperture Library from the Media Browser in iMovie?

     

    And what are your Aperture and iMovie versions?

     

    Regards

    Léonie

  • 2. Re: Problems exporting an edited image to iMovie
    Motib Level 1 Level 1 (0 points)

    L'eonie

     

    I am using Aperture version - 3.4.3; iMovie version - 8.0.6

     

    I am exporting the version as you described.

  • 3. Re: Problems exporting an edited image to iMovie
    léonie Level 9 Level 9 (51,645 points)

    I tried, Motib, but I found no way to reproduce the problem you are seeing. When I export an edited version, stacked or not, only one version will be exported.

     

    Do you see the same, when you try exporting from a different Aperture library? You may want to craete a test library and import a few image files, just to check, if your Aperture library needs repairing.

  • 4. Re: Problems exporting an edited image to iMovie
    Motib Level 1 Level 1 (0 points)

    I am at a loss.  When I try the exact procedure on another computer - it works.  All other things remain constant, including versions of software.

     

    I have no idea what to do to rectify thie problem.

  • 5. Re: Problems exporting an edited image to iMovie
    Frank Caggiano Level 7 Level 7 (23,800 points)

    What you say is happening is hard to follow. If you export a version from Aperture a single file of the  type spesified in the export ipreset s created from the version, JPG, TIFF, whatever.

     

    When exporting a version stacks have no bearing on the outcome. A version can be part of a stack but when exported (unless the stack was selected) only that one version is made into an external file.

     

    So  what format and export preset are you using? When the image is exported and you look at the file with preview before you import that file into iMovie what do you see?

     

    How are you actually doing the export? Léonie asked you  but your answer was vague. You wrote back that you were exporting the version as described but Léonie described three different ways to export.

     

    If you could respond to these questions we might be able to clear up the problem.

     

    regards

  • 6. Re: Problems exporting an edited image to iMovie
    Thomas Emmerich Level 4 Level 4 (3,485 points)

    This sounds vaguely familiar as a bug that was in Aperture at one point last year. I could totally be imagining this but my brain says there was a some bug causing all the images in a stack to be used in some circumstances. But the fact that you are using Aperture 3.4.3 should make a past bug irrelevent. Maybe you should try reinstalling Aperture on the Mac having the issue.

  • 7. Re: Problems exporting an edited image to iMovie
    Motib Level 1 Level 1 (0 points)

    Frank -

     

    My method for exporting is - to select the edited version (JPG) usiing "File > Export > Version".  It is then exported to the desktop and shows as one (1) image.  When it is dragged into iMovie, all of the images show.

     

    I hope this clarifies my vagueness.

  • 8. Re: Problems exporting an edited image to iMovie
    léonie Level 9 Level 9 (51,645 points)

    but my brain says there was a some bug causing all the images in a stack to be used in some circumstances

    There was a bug syncing albums to the iPhone. All images in a stack were synced, not only the stack picks. But that did apply to the export of image versions, afaik.

  • 9. Re: Problems exporting an edited image to iMovie
    Thomas Emmerich Level 4 Level 4 (3,485 points)

    Yes, that was it. Not relevent here I guess.

  • 10. Re: Problems exporting an edited image to iMovie
    léonie Level 9 Level 9 (51,645 points)

    When it is dragged into iMovie, all of the images show.

    And where in iMovie do you drag the image to? I cannot check with iMovie 8 unfortunately, I upgraded to iMovie 9.  In iMovie 9 I can only drag images to a project, not to an event. And in the project the exported images will just appear as a single still frame. What do you see in iMovie 8?

  • 11. Re: Problems exporting an edited image to iMovie
    Frank Caggiano Level 7 Level 7 (23,800 points)

    Motib wrote:

     

    Frank -

     

    My method for exporting is - to select the edited version (JPG) usiing "File > Export > Version".  It is then exported to the desktop and shows as one (1) image.  When it is dragged into iMovie, all of the images show.

     

    I hope this clarifies my vagueness.

    How does it 'shows as one (1) image'? What are you looking at the file with? How then are you importing this file into iMovie?  And why are you exporting/importing rather then using the Media Browser in iMovie?

  • 12. Re: Problems exporting an edited image to iMovie
    Motib Level 1 Level 1 (0 points)

    The one (1) image a JPG image on the desktop. 

    The image cn be opened in Preview. 

    I drag the image into iMovie. 

    Just my particular workflow.

  • 13. Re: Problems exporting an edited image to iMovie
    Frank Caggiano Level 7 Level 7 (23,800 points)

    What happens if you use the Media Browser?

  • 14. Re: Problems exporting an edited image to iMovie
    Motib Level 1 Level 1 (0 points)

    I'll have to leave this discussion in limbo for a while - thanks for the input.  I'll get back  shortly.