Skip navigation

Unable to use D-Link 320 Share Center NAS

13194 Views 9 Replies Latest reply: May 20, 2013 12:29 AM by EJW Tas RSS
EJW Tas Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 1, 2012 7:10 PM

Has anyone successfully set up a D-Link DNS320 NAS on their network? The DLink manuals provide minimal to nil instruction for Mac setups.


I have setup the NAS with 2 3TB WD Caviar Green drives, but everytime I drag files to folders on the NAS, the Finder either asks for a password or tells me outright I don't have permission to read/write files on the NAS. Other times when I try to dismount the NAS, I need to reboot the Finder to release the NAS so it can be unmounted.


None of my folder settings (vies, location, view options) stick from one view/setting to the next. I can't see how the drives were formatted (I am assuming Windows-specific formatting, over which there is no control or access to options).


I have set up the read/write access using the DLINK web interface ( and all appears to be normal until I try to use the NAS.


I have tried to fix ACLs and permissions etc with individual folders and with the volumes themselves using Terminal command "sudo chown -R `id -un`:`id -gn` " but this hasn't worked.


Various other sites have been visited (eg / and but no help there. The DLINK web pages are near-totally useless.


Unless someone else has gotten theirs to work, its going into the bin and I will have wasted $$ in buying the box

MacBook Pro, Mac OS X (10.7)
  • Linc Davis Level 10 Level 10 (108,160 points)
    Currently Being Moderated
    Apr 1, 2012 7:40 PM (in response to EJW Tas)

    That thing looks like a piece of junk, but this might help:


    OS X Lion: Connecting to legacy AFP services

  • rodney_robles Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 7, 2012 12:21 AM (in response to EJW Tas)

    You seem to be using Lion, hence, you can check this out:

  • tonyb1986 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 6, 2013 4:15 PM (in response to EJW Tas)

    i was having the same problem and with a bit of fiddling on my part its actually extremely simple to setup and use flawlessly when you know how


    Under the Applications tab there is an icon for Local backups

    enter that then to the left is the time machine option, enable this (AFS will automatically be enabled if it is not already)


    then under time macine settings, share the drives you require and its as simple as that, from there use finder on your mac and you should have 2 or 3 dlink devices (depending on the name or how many drives you have) and you can now freely browse, delete, copy etc and even use the time machine backup utility on your mac!!


    hope this helps as its been a headache for me too!!!!

  • tonyb1986 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 10, 2013 10:58 AM (in response to EJW Tas)

    yea i read earlier in the post that was the case! hopefully it may help others too, all round im very happy with my NAS and would recommend them to anyone looking for an easy storage/backup option without paying the price of apples time caplule!


    from what i have heard, the Netgear NAS devices are the best to use and even more so as they are simple to upgrade memory as well as make modifications.

  • luke.lindsay Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 10, 2013 12:30 AM (in response to EJW Tas)

    (Using OS10.8.3) I too have had no end of problems with my DLink NAS 320. EJW, I know you have trashed yours in frustration and I nearly did the same, but hopefully to help others I am posting this. My goal was to create a password protected backup disk using the NAS. I tried all sorts of formatting and shares combinations and each time copying files failed at some point. The posting by TonyB1986 helped and most of the files transferred ok but I still had permission problems/failure moving old application installers/files from PowerPC days.

    The solution that has so far worked was I reformatted the NAS  as JBOD then using Disk Utility I made a password protected SparseBundleDisk image and saved it to the NAS Volume. I didn't set up any users or shares and just connect to the Volume as Guest. I then open the Sparse image with a password and this setup hasn't failed to copy anything yet and all is secure!


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.