7 Replies Latest reply: Mar 11, 2013 12:07 PM by hedgert
hedgert Level 1 Level 1 (0 points)

I have a large Aperture library and have been going through it over time to name the faces, but Aperture keeps presenting me with "faces" that don't have a picture.

This happens in two places, if I've selected a named face and I'm looking at or confirming faces for that name then I get some faces offered to me where there is no picture of the face:

Screen Shot 2013-03-08 at 10.13.09 AM.png

And in the faces view before selecting a name, where you are presented with unnamed faces to name, I get offered faces like this:

Screen Shot 2013-03-08 at 10.12.59 AM.png

For Aperture to show these to me it presumably must have a photo somewhere, so presumably this is something to do with missing thumbnails or previews.  I have done a complete repair/rebuild of my library - which had no effect - so I'm stuck.

Has anyone else seen this; any suggestions on how to get these photos to show an image?


iMac, OS X Mountain Lion, Aperture 3.4.3
  • 1. Re: Face detection presents faces with no picture
    léonie Level 9 Level 9 (51,805 points)

    Does naming faces work on a new test library? Try to create a new, empty library (File > Switch to library > Other/new) and import some photos and name some faces. Does it work well with a new library?

     

    If Aperture works well on a different library, probably the "Faces" database in your current library is broken. Do you have a backup of your current library from the time, "faces" was still working correctly, or did it never work correctly with that Aperture Library?

     

    Regards

    Léonie

  • 2. Re: Face detection presents faces with no picture
    hedgert Level 1 Level 1 (0 points)

    Thanks leonieDF.

    It's not that faces doesn't work at all - I can see, name and get suggested faces with the library as it is - so I don't see what I'm going to prove by creating a new library.

    You suggest my faces database might be broken - what does that imply - is no repair possible?

    I have online backups with continuous changes backed up and yes, there was a time maybe 3 months ago when this problem wasn't happening, but I've added hundreds of photos, tags, names etc since then - so I don't want to revert the whole library.

    Are there any utilities to help with corrupted faces databases?  Or is there a way of drilling into the photos that don't show an image to find which ones they are to see if I can work out what's happened to them?

  • 3. Re: Face detection presents faces with no picture
    léonie Level 9 Level 9 (51,805 points)

    It's not that faces doesn't work at all - I can see, name and get suggested faces with the library as it is - so I don't see what I'm going to prove by creating a new library.

    I wanted to be sure that Aperture is working correctly, if the library has no issues.

    You suggest my faces database might be broken - what does that imply - is no repair possible?

    You have tried the built-in repair options - repair library, rebuild library. If you have enough disk space you could try to rebuild the library by importing it into a new library. Add some images with faces to it, before you import your old library. This will recreate the library and the Faces database. I cannot guarantee that this will solve the trouble, however. When I had a similar problem, only manually repairing the library package by replacing the "Faces" database inside from the backup did help, but you have added too many faces since the last working backup to go this way.

     


  • 4. Re: Face detection presents faces with no picture
    hedgert Level 1 Level 1 (0 points)

    Thank you again leonieDF.

    If I create a new library as you've suggested and import my old library - will the import include the faces already named - or is it effectively starting again?

  • 5. Re: Face detection presents faces with no picture
    léonie Level 9 Level 9 (51,805 points)

    It should include all named faces, places - everything you now have in your library. But you will need plenty of free disk space because Aperture will need working space in addition to the library.

  • 6. Re: Face detection presents faces with no picture
    hedgert Level 1 Level 1 (0 points)

    Great thank you - I have a spare external disk so I've kicked off an import on that (which has plenty of space) - I'll post back when it's finished with the results.

  • 7. Re: Face detection presents faces with no picture
    hedgert Level 1 Level 1 (0 points)

    leonieDF - I came back to my Mac after several days and the import was complete and so the faces problem looks better.  I've seen the occasional person where when I go into their faces some of the pictures show up as a blank dotted box, and then when I've moved my cursor over the blank box the picture has appeared - and that wasn't happening before.  And I haven't seen any of the templated sillouhettes appearing in the unnamed faces at the bottom - although a consequence of the import is that I've lost some of my naming, so there are a load of faces appearing as unnamed that I'd already named, that I'm having to work through again, and until I've done that completely I can't be sure there are none.

    But either way the situation is much better (possibly fixed completely) and as a side benefit I've also noticed Aperture performing more quickly than before.

    So thanks for your help.