Skip navigation

Flash 11.5 hack for PowerPC

12101 Views 31 Replies Latest reply: Feb 23, 2014 10:38 AM by Patrick Duncan RSS
1 2 3 Previous Next
applefan_since1998 Level 1 Level 1 (25 points)
Currently Being Moderated
Feb 6, 2013 8:03 AM

Just wanted to share this. Someone tweaked the last hack so that now it shows up as 11.5. I've tried it and it works.

http://scriptogr.am/nordkril/post/adobe-flash-11.5-for-powerpc

Dual 800mhz PowerMac G4 / Powerbook G4 1.33mhz / BW G4 500mhz, Mac OS X (10.4.11), Mac Pro 2.66 dual core/ G5 dual 2.0
  • Klaus1 Level 8 Level 8 (43,415 points)
    Currently Being Moderated
    Feb 6, 2013 10:57 AM (in response to applefan_since1998)

    Thanks for posting - a useful hint!

     

    Can't speak for Tiger but it works for Leopard.

     

    But it does not solve a problem where a website, such as the BBC, not only requires the latest version of Flash Player, but still only works with Intel Macs.

     

    For users of PPC Macs there is this workaround:

     

    I cannot watch flash videos on the BBC website or on BBC iPlayer, although all other flash videos (YouTube for example) are fine.

     

    For reasons that passeth all understanding, they work with the PPC version of Firefox, called TenFourFoxG5.app, once you have anabled plug-ins, as it does not natively support Flash.

     

    You can download TenFourFoxG5 from here:

     

    http://www.floodgap.com/software/tenfourfox/

     

    Now for the interesting bit: TenFourFox, like Firefox, does not support most plug-ins. Unless you are prone to headaches (in which case don't) you can read about that here:

     

    http://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported

     

    But there is a workaround!

     

    Open TenFourFox and type in the address bar: about:config (no spaces) and click return. This gives you a warning that it might harm the application. Ignore that and click on 'I'll be careful, I promise' and you get the config file that you can edit - with great care.

     

    Look/search (scroll down) for: tenfourfox.plugins.enabled

    Set it to true. (Double click it to toggle it)

     

    Now close TenFourFox, open it again, and Flash will now work, as it now uses the plug-ins that Safari has stored.

     

    I am using Flash 11.5.502.55 in TenFourFox and it works just fine, including the BBC news site and iPlayer.

    iMac iSight G5 2.1 GHz, QT Pro 7.7, Mac OS X (10.5.8), iLife 9 but prefer iMovie 6
  • jcm9812345 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 8, 2013 6:34 PM (in response to Klaus1)

    It works on tiger 10.4.11 so it is awesome! lets me do everything now

  • BDAqua Level 10 Level 10 (114,790 points)
    Currently Being Moderated
    Mar 9, 2013 11:56 AM (in response to applefan_since1998)

    Thanks to both, does work on G5/10.4.11/SeaMonkey & TenFourFox.

  • romko23 Level 2 Level 2 (395 points)
    Currently Being Moderated
    Mar 10, 2013 11:02 PM (in response to applefan_since1998)

    Has anyone modified the hack to allow it to display 11.6? I heard that Adobe brought out 11.6 flash, though there really is no difference between that and 11.5.

  • Texas Mac Man Level 8 Level 8 (44,245 points)
    Currently Being Moderated
    Mar 11, 2013 1:40 PM (in response to applefan_since1998)

    Thanks for the link. For a long time I had been using the 11.1 Flash hack, but recently it caused all of my browers to frequently crash. Finally had to disable.

     

    I installed the file in the Library>Plug-ins after deleting the old hack. I'm using TenFoxFour version 17.0.4 with Tiger. To activate the plug-in, (in the TenFoxFour menu) go to Tools>Add-ons and make sure the Flash plug-in  shows Disable on the button.

     

    Next I'm going to install on Leopard and also on my PowerBook running Tiger.

     

     Cheers, Tom

  • romko23 Level 2 Level 2 (395 points)
    Currently Being Moderated
    Mar 11, 2013 6:14 PM (in response to Texas Mac Man)

    What about a hack for 11.6 flash?

  • eldorado67 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 9, 2013 10:51 AM (in response to applefan_since1998)

    Thanks, tested and working on my 1.67 GHz Powerbook with Leopard.

     

    Too bad we are no longer getting security updates from Apple themselves to Leopard. I feel abandoned.

  • romko23 Level 2 Level 2 (395 points)
    Currently Being Moderated
    Apr 11, 2013 12:17 AM (in response to eldorado67)

    Don't be.. dude.. we are all your family now! And we all support each other with PPC.. PowerPC won't die until the day comes when we can no longer access the i-net or do anything that we used to do on them..

     

    BDAqua knows what I am talking about.

  • William Stanton Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2013 4:05 AM (in response to romko23)

    Looks like someone updated it again. I'm not sure if I can post the link here, but it's on another Mac site.

  • iminthemix Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 4, 2014 7:35 PM (in response to applefan_since1998)

    2014 update-Looks like BBC has killed the PPC mac on its site for all Flash content. 11.5...hack no longer works for BBC. Tech at BBC told me they were surprised any of their players worked for video. I reminded them Youtube and other Flash sites often work fine, BBC no longer does. e.g. the BBC is the problem.

     

    Anyone who hears of a fix, let me know!

     

     

    Thanks

  • Klaus1 Level 8 Level 8 (43,415 points)
    Currently Being Moderated
    Feb 5, 2014 1:32 AM (in response to iminthemix)

    See my post in this thread dated Feb 6, 2013.

  • Lin Level 2 Level 2 (235 points)
    Currently Being Moderated
    Feb 8, 2014 4:15 PM (in response to Klaus1)

    I have the hack you mention in your Feb.6, 2013 post, but it seems this one is now obselete.  Do you know of any new ones?

     

    Thanks,  Lin

  • Klaus1 Level 8 Level 8 (43,415 points)
    Currently Being Moderated
    Feb 8, 2014 4:27 PM (in response to Lin)

    What version of OS X are you running, and what version of TenFourFox?

  • Lin Level 2 Level 2 (235 points)
    Currently Being Moderated
    Feb 8, 2014 9:16 PM (in response to Klaus1)

    I am running OS 10.5.8 on a G5 PPC, and my TenFour Fox is version 24.2.0.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.