13 Replies Latest reply: Mar 11, 2013 8:03 PM by aapl.crox
aapl.crox Level 1 Level 1 (0 points)

I'm not sure what is happening, but this is a major crisis!!! For some reason starting today, aperture is reseting all my curves adjustments! What would happen is, when I click on a picture to view it the curve would should momentarily for half a second (I could even be able to see the actual curve on the left) and then after that aperture would reset it. It doesn't reset it to the default state, what it would do is set the left and right slider to match the lowest blacks and highest white. Please help me, how do I stop this? I don't want to retouch my entire photo library!

  • 1. Re: Aperture is reseting all my curves! HELP!
    léonie Level 9 Level 9 (51,795 points)

    I have never seen this happen before. It looks like Aperture were reprocessing your images for an upgraded raw processing.

     

    What is your Aperture version and your Mac OS X version?

    How did you apply the Curves-adjustments? Are they part of a plug-in package with predefined adjustments, that you installed as an add-on? Or did you define your own Curves-presets?

     

    Have you upgraded Aperture recently? Installed any plug-ins? Moved your Aperture Library? Did you have any crashes or needed to force-quit?

    Do you shoot raw or in another image format? Where is your library located? Is it referenced or managed?

     

    And do you have a backup or vault, where you could restore your library from? If not, I'd recommend to make a backup asap, before you touch, edit, and currupt any more image versions.

     

    Regards

    Léonie

  • 2. Re: Aperture is reseting all my curves! HELP!
    aapl.crox Level 1 Level 1 (0 points)

    Thanks for your feedback, I'll try to answer all those questions:

     

    I'm using latest version of OSX.

     

    I'm using latest version of Aperture.

     

    I applied the curves adjustments by using the curves brick. Sometimes I use effects/presets that put in their own curves.

     

    I use the niksoftware plugins sometimes, but it basically creates a new file so it doesn't really have anything to do with the curves.

     

    I have no upgraded aperture recently, or installed anything. However two things I did in the past few days:

    1) Aperture crashed randomly at one time. I just relaunched it and it seems to run just fine so I just continued.

    2) Aperture imported some photos from my camera and it says "Raw format not recognized" so what I did was rebuilt my database (by holding option+alt when launching). Afterwards the unrecognized images are shown.

     

    My entire library is managed, no references. I only shoot RAW.

     

    I have a time machine backup but no vaults. I'm going to roll back to a time machine version 3-4 days ago and see if the curves is still a problem. I will report back.

  • 3. Re: Aperture is reseting all my curves! HELP!
    JasoninaJeep Level 1 Level 1 (5 points)

    I've had this exact thing happen to me (https://discussions.apple.com/message/21128033#21128033). The bad news is that I don't have any "fix" for you. I restored my library from a backup but now I will always be afraid to rebuild my library in any future troubleshooting efforts.

  • 4. Re: Aperture is reseting all my curves! HELP!
    aapl.crox Level 1 Level 1 (0 points)

    Jason, so yours was due to a rebuild too?

  • 5. Re: Aperture is reseting all my curves! HELP!
    JasoninaJeep Level 1 Level 1 (5 points)

    I don't recall if an initial rebuild triggered the problem. I just remember opening Aperture one day and watching it change photo after photo that I'd select in the viewer. I don't remember what I was working on or if I was troubleshooting something else. But I can say that I proved to myself that a rebuild will repeat the problem; I just can't confirm if it was an initial cause.

  • 6. Re: Aperture is reseting all my curves! HELP!
    aapl.crox Level 1 Level 1 (0 points)

    Is there seriously no way to fix this? This is the absolute worst experience I can have. Aperture is essentially deleting my photos....all my photos are touched up and now they are gone....

  • 7. Re: Aperture is reseting all my curves! HELP!
    aapl.crox Level 1 Level 1 (0 points)

    Actually I'm pretty screwed I think....does anyone use Aperture with time machines? I think when you restore a library from time machine, you HAVE to rebuild the database before you can use it. In other words, I will always be stuck with this bug by using time machine. There's no way to get my photos back.......

  • 8. Re: Aperture is reseting all my curves! HELP!
    JasoninaJeep Level 1 Level 1 (5 points)

    I used Time Machine to recover my library to a pre-curve-disaster state. Once restored you don't have to rebuild the library. The only thing I lost was metadata entry (keywords, location, etc) but my curves weren't screwed up.

  • 9. Re: Aperture is reseting all my curves! HELP!
    aapl.crox Level 1 Level 1 (0 points)

    Do you know if this bug only cleared curves or possibly other things too? I'm trying to debating whether it's better to redo all my curves or just keep trial and error'ing with my TM to see which day has the pre-curve-diaster date? (Each round of restore is 16 hours for me).

  • 10. Re: Aperture is reseting all my curves! HELP!
    JasoninaJeep Level 1 Level 1 (5 points)

    The ONLY thing I saw change were the curves adjustment brick. Each of the other adjustments remained the same for the pictures. Metadata remained unchanged as well. Did you happen to read through the past discussion I linked? The article from apertureexpert.com described what the curves changed to. Essentially it replaced my s-curve adjustment with the "old" style curve adjustment. And it happened to any photo I had adjusted in the library, not just a few certain projects, but any and all photos that had a curves adjustment applied. Ouch.

     

    My library is referenced so it was a little less painful for me to restore but it ticked me off nonetheless.

  • 11. Re: Aperture is reseting all my curves! HELP!
    aapl.crox Level 1 Level 1 (0 points)

    I couldn't find the article from your previous thread. But I'm not sure know what it is changed to would help in this situation?

  • 12. Re: Aperture is reseting all my curves! HELP!
    JasoninaJeep Level 1 Level 1 (5 points)

    No, knowing won't help fix it as far as I know. I got lucky in that I had a recent Time Machine backup & I didn't lose tons of work. I hope you're able to find an answer because I've looked around the web a bunch & couldn't find any relief.

     

    Here's the article:

    http://www.apertureexpert.com/tips/2011/11/10/new-auto-curves-behavior-getting-t he-old-way-back.html

     

    My bug was like I option-clicked the auto button in the curves brick, as he described.

  • 13. Re: Aperture is reseting all my curves! HELP!
    aapl.crox Level 1 Level 1 (0 points)

    You are exactly right, that's is the behaviour!!!!! Someone please give me a fix!