Skip navigation

why won't some of my hp printers work with os 10.8

1975 Views 8 Replies Latest reply: Jun 5, 2013 2:11 AM by fedupwithchange RSS
wilbo8 Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 27, 2012 4:27 PM

I've upgraded to Mountain Lion but two of my HP printers (laserjet 2100tn and designjet 130nr) don't now oerk. I've downloaded the latest update 2.1 (I think) and retarted my Mac Pro Intel 2010. I also have a HP F4100 - this works! The printers shwo up in printer preferences as new printers just added, documents show the printers in their print menus, and say that they are printing. Then nothing happens. The printer dialogues says ready to print. If I press resume it says printing, but still nothing happens. It even says "printed - page 1" then briefly comes up with a message saying "connected", before returning to the dialogue window noting " ready to print" again! Any ideas?

Mac Pro, OS X Mountain Lion (10.8.1)
  • VikingOSX Level 5 Level 5 (4,685 points)
    Currently Being Moderated
    Aug 27, 2012 5:14 PM (in response to wilbo8)

    I think it is tabula rasa time.

     

    Reset the PRAM on the computer.

     

    In System Preferences > Print & Scan, make a mental note of the printer short names, then remove the 130nr and 2100tn entries. Do not right-button one of these printers and choose "Reset printing subsystem," as it will also blow away all printers and preferences.

     

    Next, in ~/Library/Preferences, look for the the following files that have the above short printer names in the (binary) filename(s):

     

    com.apple.print.custompresets.forprinter.*.plist

     

    Remove only the files for the 130nr and 2100tn printers.

     

    Now, with both printers warmed up and ready, add back the 130nr and 2100tn with appropriate options set. Now, in the list of 3 printers, choose the one you want as default, and right button click on that device and mark it default.

     

    Now, in Print & Scan preferences, select Open Print Queue. Choose Printer > Print test page.

     

    You should be printing these test pages, unless there is a network issue.

     

    If it still doesn't work, you can review the Network diagnostics and Error log options from this same menu.

  • sig Level 8 Level 8 (35,770 points)
    Currently Being Moderated
    Aug 28, 2012 6:21 AM (in response to wilbo8)

    Update the printer drivers.

    http://support.apple.com/kb/DL907

  • VikingOSX Level 5 Level 5 (4,685 points)
    Currently Being Moderated
    Aug 28, 2012 1:12 PM (in response to wilbo8)

    Makes me wish for an old DECwriter 1200. Geez.

  • john10423 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 12, 2013 10:29 AM (in response to wilbo8)

    I have this exact same problem with a HP LJ 2100-M.  Except my printer is connected via a USB cable.  I had System 10.6 for quite a while, and it printed most stuff (anything that did not have a large amount of graphic content, anyway) although it perennially showed up as "offline".  I have just discovered, somewhat by accident, that it will print old-style Word documents (.doc) but not new-style ones (.docx).  A fix would be appreciated if anyone comes up with one.

  • sig Level 8 Level 8 (35,770 points)
    Currently Being Moderated
    Mar 12, 2013 3:46 PM (in response to john10423)

    Update the printer drivers.

    http://support.apple.com/kb/DL907

  • fedupwithchange Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 5, 2013 2:11 AM (in response to sig)

    I downloaded the whole package of latest drivers and no luck - the Laserjet 1022n printed page 1, 2,4,6,8 of any document whatever the source.  If you set it to print odd pages only it printed 1,4,8, etc.

     

    The answer for me was Gutenprint - thanks to the exhausted-sounding person in the HP support forums.  This is what worked for me:

     

    go to http://gimp-print.sourceforge.net/MacOSX.php , download v5.2.9 and install it.  Ignore the terrifying documentation that refers to compiling, it works automatically.

     

    control-click in the printers box in system prefs and reset the printing system completely

     

    add the LJ1022 in the usual way - osx insists on installing the useless latest driver, so let it. 

     

    Then add a new printer again, this time a box comes up which allows you to choose which printer and with what driver. 

     

    Select LJ1022 + CUPS + Gutenprint v5.2.9 as the driver, confirm that you want to add a second instance of the LJ1022 - this came up as LJ1022-1

     

    Now delete the original instance of that printer, and off you go. 

     

    Prints all the pages and doesn't hang ... so far ...

     

    This reflects my own experience and was with osx 10.8.3 and an HP 1022n on the network.  Can't say if it'll work with anything else, but there are a lot of folks out there talking about Gutenprint for unsupported printers with later versions of osx. 

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.