Skip navigation

subscribed calendars added on mac, not updating correctly on iphone

6929 Views 11 Replies Latest reply: Oct 27, 2013 2:12 PM by brianjdoherty RSS
motech Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 12, 2012 4:20 PM

i add a subscribed calendar to my mac.

it shows up on my iphone.

 

i change something in the calendar that is the main calendar that my mac and iphone are subscribing to,

the mac updates fine (sometimes i have to press refresh all but it works),

 

on my iphone though, the subscribed calendar does not see the changes.

pressing refresh does not help.

 

the only thing that forces a refresh is to restart the iphone.

 

im on icloud, running iOS 5.1 on an iPhone 4S.

  • Jeroen Pietersma1 Level 1 Level 1 (10 points)

    Same here. I use Songkick.com which offers a personalized concert calender/a personal iCal subscription.

    Works fine on my Macs, not on my iPhone.

     

    The subscription is listed on my iPhone (and it's checked) but when I add a concert, it will only show up on my Macs but not on my iPhone. Pressing refresh does not fetch the data...

     

    Deleting the calendar and re-adding it adds the latest calendar. Also, turning off Calendars in the iCloud settings on the iPhone, and then turning Calenders on again, will update the updated calendar. But that's not "push". I'd call it "hassle"

  • incubheat Level 1 Level 1 (0 points)

    I have the same problem. Just to be clear, these are subscribed calendars on iCloud. They update just fine on the Mac's iCal, but not on the iPhone. Changes to my calendar only appear on the iPhone as they do for Jeroen Pieterma1. Can we get a response?

  • Jeroen Pietersma1 Level 1 Level 1 (10 points)

    I've found a solution...

    It appears it's not possible to add subscribed calendars to iCloud. And when you subscribe to a calendar on your Mac, you can add it on your iPhone, but it won't sync any changes on your iPhone.

    The solution is to manually add the calendar.

    On your iPhone, go to "Settings", then choose "Mail, Contacts, Calendars", then choose "Add Account".

    Choose "Other" and then choose "Add Subscribed Calendar", and paste or type the address of the calendar. You're all set. The calendar dates will show in the Calendar app and the Calander list will now show a section "Subscribed", similar to the list in iCal on your Mac. Same thing, just a bit of a hidden way to add a subscribed calendar...

    It would be nice if it would all just simply work the same, so add a subscribed calendar on iCloud of your iPhone and it will show up on all your devices.. (Maybe soon, Apple?)

    I use a Songkick calendar, by the way. A great way to track concerts and organize my concert agenda

  • incubheat Level 1 Level 1 (0 points)

    Thanks Jeroen, I agree that is a valid temporary, work-around solution but I think something is definitely amiss in the way "iCloud subscribed calendars" are working and we should expect more. These calendars definitely don't show on iCloud.com but according to this apple article: http://support.apple.com/kb/HT5029, I would expect that I can subscribe to a calendar on my mac, set it to iCloud, and it should sync/update on my iPhone. Yet the calendars don't update on my iPhone. It's an already great service but none of us are seeing the behavior from the service that the article says we should expect, so somewhere something is wrong. For now I'll stick to your workaround and Songkick is pretty great!

  • pioneernoir Level 1 Level 1 (0 points)

    I've had the same problem with both iPad 2 and iPhone 4S not updating with subscribed calendars located in iCloud. This worked on both devices - I went into Settings -> iCloud then clicked on the 'Account' button. On the next screen it shows the account details, and takes a moment to give the status of you storage plan. Having completed this, my subscribed calendar immediately updated to the current version.  I don't know if this would have to be repeated every time I want to sync the calendar, as I have only done it once. This produces the desired behavior, but clearly not in the seamless way Apple intended.

  • nuthouse Level 1 Level 1 (5 points)

    Am seeing the same behavior here with 2 TeamSnap calendar subscriptions. Work great in iCal. Appear on iPhone as part of iCloud account. But they have stopped getting new/changed events on my phone. Argh.

  • Judy Level 4 Level 4 (2,235 points)

    I have the same problem with my ipad.

    There is another way to refresh the calendar and that is to turn off the device and then turn it back on again.

    But I think your way is much quicker.

    I would rather go to the icloud preferences and click on account and wait the few seconds for it to get the storage plan.

     

    The best way would be for apple to fix the problem.

  • Judy Level 4 Level 4 (2,235 points)

    I finally got it to work.

    Here are the steps I took.

     

    1. On your Mac, make sure all calendars are stored on icloud.

         http://support.apple.com/kb/HT5029

     

     

    2. On your iDevices, go to Settings - > Mail, Contacts, Calendars

        Here you will see your main account that accesses mail, contacts, bookmarks, etc.

        Any other accounts will access mail only.

     

     

    3. Scroll to bottom of list - > Add account - > Other

     

     

    4. choose Calendars - > add CalDAV Account

     

     

    5. Enter Server name

        (if an iCloud account, just put me.com.  This is where I was stumped for awhile)

        Enter user name, password, and description. This creates a new calendar.

     

     

    6. On your iDevices, go to Settings - > Mail, Contacts, Calendars

        Check to see if indeed you have another account that is Calendars, Reminders

     

     

    7. On your iDevices, go to Calendar app

        Show Calendars (a list)

     

     

    8. On the main calendar, clear checkmark from previously subscribed calendar.

        (this eliminates viewing duplicates and entries that do not update)

     

     

    9. On the next calendar below (in the list), put a checkmark next to your new one.

        Remove other checkmarks in the list from ones you do not want.

        The calendars should now update automatically.

     

        (My iPad updated almost immediately.

        My iPhone took longer but did do it eventually.

        You can always check iCloud storage to force refreshing sooner.)

  • tsooname Level 1 Level 1 (0 points)

    None of these workarounds worked for me. I was able to add the new accounts in both scenarios, but no calender sync on iPhone. Funny, my iPad does sync just fine. This is a major paine as we use basecamp to schedule meetings and my whole team subscribes to the calender. Was working, now it doesn't work...

  • Judy Level 4 Level 4 (2,235 points)

    did you turn off your iphone and turn it back on?

  • brianjdoherty Level 1 Level 1 (0 points)

    I have the exact same issue.  Basecamp calendar works just fine on my iPad (3), but not on my iPhone (4s).  Same OS on both; had problem in iOS6 and still in iOS7.  Talked to 37s and they tried to help but it seems to be a strange Apple bug.  Frustrating. 

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.