0 Replies Latest reply: Mar 12, 2013 4:46 PM by Marcelo P.
Marcelo P. Level 1 Level 1 (0 points)

I have a iBook G3 and i need to update to Safari 4.1.3 and Java for Mac OS X 10.4, Release 5 and it wont update. Please help!


iBook, Mac OS X (10.4.11), iBook G3