Skip navigation

Lost system privileges after adding SSD

272 Views 6 Replies Latest reply: Mar 13, 2013 10:18 PM by pvanhorn RSS
raduray Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 13, 2013 12:28 PM

I have a 2011 MacBook Pro.  It came with a 750GB HDD.  I just installed an OWC 120GB SSD as the Boot/Program disk and placed the old HDD, holding my Photo, Music and Download files, in the optical drive position.

 

This is how I proceeded:

1.  First I made sure to have an updated Time Machine backup to my USB external drive.  I never did have to use it, at least so far.

2.  Created Photo, Music and Download directories at the root level of the old HDD and moved all my photo, music and download files from the user folder to the new folders.

3.  I then physically installed the SSD into the HDD bay and moved the HDD to the optical bay per the instructions from OWC.

4.  Started up the system and it booted from the HDD in the optical bay.

5.  Using Disk Utility, I created two partitions on the SSD.   The first partition, titled RECOVERY was 1.1 GB and the second partition, titled SSD BOOT held everything else.

6.  Using Recovery Disk Assistant, I created a Recovery partition on the RECOVERY partition.  After that was completed, I no longer saw the RECOVERY partition in Finder.  That is as expected.

7.  Using Carbon Copy cloner, I cloned the HDD, excepting the newly created Photo, Music and Download directories, to the SSD BOOT partition.

8.  Restarted the system while pressing the Option/Alt key.  I was given the option of booting from the SSD or from the HDD and I selected the SSD.  Boot proceeded as expected and I was into my system, with all my settings and configurations apparently intact.  The only thing that was abnormal was that I had to re-establish the Dropbox link. 

9. Linked Lightroom to the Photo directory on the HDD, linked iTunes to the Music directory on the HDD, and created a symbolic link in my Users directory to the Download directory on the HDD.

10. After the above steps, I tested my applications, including Parallels, and everything seemed fine.  I thought I was done.

 

11. Several days later, I ran the I1Display Pro photo calibration for my monitor, and found that I could only change the User profile and that the System proflie was greyed out.  I subsequently tried to copy a photo paper color profile to SSD BOOT/Library/Color Synk/Profiles directory and was denied access.  I do have access to the equivalent folder in the user directory.

 

So, I obviously broke something and, although my user account has Admin privileges, I no longer have access to system files. 

 

How did I break this and How do I fix it?

 

Would appreciate any assistance.

OS X Mountain Lion (10.8.2)
  • Eric Root Level 6 Level 6 (13,835 points)
    Currently Being Moderated
    Mar 13, 2013 12:43 PM (in response to raduray)

    Apple support article:

     

    Troubleshooting Permission Issues

  • pvanhorn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 13, 2013 4:55 PM (in response to raduray)

    It's not totally clear anymore what the problem is. If you can't see the /System folder, then it's probably becuse Finder is hiding it. Even non-admins have read access on that folder. If that's not the case, then something bad happened when you copied the data over. In Finder, cick on the Go menu up top and click Go to Folder... and type in /System.

     

    If it desplays the System folder, then it's just that Finder makes it difficult to see that folder unless you know where to look. If it throws an error indicating that you do not have permission to view this folder, then you have serious permission problems.

     

    I would recommend using Disk Utility to clone data like that rather than any sort of third party application. Disk Utility is very solid in this capacity I've found, particularly when it comes to permissions.

  • pvanhorn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 13, 2013 10:18 PM (in response to raduray)

    Not sure why they chose to change the defaults for finder, but you can drag whatever you like onto that left sidebar and it will stay. They changed it incrementally in Lion and then Mountain Lion to make the system files more difficult to find.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.