Skip navigation

Airport Router Ports Not Stealthed

1193 Views 11 Replies Latest reply: May 8, 2013 3:08 PM by flyingout RSS
Hobodork Calculating status...
Currently Being Moderated
Mar 13, 2013 10:06 PM

Ever since I updated my Airport Base Station with the latest firmware update "AirPort Base Station and Time Capsule Firmware Update 7.6.3, whenever I do a port scan with Shields Up via GRC.com to test the integrity of my Router Firewall, almost all of my ports show as closed, not stealthed. Whereas prior to this update all of my ports showed as stealthed. I have reset my AEBS on a few occasions and still the same issue. Oh, this issue is not limited to just my router. A few of my friends are having the same issue after they updated their Aiport Routers with this firmware update. Does anybody have any suggestions on how I should handle this or how I can notify Apple of this issue? Any help would be greatly appreciated. Thanks!!

Airport Extreme Base Station
  • dpr11 Calculating status...
    Currently Being Moderated
    Mar 14, 2013 8:22 AM (in response to Hobodork)

    I have the same problem.  I was very pleased in the past to see that the whole display was green - meaning every port was stealthed.  But after the update to 7.6.3 there are many blue ports - meaning they are closed. 

     

    Does anyone know why these changed?  Is it possible to downgrade the firmware to get back to all green?

     

    Thanks.

  • John Galt Level 7 Level 7 (33,085 points)
    Currently Being Moderated
    Mar 14, 2013 8:50 AM (in response to Hobodork)

    You can revert to a previous firmware version temporarily. Do that and run the test again.

     

    I am at a loss to explain since this is what I see while running Firmware 7.6.1 on my AEBS:

     

    Screen Shot 2013-03-14 at 11.44.43 AM.png

     

    Screen Shot 2013-03-14 at 11.47.26 AM.png

     

    I am curious to know what changes downgrading results in for you, since it made no change in the Shields Up test that I could observe.

     

    As far as I know Apple never offered "stealth mode" for any AEBS, and the only comment I recall reading was that they were not interested in implementing the feature. Where do you find it in AirPort Utility?

    MacBooks  iMacs  iPads  AirPorts, OS X Mountain Lion,  28 years Apple!
  • edex67 Level 4 Level 4 (3,235 points)
    Currently Being Moderated
    Mar 14, 2013 9:08 AM (in response to Hobodork)

    Basically, as John Galt has said, the Extreme's firewall doesn't offer this functionality. You can request it here:

    https://www.apple.com/feedback/

  • edex67 Level 4 Level 4 (3,235 points)
    Currently Being Moderated
    Mar 14, 2013 9:22 AM (in response to Hobodork)

    The feedback form I posted, or:

    https://expresslane.apple.com/GetproductgroupList.action

    But the AirPorts have never provided the "stealthed" functionality. They have always shown as "closed".

  • John Galt Level 7 Level 7 (33,085 points)
    Currently Being Moderated
    Mar 14, 2013 9:26 AM (in response to Hobodork)

    Thanks. The results I showed are also using the latest AEBS, but if you downgrade the firmware it stands to reason whatever functions you enjoyed in the past would be restored.

     

    This is a mystery. Send Apple your feedback. They definitely read Feedback submissions, but you will not get a response, and as I wrote the last I heard was that this feature will not be implemented.

     

    Try contacting Steve Gibson. He might have an explanation and there is a chance you will get one from him vs. none from Apple. If he does please post a follow-up.

  • John Galt Level 7 Level 7 (33,085 points)
    Currently Being Moderated
    Mar 14, 2013 9:46 AM (in response to Hobodork)

    http://www.grc.com/stevegibson.htm

     

    Start here: http://www.grc.com/cb-faq.htm

     

    There is a discussion forum though I do not know how active it is.

  • ed2112 Calculating status...
    Currently Being Moderated
    Mar 28, 2013 8:35 AM (in response to Hobodork)

    I had the same problem as you with my Airport Extreme Base station.  When I was on 7.6.1, all of the service ports showed a stealth status.  When I updated to 7.6.3 firmware, most of the ports reported closed instead of stealth (I would say 95% closed is a good guesstimate).  I rolled back to the 7.6.1 firmware, and now the ports are back to showing stealth again.  I noticed in another thread that even when you rolled back to 7.6.1 that your ports are still showing closed...not stealth.  Weird.

     

    One difference might be in my particular setup:  I have set a default host IP address to a non-existent IP address (which essentially will forward all non-solicited requests to that IP address, and force a non-response to those unsolicited requests).  I use this to keep my AEBS from responding to ping requests.  To do this in Airport Utility, go to Network Tab, click on 'Network Options' and in the field for the default host, type in an IP address that is outside the DHCP range of addresses.

     

    Hope this helps.

  • flyingout Calculating status...
    Currently Being Moderated
    May 8, 2013 3:08 PM (in response to Hobodork)

    I thought I'd mention this because I've seen the confusion between the Airport firmware upgrade and loss of stealth in ShieldsUP! in a couple of threads.

     

    Steve recently changed the way ShieldsUP! detects stealth. It now detects an ICMP Destination Ureachable returned message and, argueably correctly, interprets the port as Closed rather than Stealth.

     

    Steve also mentioned on today's Security Now (#403) that you might see wierd results because some routers out there on may drop ICMP packets if too many are received too frequently.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.