1 2 Previous Next 27 Replies Latest reply: Sep 20, 2013 10:13 AM by catalan Go to original post
  • 15. Re: Mail.app- 'Remove Attachments' corrupting mails
    Screaming.Pict Level 1 Level 1 (0 points)

    Joseph,

     

    That sounds like a slighty different issue that would warrant its own thread. I've not seen that issue before.

  • 16. Re: Mail.app- 'Remove Attachments' corrupting mails
    Screaming.Pict Level 1 Level 1 (0 points)

    Hmm... an update to my previous message and a little more information on this issue.

     

    1- If you copy (or move) a message to a local folder before removing the attachment then it will not corrupt the message in the same way.

    2- However there is often slight corruption with e.g. a long-hyphen "" being replaced with " – "

    3- And when you copy the message back to the Exchange server, it then gets corrupted!

     

    This leads me to think there's a 2-part problem, one part is the slight corruption that must be something to do with code pages etc. and then that is what's triggering the complete corruption when saving to an Exchange server.

  • 17. Re: Mail.app- 'Remove Attachments' corrupting mails
    rickjtaylor Level 1 Level 1 (0 points)

    Joseph, I am having this exact issue. Did you in fact start another thread or have you learned anything new?

  • 18. Re: Mail.app- 'Remove Attachments' corrupting mails
    josephavellino Level 1 Level 1 (5 points)

    Rick, I didn't start another thread as I am not sure where I would do so.

  • 19. Re: Mail.app- 'Remove Attachments' corrupting mails
    josephavellino Level 1 Level 1 (5 points)

    Thanks for the note.

     

    I'm using the Mac Mail app on my Mountain Lion Macbook Air.

     

    It seems that message after message, when I take out attachments, Mail says that the attachments have been removed, but a lot of pieces of the email become .txt files at the end of the message.

     

    Very frustrating.

     

    Please let me know where it might be better off creating a new thread on this.

     

    Thanks in advance.

  • 20. Re: Mail.app- 'Remove Attachments' corrupting mails
    gindaray Level 1 Level 1 (0 points)

    -Screaming.Pict

     

    The account that is corrupted is a pop account. I downloaded the mail, read the mail. when i removed attachment... all chinese fonts becomes corrupted. Totally unreadable. I changed to thunderbird. Am now thinking of going back to mail due to the ability to quicklook attachment. But I am not planning to remove attachment at all from mail.

  • 21. Re: Mail.app- 'Remove Attachments' corrupting mails
    Screaming.Pict Level 1 Level 1 (0 points)

    gindaray,

     

    That's interesting- I've not seen this reported with a local (i.e. POP) account before. However I have seen similar behaviour when copying mails to a local folder and removing attachments where the mail looks OK but if you reload the folder or move the mail it proves to be corrupt.

     

    I'll try to update Apple on that point in the bug I raised.

  • 22. Re: Mail.app- 'Remove Attachments' corrupting mails
    roy16 Level 1 Level 1 (0 points)

    Hi,

     

    I can report that I also get corrupted messages after removing attachments with Snow Leopard (10.6.8) and Apple Mail (4.5 1084).  The mail server type is Exchange 2007.

     

    The problem seems to arise in messages with additional German characters (umlauts,etc.), but it doesn't happen in every instance.

     

    Thanks,   Roy

  • 23. Re: Mail.app- 'Remove Attachments' corrupting mails
    Bwsmile Level 1 Level 1 (0 points)

    Ugh. I've got the same issue as the original one, on 10.8.2, using Mail 6.2. I stopped using mail.app in favor of Outlook over a year ago because of this issue, but I just upgraded to Mountain Lion, figuring they must have fixed this by now. For the most part, I prefer mail over Outlook, but this is a deal-killer for me. I get 10 or 20 attachments/day that I need to remove to keep under my quota.

     

    Not sure what to do, other than complain to Apple via bug reporter.

     

    As far as narrowing down where this bug is, I don't think it has anything to do with Asian fonts. When I remove attachments, the email appears fine immediately (It replaces the attachment icon with a "this attachment has been manually removed" message). But if I look at a different folder and then go back to the message, it's gibberish. Also, the message appears corrupted on my iPhone as well, so it looks like mail did corrupt the message itself, not just the view (though it's different gibberish on the phone than on my Mac).

  • 24. Re: Mail.app- 'Remove Attachments' corrupting mails
    Screaming.Pict Level 1 Level 1 (0 points)

    Issue tentatively appears resolved in 10.8.3.

     

    I've trawled through 6-7 old mails with Chinese characters in them (that used to provoke the issue a lot) with attachments, copied them and removed the attachments and no corruption.

  • 25. Re: Mail.app- 'Remove Attachments' corrupting mails
    Edward Tewkesbury Level 1 Level 1 (5 points)

    Great follow-up. Thanks for the tentative good news. Please keep us posted.

  • 26. Re: Mail.app- 'Remove Attachments' corrupting mails
    Screaming.Pict Level 1 Level 1 (0 points)

    Hmmm- subsequent to this I I think that the issue is still there, however mail.app is no longer rendering the garbage text, just skipping it.

     

    I have had a couple of mails that, on removing the attachments, were suddenly missing most of the history/text. Checking the raw source shows the same symptoms as before; all of the text is there with the whitespace removed.

  • 27. Re: Mail.app- 'Remove Attachments' corrupting mails
    catalan Level 1 Level 1 (0 points)

    I have experienced this "garbage after removing attachment" issue since some time. I am now with OS X 10.8.4 and Mail 6.5, and still happens. Rebuilding mailboxes does not help. It started to happen with messages coming from a few specific Windows users, and totally unpredictable... but today it happened to me with one of the messages I had just sent out! Always normal latin fonts, perhaps with accents, but some without... 

     

    I leave aside the awkward fact that the menu item "Remove attachments" is not always available. Sometimes, with the same message in different machines but with the same OS (my account is an IMAP one, and I consult it from different machines, but always with Mail and keeping local copies), one machine does not allow you to remove attachments, and the other one does. It started to happen with Lion, and some time ago, one of the machines still had Snow Leopard, and this one always allowed removing attachments.

     

    Any help would be appreciated. For outgoing messages, removing attachments is a must; otherwise, you will have two copies of the same file in your disk (i.e., if you sent out one file of yours, which you want to keep filed in its proper place).

     

    Best,

1 2 Previous Next