Skip navigation

Random linkbucks redirect issie...please help!

7231 Views 13 Replies Latest reply: May 14, 2013 8:25 AM by Aaaarrrrgggghhhh RSS
BertieTBE Calculating status...
Currently Being Moderated
Mar 14, 2013 2:55 AM

Hello,

 

I've got this strange redirect issie in all my web browsers, and think I may have a trojan or a virus. It's driving me mad, please somone help! I'm running OSX 10.6.8 with Firebox and Chrome.

 

When I click a link on random sites it redirects me to an irellevant URL + advertising: linkbucks.com... [followed by the adress of the intenended site]

 

This occures when leaving the page you are on (e.g. changing page on the site you are viewing). It happens on any site and appears to be compeltly random.

 

Is this a virus/trojan? If so, how can I get rid of it?

 

Thank you very much.

 

Ben

MacBook, Mac OS X (10.6.8), Latest Firefox and Chrome
  • thomas_r. Level 7 Level 7 (26,950 points)
    Currently Being Moderated
    Mar 14, 2013 4:08 AM (in response to BertieTBE)

    This is not malware of any kind. As to what it is, see:

     

    Eliminating browser redirects and advertisements

  • thomas_r. Level 7 Level 7 (26,950 points)
    Currently Being Moderated
    Mar 14, 2013 6:39 AM (in response to BertieTBE)

    QHost is extremely unlikely.

     

    Did you go through that page systematically, checking the three things that it asks you to test and then trying all the suggested fixes? What were your answers to those three questions?

  • thomas_r. Level 7 Level 7 (26,950 points)
    Currently Being Moderated
    Mar 14, 2013 7:57 PM (in response to BertieTBE)

    What you're describing is not something that would be caused by OpenDNS. At this point, I would recommend that you make an appointment at the Genius Bar at your nearest Apple Store and take the machine for them to look at.

  • thomas_r. Level 7 Level 7 (26,950 points)
    Currently Being Moderated
    Mar 15, 2013 4:22 AM (in response to BertieTBE)

    The problem with trying to troubleshoot this in a forum is that it doesn't seem that you have followed through on all the instructions on the link I gave you. Have you yet tried this section?

     

    Browser plug-in issues

     

    That's the most likely to be causing the problem.

  • thomas_r. Level 7 Level 7 (26,950 points)
    Currently Being Moderated
    Mar 16, 2013 4:07 AM (in response to BertieTBE)

    Well, the fact that the problem stopped after you changed DNS settings suggests that was the source of the problem. Of course, it's also entirely possible that the problem is still not entirely fixed, and is being caused by an issue with the wireless router.

     

    As to why some sites are not loading correctly, that's not a problem that would be caused by changing DNS settings. What else have you done? You mention turning on your firewall. (Note that that won't really help with this sort of issue, and is generally not necessary. See Do I need a firewall?) Did you do anything else, like installing some kind of security software?

     

    If you have a separate wireless router and cable/DSL modem, try disconnecting the router and plugging your computer directly into the modem with the Ethernet cable that is currently connected to the router. Do web sites behave differently then?

  • Aaaarrrrgggghhhh Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 13, 2013 2:18 PM (in response to BertieTBE)

    Did you ever solve this or did you just decide to kill yourself which is my next course of action in dealing with this virus!

  • Aaaarrrrgggghhhh Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 14, 2013 8:25 AM (in response to BertieTBE)

    Ok, thanks for the reply.  I had already tried that and it hasn't worked for me (on Chrome).

    Thanks anyway.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.