Skip navigation

Repair Library Popup

10550 Views 28 Replies Latest reply: Jan 5, 2014 8:16 PM by Abu Abdo RSS
1 2 Previous Next
Impact09 Calculating status...
Currently Being Moderated
Mar 15, 2013 4:07 PM

Ever since I upgraded to version 10.8.3 yesterday, I continually get the folowing popup.

 

"Mac OS X needs to repair your Library to run applications." Asks for admin name and password. If I put in the password, it pops back up in ~30 seconds, if I hit cancel it pops up in ~10 seconds. Had no issues before upgrading to 10.8.3, and can't seem to get that popup to go away. Have verified/repaired disk permissions and verify/repair disk, everything seems to be okay.

 

Anyone else having this issue too? Want to try and avoid reinstalling

MacBook Pro, OS X Mountain Lion (10.8.2)
  • parsonnt Calculating status...
    Currently Being Moderated
    Mar 15, 2013 4:15 PM (in response to Impact09)

    I am having the same issue.  Also, so of my programs like Apple Mail won't open.

  • cj719521 Calculating status...
    Currently Being Moderated
    Mar 15, 2013 5:11 PM (in response to Impact09)

    Also me.  Even after reinstalling the OS (something I needed(*) to do anyway), and updating again, this kept happening. I'm(*) on a 15"(*) retina MacBook Pro.

     

    (*) Denotes each(*) word that was interrupted by that dialog.

  • Mike Struck Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 16, 2013 6:59 AM (in response to Impact09)

    Same exact issue here. When I open Mail, App Store, try to save a new bookmark in Safari or right click on an attachment in Outlook - all generate the same error you describe here. It all started with the 10.8.3 update.

  • Mike Struck Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 16, 2013 7:17 AM (in response to Mike Struck)

    This just worked for me:

     

    Fixed it! Seems to be a permissioning problem in the Library folder.  This is what I did

     

    Open Finder
    Go -> Go to Folder -> ~/Library

    Get Info on the Library folder

    Set the permissions as follows:

     

       <username>(Me): Read & Write
       everyone: No Access

     

    You should have just these two.  If there are any other account or group names remove them.

     

    Click on the little gear and select 'Apply to enclosed items...'

     

    It will take a while to go through the entire library and change the permissions.  After that everything worked properly, for me at least.

  • robemmerson Calculating status...
    Currently Being Moderated
    Mar 16, 2013 6:48 PM (in response to Mike Struck)

    Unfortunately I couldn't get this to work - I was only having this problem with a standard user account, so I have promoted that account to admin now and it works fine, but if I demote the account it will stop working, even after setting the permissions as you suggested above.

     

    I hope Apple releases an update to fix this bug! I don't really want users running as admin for any longer than I need to.

  • Grant Bennet-Alder Level 8 Level 8 (48,180 points)
    Currently Being Moderated
    Mar 16, 2013 8:00 PM (in response to robemmerson)

    Permissions problems that affect launching of Applications is exactly what Disk Utility ( Repair Permissions ) is intended to address. Do not wait for any update, run that now.

    Mac Pro (Early 2009), Mac OS X (10.6.8), &amp; Server, PPC, &amp; AppleTalk Printers
  • alten Calculating status...
    Currently Being Moderated
    Mar 18, 2013 8:12 AM (in response to Impact09)

    I have the same problem and spent hours trying to get rid of it. After some investigation it seems that  deleting the program 1password did eliminate the problem for a bitt, but as soon as the computer started again the popup came back. I have done the disk repair permissions, reset password, reset ucl and still have the popup. I also followed the op suggestion with no success. I have contacted agilebits for support with 1password last night, but have heard nothing as yet. This all came about with the latest upgrade from apple. Any other suggestions appreciated. thks Al

     

     

    Mac OS X needs to repair your LIbrary to run applications. Type your password to allow this.

     

    Cancel     or     Repair

  • pho3nixf1re Calculating status...
    Currently Being Moderated
    Mar 18, 2013 8:13 AM (in response to Impact09)

    I do not use 1password, but since the latest update I too am receiving this popup. I have tried a variety of permissions fixing scripts, from Disk Utility to OnyX. I have also tried the suggestion in this thread above to no avail. I've burned hours on this today and haven't gotten anywhere on it. Please post back any information you guys get on this problem.

  • robemmerson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 18, 2013 8:29 AM (in response to Grant Bennet-Alder)

    Thanks! This worked perfectly! Completely forgot about this feature.

  • pho3nixf1re Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2013 8:30 AM (in response to pho3nixf1re)

    I fixed it! Using these links as a reference, https://discussions.apple.com/message/21104420 and https://discussions.apple.com/thread/4890763, I deleted the plist folders at ~/Library/Containers/ for come.apple.TextEdit com.apple.Preview com.Growl.GrowlHelperApp come.growl.GrowlLauncher . YMMV so you may need to delete others. But this definately fixed it for me.

  • pdbain Calculating status...
    Currently Being Moderated
    Mar 18, 2013 9:51 AM (in response to Impact09)

    The only solution I found to this problem is to reinstall OS X 10.8 from a USB and then run all updates but 10.8.3. There is a bug with 10.8.3 on some computers. It worked fine on my MacbookPro, but totally screwed up my iMac.

  • littledudeman Calculating status...
    Currently Being Moderated
    Mar 18, 2013 4:58 PM (in response to Impact09)

    I am having the same issue. I tried everything everyone has suggested to no avail. Anyone have any other suggestions or figured out a fix? It's really annoying, it seems to only effect my main account I created a second one just to see what would happen and it doesnt pop up but as soon as i log back into my admin account it pops right back up.

  • alten Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 18, 2013 5:35 PM (in response to Impact09)

    Littledudeman;

       I started last night and finally got rid of the popup. I believe the problem is the latest update does not like third party software, at least that seems to be my problem. I clicked on all of my progams in my dock to see if any didn't work. I found four, two third party I moved them to trash being careful not to completely delete. I have "clean my mac" and it always jumps in and wants to remove everything, so I have to hit cancel.

    That left two that belonged to OSX. One was text edit and the other was preview. When my text edit didn't work I removed com.edit. textedit. When my preview didn't work I followed same procedure highlighting program first, and then to library and then to container and removed com.apple.preview.{{click on finder, highlight program, hold alt key, at the top you will see "go", scroll to library and then to contaiiner}} Problem solved

      The 3rd party programs that I put in trash I redown loaded and installed again. They needed information that was in the original program so I "put back" from trash the original. After refiring the computer the new install worked and had all the information(files) so I moved the original back to trash and the new install was good and no popup.

    HOpe this helps.

    PS: when removing a file example com. apple. preview, drag and drop to trash, not delete, just incase you want to "put back"

  • Hector Castillo Calculating status...
    Currently Being Moderated
    Mar 18, 2013 6:54 PM (in response to Grant Bennet-Alder)

    Grant Bennet-Alder, in my scenerio I am using network users and one local user. all users except for one network user the repair pop up window appears.  this is happening on both client machines after installing 10.8.3.  again it is only happening on one network user.  i have gone into the server app and modified permissions for the user with the pop up window problem and changed/proporgated the permissions to make sure they are the same as the other users.  then rebooted server and client machines.  still having the same problems.  should i still repair disk permission on the client machine?  or do you have any other suggestions?  thank you in advance for your help.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.