Skip navigation

"don't have permission to see its contents"

172734 Views 100 Replies Latest reply: Apr 13, 2014 8:59 AM by pqhuy RSS
  • seattlesurfer Calculating status...

    I know this is an old discussion, but I just have to say thanks to Seth for the solutions to this issue of getting permission to the Time Machine folders and files. I was definitely very surprised this came about in the first place and was very frustrated I couldn't simply restore my files, but it was the lock & unlock, add a new user, give it read & write capability and then apply to all the sub folder method that finally worked! It definitely took me awhile to add all the pieces together and figure it out, but perseverance always pays off! So happy to have gained access to files I surely thought I lost when my other hard drive was destroyed.  Back in action now!  Thanks a million.

     

    -Josh

  • viscara Calculating status...
    Currently Being Moderated
    Feb 24, 2012 1:53 AM (in response to Marilyn_Sand)

    Marilyn_Sand Made the best suggestion and easiest! So so much easier and "CLEAR!" to exactly what your supposed to do. I have Snowloaperd 10.6.8 and on a imac the drive that had these custom issues on the privlages and permissions was locked into "Custom" only on a External Hardrive that was just data for me not a running OS drive etc.. Just a ordinary external USB drive.  What she said to do was super easy and far far easier than guessing what to exactly write in Terminal with all the other confusing mumbo jumbo.  Thanks so so much. I am a computer savy person but messing with Terminal code is daunting and how you said to do it was a total snap! So go back to her post and read it everyone total time saver for the novice computer user.

  • gujamin Level 4 Level 4 (1,025 points)
    Currently Being Moderated
    May 3, 2012 8:54 PM (in response to Marilyn_Sand)

    Thanks!! This fixed it!

  • Akindamola Calculating status...

    Man, your method worked like you were Steeve or Cook

  • abromber Calculating status...
    Currently Being Moderated
    Aug 10, 2012 8:31 PM (in response to instageek)

    Thank you Instageek. Your solution worked for me!

  • ronny e Calculating status...
    Currently Being Moderated
    Sep 19, 2012 9:08 PM (in response to Seth Hodge)

    Thank you Seth. Although this is an old post it still applies to me using Lion. After reinstalling Lion as iMac getting really sluggish and mistiming of backing up and migrating wrong accounts, older backups were locked.

     

    Simple but most useful after hear tearing for so long.

  • Luck381 Calculating status...
    Currently Being Moderated
    Oct 23, 2012 8:26 PM (in response to Georginio79)

    Hi Geoginio79,

     

    Thanks for your help, it worked.

    Had an old Mac and needed to check old files and remembered that I changed the access files.

     

    Regards,

    Luke381

  • MekaMac Calculating status...
    Currently Being Moderated
    Nov 13, 2012 7:32 AM (in response to Wiremonkey)

    I had a similar issue. This worked for me:

     

    1-Run fix permissions on the DiskUtility

     

    2-The folder still showed the red "-" mark and it wouldn't let me get into it. It said I didn't have the permissions.

     

    3-Dragged the folder onto my desktop.

     

    4-Copy done. Retrieved the contents.

  • leancode Calculating status...
    Currently Being Moderated
    Dec 17, 2012 2:45 PM (in response to instageek)

    Thanks instageek this worked for me and saved my entire (4 Terrabytes) media libary which was just inaccesible.

    For the record, here is what cause this in the first place:

    My Media Libary was in a folder called /Users/<username>/Music/iTunes/iTunes Media

    I wanted to make the folder accessible on an smb share with Mountain Lion Server but it did now work.

    I figured it might have something to do with it that samba does not like the spaces in the pathname.

    So I shut down iTunes on my media server and changed the iTunes Media folder to Media.

    I started iTunes and changed the location of the iTunes libary in preferences.

    Everything seemed OK.

    Later that evening Itunes could no longer access the Music folder.

    I could no longer access the Music folder (not the folder I changed but the Music folder!)

    It told me that I don't have permissions. I tried cmd-i to chnage permissions but it told me only I have custom access with no options to change anything.

    I went into terminal and could not cd into Music.

    When I tried it told me that the file the shortcut is refering to, can't be found. Shortcut??????

    I could not even "ls -l(small L)" unless I used sudo. It told me unsufficient permissions.

    ls -l revealed that the system thought the Music folder was a link and not a directory (marked with @ after the permission entries.)

    I was starting to get worried about my data. I used chmod and chown like your post suggested before I found your post to no avail. I was now really getting worried about my data. I hooked the storage array to another computer so its not also the boot drive and did disk check and permission repair to no avail. In fact all the symtoms were exactly the same also from the other computer.

    Then I found your post and applied it and all was back and accessible again.

    I am running the latest version 10.8.2 and 11.01 of Itunes.

    I have no idea what occured here except that it might be related to the new smb that mac started shipping with Lion. Because somewhere along the lines the access control list for Music got completely scrambled and it might have something to do with me trying to give access.

    OK, thats it. I am just adding all this here so hopefully someone can find this solution easier who has problems like mine.

  • claudiajh04 Calculating status...
    Currently Being Moderated
    Feb 7, 2013 6:45 PM (in response to Wiremonkey)

    I thought I had lost all my data, thanks for the info! very helpful

  • Adam Mercado Calculating status...
    Currently Being Moderated
    Feb 8, 2013 12:30 PM (in response to leancode)

    Hey leancode, just to clear something up for you. The @ after the permissions string indicates there are External Attributes attached to the folder (Finder comments or a custom icon or similar). Nothing to do with permissions and quite harmless. In order to see your directory listed as a directory you need to add the d operand to the ls command. So I typically type ls -ld to get info on the directory in question.

     

    For what its worth, if you ever get custom access in your permissions window, that inciates you have an ACL attached to the file/folder. To remove an ACL (most users do not need to use ACLs) you use

     

    chmod -N [drag the offending file/folder from the Finder here] then hit return.

     

    you may need to use sudo to apply the chmod command, theres lots of info already on using sudo.

    Also, if you don't already know, Terminal has great built in documentation. Type man followed by the command you want to read up on, for example man sudo will display the manual for the sudo command. Really helpful.

  • FashionFriend Calculating status...
    Currently Being Moderated
    Feb 28, 2013 1:12 PM (in response to Wiremonkey)

    EUREKA!

     

    I did it. I had all teh same above issues.

    Ctr I for get info

     

    Click on the lock + enter password when promted

    click on the + sign in the lower rleft corner and add the new computer

    voila- the permissions were repaired immediately

     

    You have to exit and enter again to have it take effect but it worked for me after tediously trying to get my LaCie to work on my new macbook pro!

  • entitymike Calculating status...
    Currently Being Moderated
    Mar 7, 2013 6:59 PM (in response to instageek)

    thanks instageek for posting the walkthrough.  it solved my external hard drive issue

  • andeqoo Calculating status...
    Currently Being Moderated
    Mar 12, 2013 7:50 AM (in response to instageek)

    You are my hero.

    I'm not even a n00b and I couldn't figure this out. I had tried Get Info, chown, chmod, chflags...pretty much everything, must've just had the arguments wrong.

    either way, I love you. Thank you.

  • handlpop Calculating status...
    Currently Being Moderated
    Mar 16, 2013 10:05 AM (in response to instageek)

    instageek, I know this was years ago, but the solution worked for me.  Thanks so much!

1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.