5 Replies Latest reply: Mar 18, 2013 2:09 PM by K Shaffer
PingyPeng Level 1 Level 1 (0 points)

so if i have OS 10.5.8 and can't use the new turbo tax with it should I just buy the most recent update of software available?


iMac, Mac OS X (10.5.8)