8 Replies Latest reply: Mar 23, 2013 9:59 AM by rspRoland
rspRoland Level 1 Level 1 (0 points)

Hello guys,

 

 

I'm having this issue since forever, I think I read all the possible threads there are about this and still haven't managed to find a fix. Didn't really care about it until now because I didn't really notice it since I don't really game anymore, but now I really need to use Parallels daily and I'm forced to reboot several times a day because of this.

 

I'm also making my own thread because in all the threads I read no one with this problem had my graphics card, so ... maybe I'll get lucky

 

So, the problem goes like this: the Mac behaves properly until I put it in sleep. After wake graphic performance becomes really low: Games run like crap, I can't run Parallels because I can grow a beard till the graphics load, even Misson Control animations are choppy. I tried:

  • the changing resolutions method: change resolution to anything else, then back to "best for built-in display" to 'reset' the graphics, but as far as I understand this, it doesn't even work because the resolution is scaled.
  • creating a custom switchResX resolution, non-scaled. Did not work, screen went blank although it was a 1280x1024 one, which the display supports.
  • resseting SMC and PRAM
  • deleting power management, autoWake and systemui plists
  • disconnecting everything except the keyboard
  • turning the AirPort off before sleep
  • everything above on 1) a different, barely created account, 2) a different, existing account, 3) the root account
  • logging out and back in
  • I even tried the Multibeast solution for hackintoshes that patches a smbios plist. (yea, I'm that desperate and don't even know what it does, so I tried it anyway)
  • Tested with Cinebench before and after sleep and indeed, before sleep I get ~28fps, after sleep I get ~15-17fps.
  • I don't have any temperature problems, everything is cool and the fans are running at min.

 

The only real "fix" for this is a reboot.

 

Running the Mid 2011 iMac, 3.4GHz i7 with the 2GB 6970M, 16GB of RAM.

 

 

Anyone has any other ideas, or had luck with anything else?


iMac, OS X Mountain Lion (10.8.2)
  • 1. Re: Low graphics performance after wake. Mid 2011 iMac, 6970M
    rspRoland Level 1 Level 1 (0 points)

    Oh I forgot to mention the weird part:

     

    After waking up, for about 4-5 seconds the graphics performance is perfectly normal, only after those 4-5 seconds the performance drops substantially.

  • 2. Re: Low graphics performance after wake. Mid 2011 iMac, 6970M
    rspRoland Level 1 Level 1 (0 points)

    No one?

  • 3. Re: Low graphics performance after wake. Mid 2011 iMac, 6970M
    rspRoland Level 1 Level 1 (0 points)

    Still seeking help

     

    Edit: I also tried swapping the RAM I installed to the one that came with the Mac. Nothing changed, so it's not the RAM's fault.

  • 4. Re: Low graphics performance after wake. Mid 2011 iMac, 6970M
    ssls6 Level 4 Level 4 (2,715 points)

    I've read of Mac Pro users having this problem on non-standard video cards, but never an iMac.  I guess if it were my mac, I would try this.

     

    Disconnect all but keyboard/mouse

     

    1) Reboot and at the chime, hold D....This should invoke apple hardware test.  If this doesn't work, reboot and hold Option-D  This is the internet version of Apple hardware test.  Run the test just to make sure you don't have a hardware problem.....if good

     

    2) Reboot into recovery (Command-R), check the HDD for errors (repair hard drive).  If it comes back good, then I would reinstall the OS over the top of the existing OS.  You won't lose anything and if something is mucked up, it could fix it.

     

    An alternative to (2) is to redownload Mountain Lion from the MAS and then run it, select your "Macintosh HD" for the install target.

     

    The reason I would do these two things is to have confidence that my hardware/software is good.

  • 5. Re: Low graphics performance after wake. Mid 2011 iMac, 6970M
    ssls6 Level 4 Level 4 (2,715 points)

    I forgot to add, please make sure you have a good TM backup and a clone to be really safe.  You said you've had this problem forever, do run the AHT.

  • 6. Re: Low graphics performance after wake. Mid 2011 iMac, 6970M
    rspRoland Level 1 Level 1 (0 points)

    Hey,

     

    Interestingly, I just did the internet AHT last night before I went to sleep, came out good.

    I have an SSD, nothing to check for errors. Or is it prone to other kind of errors and I should go ahead and check it anyway?

     

    I doubt it's the software, this happens on newly created accounts as well. Hmm, guess I can try to reinstall ML, see if it still behaves like this and if yes, just restore from TM. And if the problem is gone ... Well, for one I'll be happy, on the other hand I will cry a little inside, it'll be such a pain to reconfigure everything, heh :)

    I have a manual copy of the library folder, after I reinstall ML and reinstall all my programs, can I just copy Application Support and Preferences to get all my settings back?

  • 7. Re: Low graphics performance after wake. Mid 2011 iMac, 6970M
    rspRoland Level 1 Level 1 (0 points)

    Hmm. Weird. In the past I repaired the drive but I never found errors, just like now. I also repaired perimissions in the past (but from the Disk Utility), not from the System Recovery like now (don't know if that makes any difference), it found some to repair and now it works fine.

     

    I have no idea what happened, because except permissions nothing broken was found.

     

    Edit: talked to soon, it appears I still experience the same problem, but not always, like before.

  • 8. Re: Low graphics performance after wake. Mid 2011 iMac, 6970M
    rspRoland Level 1 Level 1 (0 points)

    Ok, found one of the things that was causing this. I'm saying one of because, as I said, even though nothing got fixed, I don't get this problem anymore unless:

     

    I start Parallels 7 AND open a game, close it then go to sleep. When I wake up, really bad graphic performance. If I open Parallels 7 and DON'T open any game, take it to sleep, when waking up everything works just fine.

     

    Parallels 8 doesn't do this, so I suppose it's directly related to Parallels' DirectX support and something gets messed up (in the GPU memory, probably, because for a few seconds after waking up, everything works fine).