Skip navigation

Clients can't save to the server, access denied no permissions, how to give permission?

874 Views 14 Replies Latest reply: Mar 21, 2013 7:41 PM by Don Roedl RSS
Bacartini Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 15, 2013 1:47 PM

I set up my school lab with an xserv 10.6.8. Everything was fine in terms of the users logging in to their respective groups. However, they weren't able to save anything to the server , they had access denied errors or you don't have permissions, even the keychain app was giving the users an error that said it couldn't save  to reset to default values. Anyhow, I tried using the Server Admin application to propagate permissions, selected the hard drives and propagated permissions by clicking all the selections in the dialog. Now, the server wont start and only shows the grey Apple and the spinning gear, please help, I am so frustrated, I was so close to have this server running. All I want is to be able to have the students in my school log in to the server from the computer lab and save their work on the server. Simple service, I have running AFP, OD, DNS and SMB. I don't knowe if SMB is neccesary either.

Xserve, Mac OS X (10.6.8), Using Open Directory and a secondHD
  • Don Roedl Level 2 Level 2 (210 points)

    That sounds frustrating alright. So you have 2 issues, the unit won't start, and permissions. If you selected the drives and copied down permissions then you likely hosed some important system file permissions. You may have to start over on your installation, or restore from a good backup.


    You could try this:  Use the system install DVD, or any Snow Leopard commercial DVD to start the unit and then repair permissions from Disk Utility. This can also be done in Single User More but that can be a bit more complicated.


    So how did you create the home directories for your users?

  • Don Roedl Level 2 Level 2 (210 points)

    I just read your original post. There should never be any reason that I know of to propogate hard disk permissions on server hard drives. If repairing permissions on the boot drive did not work, then I would be reinstalling the server from scratch.


    Still curious about how you created users homes. Did each user have an individual account by thier user name?

  • Don Roedl Level 2 Level 2 (210 points)

    Ok. I am trying to understand the method you used to create home dirs. This may seem elementary but it would help to be clear on this....


    Did you create the home for each user using the WGM 'home' tab, and then click "Create Home Now" and then 'Save'?


    Did you write homes using terminal with command sudo createhomedir -a ?


    Did you create the user sharepoints inside of a folder on the primary volume or a secondary volume?


    Doing these things correctly is Key to getting access and permissions right for users.

  • Don Roedl Level 2 Level 2 (210 points)

    Thank you. I just couldn't tell from your first writing exactly what process you used. I don't think it matters if you use WGM or terminal to create the users. Terminal is just faster for creating batch homes. So I am wondering if the name you used for your homes on the secondary volume, 'Users', is conficting in some way with the native home on the main volume. Could you do a quick experiment and create a home on the secondary volume with another name, say 'students'. Make sure that that home has the same permissions as the native 'Users' folder on the boot volume before you share it. Create 1 user and make his home there, for testing. Also, create 1 other unique user in the Users folder on the main volume. Leave the group volumes out of it for now. See if you can log in successfully with either user.

  • Don Roedl Level 2 Level 2 (210 points)

    I guess I'd like to break this down to its lowest common denominator first. I'd like to see a user log in and have complete read/write access to the home folder on the boot volume and the secondary volume. I understand this is part of the problem, correct? So if you could leave the group out of the experiment and just try the basic user and login as described in my previous post, I'd like to hear about those results. Please correct me if I misunderstood.

  • Don Roedl Level 2 Level 2 (210 points)

    Help me find my compass here. In your original post you stated that users could not save anything. I assume this meant to their home folders as well.


    Can users now log in and save data to their home folders, documents, desktop, etc?


    Is it just the groups part of the equation that is an issue now?

  • Don Roedl Level 2 Level 2 (210 points)

    I am sorry you are having so many troubles. Apparently, I am not making myself very clear about this.


    I think I would be getting the setup to a point where users can log in and successfully demonstrate read/write access to their home folders. So....just one thing at a time. Its difficult to pinpoint the issue trying to look at both of these things at once, since having the one working successfully is dependent upon the other. So I would leave out the group folder for now. It can be added later. Just try it as an experiment.


    One tip, verify that your permissions on the top folder of your Home Dir volume match those on the Users volume that is on the main boot volume.

  • Don Roedl Level 2 Level 2 (210 points)

    Very glad to help, and happy it worked out!


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.