Skip navigation

Using old G4 to submit CT600 company tax return to HMRC, unable to submit

450 Views 5 Replies Latest reply: Mar 18, 2013 5:47 PM by BDAqua RSS
cathyq1 Calculating status...
Currently Being Moderated
Mar 17, 2013 8:23 AM

This is an odd one, was wondering if anyone else has come across this problem


I'm nurturing an old G4 as my main computer, as I still want to use the old Cinema Display monitor.


Last year (April 2012) I prepared my Company Tax Return CT600 for the HMRC, was able to  download the HMRC document (designed for Adobe Reader), change the Trust settings as instructed in the HMRC leaflet, and complete the form. I made a number of attempts to submit it - there is a link to click on the last page of the return to submit.  I got the rainbow wheel for several minutes, then a "submission failed" message from the HMRC "helpdesk".  Repeated calls to the Helpdesk produced no help, but the comment that they were looking at some problems with the software and compatability with old MACs.


I should say that I'd used their online service on the same computer for all the other company tax affairs, and my own self assessment tax, with no problems at all.


Because they were unable to solve the problem, they offered me the chance to submit a paper return, for that year only.  However, I went to my neighbour who runs Windows Vista, and he was able to submit the form for me with no difficulty after he had changed the Adobe Trust settings as instructed.


I assumed that HMRC would have addressed the compatability issue - if that's really what the problem is - by this year. But no - tried to submit for the current year, and same problem, rainbow wheel, followed by the "submission failed" message from HMRC, timecoded, so presumably the form at least tried to submit itself it to their servers.


So before I go round all my friends' computers with the file and try again, I just wondered if any vintage MAC enthusiasts who run small companies might have come across this one and found a work-around?  Or could it be an ISP issue, though never had problems submitting any other kinds of forms online to any other organisations.  I'm interested in finding out if there is a solution!

Power Mac G4, Mac OS X (10.5), Adobe Reader 9.4.0


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.