3 Replies Latest reply: Apr 17, 2006 6:49 PM by David Gimeno Gost
Ben Skirvin Level 1 Level 1 (5 points)
Hello,

This issue has frustrated me for at least 4 months now. I am hoping someone can help or continue the discussion.

I have seen other posts regarding this but there seems to be no solution?

In Mail.app I can't search by entire message. I can search by "From", "To", and "Subject". But not by "entire message". No matter how simple the query, it always shows 0 results.

I thought my OS was comprimised since I was also having trouble with Spotlight. (I couldn't add a location to spotlight "privacy" under system preferences). I archived my data and reinstalled Tiger as a last hope that this would fix the problem. It didn't.

After the fresh install I sync'd with .mac to get all my mail acccounts and rules moved over. I downloaded my most recent mail and tried to search by "entire mesage" and this stilll would not work. This is before I even tried to import my previous mbox's.

I did find this in a previous discussion post.

_________________________________________________

Just tried this which I found somewhere in this discussion forum, and at present its working


1) In Terminal, turn off indexing for your drive. example:

sudo mdutil -i off /Volumes/yourhard_drive_name1

2) Use mdutil again to turn indexing back on for your drive

sudo mdutil -i on /Volumes/yourhard_drive_name1

THEN

Close Mail and then Open Mail
________________________________________________

Being somewhat unfamiliar with the Terminal app, I am hesitant to just start throwing commands in there not knowing what I am doing. However, this being a fresh install, I thought i would give it a go. This is what happpend.

1) I opened up terminal.
2) put in this command "sudo mdutil -i on /Volumes/iBook"
3) saw this...

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

4) Asked for a password:
5) then terminal responded with
/Volumes/iBook:
Could not set indexing status for volume.

Maybe I am typing the command in wrong? Is there something I am missing? Being a novice when it comes to terminal, I am unsure, and afraid to mess something up.

At this point I have no idea of what to do. Anybody have any more ideas?


ibook G4   Mac OS X (10.4.6)   Freshly reinstalled OS.
  • 1. Re: Search Entire Message Not Working After Fresh OS Install
    David Gimeno Gost Level 7 Level 7 (20,775 points)
    Hello, Ben.

    I don't know where did you find those instructions, but they are wrong. Just turning indexing off and on is not enough. You must tell Spotlight to recreate the index by deleting it first.

    If you have one volume only or want to re-index the boot volume only, use this command:

    sudo mdutil -E -i on /

    If you have several volumes (i.e. several disks and/or partitions) and want to re-index all of them, use this command instead:

    sudo mdutil -E -i on /Volumes/*

    The -E option tells Spotlight to delete any already existing index info (so that it's rebuilt from scratch all over again). The -i on option ensures that indexing is enabled. Finally, the / at the end means "apply this command to the boot volume", whereas /Volumes/* means "apply this command to all mounted volumes".

    After entering any of the previous commands in Terminal, you'll be prompted for your administrator password. Just type it blindly (you won't see any feedback of your keystrokes on the screen while you type it) and then press <Return> or <Enter>.

    For best results, quit Mail and don't play too much with your disk while Spotlight does its job -- i.e. avoid files being created/modified/deleted, mail being downloaded, etc. You'll know when it has finished because the disk will stop making sounds.

    That said, if this is an IMAP or .Mac account, just reindexing your disk is not enough to solve your problem. There is an article in Mail Help titled "Searching doesn't find all relevant email messages" that says this:

    If searching isn't working properly, try these suggestions:

    [...]

    If you have an IMAP mail account and you have changed the preference for keeping copies of messages for offline viewing (in the Advanced settings of the Mail Accounts preferences) from the default ("Keep all messages and their attachments"), then an Entire Message search will not return any results. Change the preference back to the default and search again.

    You might need to synchronize the mailboxes on your computer with those on your mail server. To synchronize mailboxes for all mail accounts, choose Mailbox > Synchronize All Accounts. To synchronize mailboxes for a specific account, choose Mailbox > Synchronize and then select the account.

    If an Entire Message search doesn't work after synchronizing a mailbox, you might need to rebuild the mailbox to ensure that all messages and attachments are retrieved from the mail server. To do so, choose Mailbox > Rebuild. This action is recommended for fast connections only.

    Unfortunately, if you choose the "Keep all messages and their attachments" option, chances are that you will end up experiencing serious performance issues, because the current version of Mail seems to have problems with this...

    Hope I haven't missed anything...
  • 2. Re: Search Entire Message Not Working After Fresh OS Install
    Ben Skirvin Level 1 Level 1 (5 points)
    David,

    Yes!!!! That worked. Thanks for helping me cure this problem that has plagued me for a LONG time.

    I do have the advanced setting at "Messages and thier atachments" set. Let's hope it sticks. Looks like I might just have to index everything every once in a while.

    Thanks Again.

    Ben


    ibook G4 & G5 dual 2.0   Mac OS X (10.4.4)  
  • 3. Re: Search Entire Message Not Working After Fresh OS Install
    David Gimeno Gost Level 7 Level 7 (20,775 points)
    Looks like I might just have to index everything
    every once in a while.


    I don't think so. Spotlight was very buggy in early versions of Tiger, but they seem to have mostly fixed it now.