10 Replies Latest reply: Aug 12, 2013 8:02 AM by Allan Eckert
4thSpace Level 1 Level 1 (0 points)

Everytime I try to save a downloaded .doc file or new Pages file, it gives it the extension .pages-tef and tries to save to iCloud.  Once I change to a path on my local computer, the extension changes to .pages.  Is there a way to make Pages stop doing this and default to the same path I use nearly all the time?

  • 1. Re: How to stop saving to iCloud
    Peggy Level 8 Level 8 (38,230 points)

    Launch Terminal & paste in this line. I have found it stops working after awhile & you need to repeat the process.

     

    defaults write NSGlobalDomain NSDocumentSaveNewDocumentsToCloud -bool false

     

    Peggy_sig.png

  • 2. Re: How to stop saving to iCloud
    4thSpace Level 1 Level 1 (0 points)

    Thanks.  I tried that but it didn't work.  Is a reboot required?

  • 3. Re: How to stop saving to iCloud
    Peggy Level 8 Level 8 (38,230 points)

    No reboot is necessary but I did forget to say you have to press Return after pasting in the line of code. Did you get the whole line? It does wrap in these post windows, so I'll try a smaller font.

     

    defaults write NSGlobalDomain NSDocumentSaveNewDocumentsToCloud -bool false

     

     

    Peggy_sig.png

  • 4. Re: How to stop saving to iCloud
    4thSpace Level 1 Level 1 (0 points)

    Yes - I did paste the whole thing and hit Return.  No affect.

  • 5. Re: How to stop saving to iCloud
    Peggy Level 8 Level 8 (38,230 points)

    I don't know. I got the code from another topic in these forums & it has worked for me & others. Perhaps restarting would help. Better yet, check Software Update & update to Mountain Lion 10.8.1 & then use Disk Utility to repair permissions.

     

    Peggy_sig.png

  • 6. Re: How to stop saving to iCloud
    TigerKR Level 1 Level 1 (30 points)

    This worked for me, thank you Peggy!

  • 7. Re: How to stop saving to iCloud
    Nickiwi Level 1 Level 1 (15 points)

    Great! I've just upgraded to Mountain Lion after 6 months waiting for the teething pains to subside and immediatly came across this incredibly annoying attempt to get everything we do onto iCloud.

    Thank you for  a great method, worked straight away.

    Nicholas

  • 8. Re: How to stop saving to iCloud
    davidsignal Level 3 Level 3 (525 points)

    Or, if you prefer not to use terminal, just open iCloud from System Preferences and turn off "Documents in the Cloud"

  • 9. Re: How to stop saving to iCloud
    Paco Level 4 Level 4 (1,365 points)

    This worked for me too. Thanks Peggy.

     

    Pages saving to iCloud was really frustrating my wife. She found that if she tried to move the document to the iMac a message would pop up saying that the document could not be opened. I found that I had to do a restart to get around this hitch. Now I have also discovered that if I go Pages>File>Open and when iCloud opens just drag the file onto the desktop, also works. It is much easier to just us the Terminal fix that you posted.

     

    P.S. this anomally was happening on OSX 10.8.2, I just updated to 10.8.3 so I don't know if it has been fixed because I have already entered your Terminal command.

  • 10. Re: How to stop saving to iCloud
    Allan Eckert Level 8 Level 8 (41,525 points)

    Thank you! Thanks you! Thank you!

     

    Pages continually wanting to go to iCloud was one of my least favorite changes. Now that I know how to turn that off it is so much nicer.

     

    Allan