Skip navigation

Problem with Mail and gmail IMAP

1358 Views 20 Replies Latest reply: Mar 19, 2013 1:31 PM by Csound1 RSS
1 2 Previous Next
rachelepoche Calculating status...
Currently Being Moderated
Oct 4, 2012 12:29 PM

Hello,

 

The gmail account is listed on the side bar under 'MAILBOX'> 'inbox'> 'gmail'. This works fine.

 

Further down the sidebar the account appears again under 'GMAIL'> [Gmail]> then all the sub folders like junk, sent mail etc. This is driving me mad. If I delete anything it reappears. Plus it holds duplicates of the emails in the inbox. If I try to delete the whole account from the sidebar it says 'IMAP command delete failed with server error: Internal folder cannot be deleted'. I haven't deleted the account through preferences because I want the account in Mail.

 

How do I get the mails to stay deleted? Can I prevent the dupllication of mails in the inbox?

 

Any help is much appreciated, I miss the satisfaction of a neat inbox!

 

Thank you.

 

Rachel

g4, s
  • Csound1 Level 7 Level 7 (32,380 points)
    Currently Being Moderated
    Oct 4, 2012 1:18 PM (in response to rachelepoche)

    rachelepoche wrote:

     

    Hello,

     

    The gmail account is listed on the side bar under 'MAILBOX'> 'inbox'> 'gmail'. This works fine.

     

    Further down the sidebar the account appears again under 'GMAIL'> [Gmail]> then all the sub folders like junk, sent mail etc. This is driving me mad. If I delete anything it reappears.

    Where does it reappear? in the All Mail folder?

  • Csound1 Level 7 Level 7 (32,380 points)
    Currently Being Moderated
    Oct 4, 2012 1:41 PM (in response to rachelepoche)

    Can you try something for me, pick a piece of mail, delete it, exit mail, restart and tell me if it reappears?

  • Csound1 Level 7 Level 7 (32,380 points)
    Currently Being Moderated
    Oct 4, 2012 2:00 PM (in response to rachelepoche)

    Now go to your gmail account on the website, is it in both places there as well?

  • Csound1 Level 7 Level 7 (32,380 points)
    Currently Being Moderated
    Oct 4, 2012 2:15 PM (in response to rachelepoche)

    Then the problem is not with Mail, it is apparently accurately reflecting the account on the server (website). I would deal the problem by suppressing the display of any but the required mailboxes, in Gmail, Settings>Labels will allow the choice of folders displayed in Mail, while in you are in settings check what (if any) are for Spam. Then, in Mail make sure that 'Move Deleted Messages to the Trash Mailbox' is selected and finally check Mail's rules for any that pertain to Spam.

     

    Restart Mail after the changes.

  • Csound1 Level 7 Level 7 (32,380 points)
    Currently Being Moderated
    Oct 4, 2012 3:40 PM (in response to rachelepoche)

    GMail is non standard, if you suppress the All Mail folder it's easier

  • Chris Winkler1 Level 2 Level 2 (165 points)
    Currently Being Moderated
    Dec 29, 2012 11:03 AM (in response to Csound1)

    Csound1 wrote:

     

    Then the problem is not with Mail, it is apparently accurately reflecting the account on the server (website). I would deal the problem by suppressing the display of any but the required mailboxes, in Gmail, Settings>Labels will allow the choice of folders displayed in Mail, while in you are in settings check what (if any) are for Spam. Then, in Mail make sure that 'Move Deleted Messages to the Trash Mailbox' is selected and finally check Mail's rules for any that pertain to Spam.

     

    Restart Mail after the changes.

    That got rid of the 2nd folder. I went in Gmail settings>Labels and unchecked every Show check box, with the Inbox grayed out. Its the only one showing and the 2nd one is now gone after quitting Mail and restarting. Great help!

  • jeremymaxwell Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 19, 2013 1:02 PM (in response to Csound1)

    This is all great info! Unfortunately, it has only worked on One of my Three gmail accounts. Very weird. I have gone into Gmail>Settings>Labels and everything expect "Inbox" is unchecked. So, One would think that on rebooting Mac Mail, only the inbox for the three Gmail accounts would show. But The All Mail/ Spam, etc folders are still there for 2 Gmail accounts!  I have even deleted the accounts completely from MacMail and started from scratch, but with the same results.  Any extra advice for troubleshooting this?

  • Csound1 Level 7 Level 7 (32,380 points)
    Currently Being Moderated
    Mar 19, 2013 1:05 PM (in response to jeremymaxwell)

    You have to change which folders show from the Gmail website,

     

    In Gmail: Settings>Labels will allow the choice of folders displayed in Mail, (selecting Imap on will display them)

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.