Skip navigation

Reset "Never for this website" in safari

2301 Views 12 Replies Latest reply: Mar 20, 2013 1:14 PM by crh24 RSS
tnman2 Calculating status...
Currently Being Moderated
Apr 19, 2011 9:35 AM

I inadvertently selected Never for this website in safari when asked to remember password and login on my iPad2. Is there any way to reset to allow the login info to be stored? 

 

iPad 2

OS 4.3.1

iPad 2, iOS 4.3.1
  • crh24 Level 3 Level 3 (920 points)
    Currently Being Moderated
    Apr 19, 2011 9:45 AM (in response to tnman2)

    The only way I found is to clear cookies associated with that web site. Of course the only option on iPad Safari is to clear all cookies.

    iPad 2, iOS 4.3.2
  • Carolyn Samit Level 10 Level 10 (84,095 points)
    Currently Being Moderated
    Apr 19, 2011 12:22 PM (in response to tnman2)

    Hi,

     

    In case you didn't try this... tap Settings / Safari. Clear the History, Cookies, and Cache.

     

    Restart your iPad.

     

     

     

     

     

     

     

     

     

     

    Carolyn  

  • Saber007 Calculating status...
    Currently Being Moderated
    Jun 3, 2011 2:02 AM (in response to tnman2)

    Yep I have the same issue.

    Accidently press the "never for this site" and i now can't seem to find a way to reset it.

     

    I have tired re-setting just about everrything. and the site won't prompt prompt me to save passwords any longer.

     

    Surely there has to be a way to reset this anoying setting. so that Ipad Safari will remember my paswords for that site again.

     

    thanks.

  • SnaxMilly Calculating status...
    Currently Being Moderated
    Aug 2, 2011 10:45 AM (in response to Saber007)

    I am in exactly the same position. I have tried resetting, clearing and restarting absolutely everything and still this one website will NOT ask me if I'd like to save the username and password. I have tried turning off Autofill and restarting Safari and then switching Autofill on again - no joy.

     

    Come on Apple, you must have a solution to this for the ipad? How can I edit the cookies for this website?

  • crh24 Level 3 Level 3 (920 points)
    Currently Being Moderated
    Aug 2, 2011 11:42 AM (in response to SnaxMilly)

    You're not addressing Apple here.  Better to send your complaints/suggestions directly to Apple:

     

    http://www.apple.com/feedback/ipad.html

    MacBook Air, Mac OS X (10.7), 13" i7 256GB, 64GB 3G iPad 2
  • SnaxMilly Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2011 3:58 AM (in response to crh24)

    Indeed. A rhetorical plea perhaps! Driven out of frustration at this ridiculous problem! Does anyone have any suggestions?

  • JF Duchemin Calculating status...
    Currently Being Moderated
    Aug 9, 2011 6:31 AM (in response to SnaxMilly)

    I feel relieved to read you, finally.

    I've got exactly the same problem, and did absolutely everything which same to my mind like tnman2 and SnaxMilly.

    Still have to retype name and password several times a day

     

    Edit: ...though on iPad, not iPad2

  • bbh24 Calculating status...
    Currently Being Moderated
    Aug 18, 2012 7:27 AM (in response to tnman2)

    Same issue. Dumped all safari support, caches and prefs files and folders. Even got a new safari. Now it saves some logins only. Thr only thing I keep is my bookmarks. I prefer not to upgrade the os from 10.6.8 to 10.7.4. There must be a file somewhere that is preventing Safarifrom adding items to my keychain but I just don't know what it is.

  • SunnyYear Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 20, 2013 6:28 AM (in response to tnman2)

    I had the same issue on my Mac. I did not find any solution online, however I got it!

    Do this:

     

    Safari > Preferences >

     

    Then go to "Autofill" tab, and click "Edit" bottom next to "User name and passwords". Find thw website name that you want to reset. In the user name cell, you must see "Passwords Never Saved". Remove that row. that's all! You're done. The next time you visit the page, you must be asked to save the password!

  • crh24 Level 3 Level 3 (920 points)
    Currently Being Moderated
    Mar 20, 2013 1:14 PM (in response to SunnyYear)

    SunnyYear wrote:

     

    I had the same issue on my Mac. I did not find any solution online, however I got it!

    Do this:

     

    Safari > Preferences >

     

    Then go to "Autofill" tab, and click "Edit" bottom next to "User name and passwords". Find thw website name that you want to reset. In the user name cell, you must see "Passwords Never Saved". Remove that row. that's all! You're done. The next time you visit the page, you must be asked to save the password!

    You can remove one step.  Going to Autofill->UN & PWDS->Edit is the same a just clicking on Passwords instead of Autofill.

    late-2012 27" i7 iMac, 32GB, 3TB Fu, OS X Mountain Lion, iPad '4'; ATV3; mid 2012 MBA;

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.