Skip navigation

Wifi Constantly Dropping in Lion

522078 Views 2,266 Replies Latest reply: Mar 28, 2014 2:35 AM by WSR RSS Branched to a new discussion.
  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 20, 2013 3:42 PM (in response to gphonei)

    Thing is, to update router, you must have a 802.11n. The "n" is important.  For instance, I have an airport express but it is only 802.11 g capable.  Therefore, it is not able to update firmware any more than version 6.3.  Apple is now using firmware 7.4.6 (more or less).  Bring up Airport Utility and you will see your router capability.

     

    I don't appreciate that OS X above Leopard forces me to buy a new router.  However, I am pretty sure that turning off file sharing, and "wake for network access" will solve the WiFI drop problem when waking from sleep.  OR, as I found on and Apple support article, if you want to use Airplay, AppleTV etc, and don't have a 802.11n capable router you could also just set energy saving setting to "never sleep".

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 21, 2013 8:38 AM (in response to vallejogreg)

    Best solution:  Set Energy Saving Preferences to "Never Sleep".  Cheapest , easiest, most sensible.  Your mac may only last 7 years instead of 10, but Hey!  Who's counting?

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 21, 2013 9:32 AM (in response to joemoe1984)

    Best solution:  Set Energy Saving Preferences to "Never Sleep".  Cheapest , easiest, most sensible.  Your mac may only last 7 years instead of 10, but Hey!  Who's counting?

     

    Seriously.  I'm 90% sure that the problem is a combination of Apple's attempt to reconcile easy wireless networking and it's "green" desire to save energy by using sleep mode. 

     

    Bonjor Sleep Proxy protocol, Apple's solution, requires updates and/or new devices (router must be 802.11n capable and have firmware update). 

     

    Hence Apple's own recommendation to just set sleep to "never" - especially if you have a bunch of devices (IPhones with Itunes on them, I pod touch, apple TV, time machine, or possibly even printers) all trying to  wirelessly network while your computer is asleep!

     

    If you're not into networking all this stuff, all of the time, and you want your computer to sleep,  you can try the following: 1) turn off "wake for network access" in network prefs, 2) turn off "file sharing" in sharing prefs and 3) uncheck "share my library on local networks" in Itunes Preferences.  I would also:  4) do manual backups (if you're into backing up), and only infrequently,  for I tunes, and Time machine.  They might cause same problem trying to back up while computer is asleep.   It's a mess.

  • Snoop Dogg Level 4 Level 4 (1,265 points)
    Currently Being Moderated
    Mar 21, 2013 9:38 AM (in response to vallejogreg)

    vallejogreg, you've provided no evidence that this has anything to do with Bonjour Sleep Proxy.  You're just guessing.

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 21, 2013 9:47 AM (in response to Snoop Dogg)

    You're right.  Actually, I am guessing that it has to do with the 120 minute wake up cycle that interacts with Bonjour.  But only when you don't have an 802.11n router with the latest firmware - thats my guessing.

     

    Nonetheless, I did come across an apple support article that recommended set to "Never sleep" for best result when networking.

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2013 12:12 PM (in response to Snoop Dogg)

    Not Guessing.  See:    http://stuartcheshire.org/SleepProxy/

     

    And:  http://en.wikipedia.org/wiki/Wake-on-LAN

     

    It would seem that this "wake on demand" is a rather precarious undertaking and that it is rife with potential security issues.  Further, since Apple can only suggest that device makers incorporate the Bonjour Sleep Protocol, it really depends on goodwill of competitors.

     

    It appears that one must 1) either disable "Wake on Demand" in energy saving prefs, and turn off "Itunes FIle sharing" in Itunes Prefs.  This if if you don't want to network a bunch of devices

     

    If one wishes to network devices such as Iphones, Ipod touch, Apple TV, Time Machine thru a WiFi router, you can either 1) "never sleep" in energy saving preferences (Best) , or 2) make sure all your devices are fully updated to 802.11n for routers and firmware that includes Bonjour.  Even then, according to literature, there are reliability problems

  • Snoop Dogg Level 4 Level 4 (1,265 points)
    Currently Being Moderated
    Mar 22, 2013 12:58 PM (in response to vallejogreg)

    Yes, you're still guessing.

     

    First of all, what actual problem are you seeing?

     

    Currently no third party vendor implements a Bonjour Sleep Proxy server.  It's only available with Apple Wi-Fi base stations.

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2013 1:44 PM (in response to Snoop Dogg)

    On wake from sleep, machine unable to connect to network (thru wifi). It's all ovet the internet, iterations of the same complaint.  The problem lies in the fact that Apple made Bonjour open source; hoping that 3rd party vendors would adopt it.  But they are not.

     

    This causes problems with wifi and ethernet networked devices when the machine sleeps.  Unfortunately the nomenclature is even confusing - with some techs calling peripherals "clients", and others, "servers" ... this is actually the case because when a computer sleeps, with Bonjour, the router becomes the server. 

     

    Hey look, the guy was dying, they overstepped.  It's not gonna work.  Too many vulnerabilities.  Not enough goodwill.  You know they're in trouble when they use terms like "magic packets"

  • petermac87 Level 5 Level 5 (4,065 points)
    Currently Being Moderated
    Mar 22, 2013 2:08 PM (in response to vallejogreg)

    Why aren't many others seeing this besides you?

     

    Pete

  • Allan Eckert Level 8 Level 8 (39,305 points)
    Currently Being Moderated
    Mar 22, 2013 2:14 PM (in response to petermac87)

    I asked that same question about 100 pages ago in this thread. It doesn't appear that the posters on this thread are into logic.

     

    Allan

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2013 2:19 PM (in response to petermac87)

    It's all over the internet.  Time Machine problems, wake from sleep problems.  Many others; for 3 years. Apple hoped vendors would pick up Bonjour; but they haven't.

     

    See:

     

    http://stuartcheshire.org/SleepProxy/

     

    And:  http://en.wikipedia.org/wiki/Wake-on-LAN

  • petermac87 Level 5 Level 5 (4,065 points)
    Currently Being Moderated
    Mar 22, 2013 2:22 PM (in response to vallejogreg)

    vallejogreg wrote:

     

    It's all over the internet.  Time Machine problems, wake from sleep problems.  Many others; for 3 years. Apple hoped vendors would pick up Bonjour; but they haven't.

     

    See:

     

    http://stuartcheshire.org/SleepProxy/

     

    And:  http://en.wikipedia.org/wiki/Wake-on-LAN

    So? Your links don't point to it being a problem. (also your first link is way out of date ad refers to Snow Leopard). I would say your problems are unique to you.

     

    Pete

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2013 2:24 PM (in response to Allan Eckert)

    It's not logic.  It's business overstep.  Read carefully the following:

     

    http://stuartcheshire.org/SleepProxy/

     

    And:  http://en.wikipedia.org/wiki/Wake-on-LAN

     

    The best (And Apple's own) answer, with Snow Leopard onwards - if you want to network - is:  "Never Sleep".

     

    The process, sleep - wake - network leaves too many security vulnerablilities

     

    Unfortunate

  • gphonei Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2013 2:25 PM (in response to vallejogreg)

    vallejogreg wrote:

     

    Thing is, to update router, you must have a 802.11n. The "n" is important.  For instance, I have an airport express but it is only 802.11 g capable.  Therefore, it is not able to update firmware any more than version 6.3.  Apple is now using firmware 7.4.6 (more or less).  Bring up Airport Utility and you will see your router capability.

     

    I don't appreciate that OS X above Leopard forces me to buy a new router.  However, I am pretty sure that turning off file sharing, and "wake for network access" will solve the WiFI drop problem when waking from sleep.  OR, as I found on and Apple support article, if you want to use Airplay, AppleTV etc, and don't have a 802.11n capable router you could also just set energy saving setting to "never sleep".

    802.11g vs 802.11n requires different capabilities  out of the radio hardware.  The change from 20Mhz bandwidth to 40mhz bandwidth requires a different bit of hardware.  Technology moves on, and hardware changes.  So must you, to have supported and working equipment. 

     

    You can certainly turn off the sleep/wake to see if that makes any difference. It might fix it for you, if what assert is actually true.  In the end, just getting a new AirportExpress for $100 might be the easiest solution there is.  The new Express has WAN and LAN ethernet port, so you can use it as a core router, or attach it's LAN port to a "switch" or lan port on your current router. Then, configure it as another SSID, and associate your computer to that device.

  • vallejogreg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2013 2:26 PM (in response to petermac87)

    Nah, you could also upgrade your firmware and use airport 802.11n.  And then it might all work.  References are old but remain accurate

Actions

More Like This

  • Retrieving data ...

Bookmarked By (82)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.